Comment 26 for bug 773524

Daniel Manrique (roadmr) wrote :

Hi Manoj,

I tried the stock Oneiric kernel on my Natty R850 and it doesn't work, shows error -110 whilst initialising. I tried several Kingston 1GB cards and a 128-MB one.

However the kernel you posted (3.0 with apparently some changes) does work, just as if the PCI commands from #13 had been issued, which so far is the only other way I've gotten the R850 reader to work.

I tried with several Kingston 1 GB cards (the ones I normally use) and the 128-MB card I had lying around, all worked fine.

they say this:

[ 372.373594] mmc0: new SD card at address b368
[ 372.374011] mmcblk0: mmc0:b368 SD 970 MiB
[ 372.375710] mmcblk0: p1

I even tried one with a borked partition table (doesn't work, but at least the kernel sees it):
[ 381.900701] mmc0: new SD card at address b368
[ 381.901092] mmcblk0: mmc0:b368 SD 970 MiB
[ 381.905208] mmcblk0: unknown partition table
[ 385.744511] mmc0: card b368 removed

Let me know if you need some more info on this.