Ubuntu

[Dell E4310 201103-7379] Fails to resume from hibernate

Reported by Jeff Lane on 2011-04-28
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
Won't Fix
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

During cert testing on the E4310, suspend works fine. However, while the system does hibernate, it fails to resume.

When it runs the suspend test, it goes to sleep and wakes itself automatically. When it hibernates, it hibernates, but does not wake. Once I push the power button to wake the system, it gives me a grub screen with no timeout set. Once I hit enter on the right entry to boot the system, it boots fresh, it does not resume the previous session.

This system is marked Enabled for 10.10, and in that submission, the hibernation test is marked as PASS.
https://certification.canonical.com/hardware/201010-6654/submission/22f2Mg8PGpQS2rB/result/test:hibernate_once:sleep

*note that is a different physical system, but they are both Latitude E4310s
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1322 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x55460000 irq 43'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:111d7605,10280410,00100104 HDA:80862804,80860101,00100000'
   Controls : 19
   Simple ctrls : 11
DistroRelease: Ubuntu 11.04
HibernationDevice: RESUME=UUID=2055bf68-8235-4890-84f1-2afe10a5614d
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
Lsusb:
 Bus 002 Device 003: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications Processor
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Latitude E4310
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=ad8bf604-ba38-4c0e-84cd-86bbfde9d11a ro quiet splash initcall_debug vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
StagingDrivers: brcm80211
Tags: natty running-unity staging
Uname: Linux 2.6.38-8-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/20/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 0WVD33
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd11/20/2010:svnDellInc.:pnLatitudeE4310:pvr0001:rvnDellInc.:rn0WVD33:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E4310
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.

Jeff Lane (bladernr) on 2011-04-28
tags: added: blocks-hwcert regression
Jeff Lane (bladernr) on 2011-04-28
affects: hw-labs → linux
Ara Pulido (apulido) wrote :

Jeff, can you run apport-collect 772766 on that system?

Changed in linux (Ubuntu):
status: New → Incomplete
Jeff Lane (bladernr) on 2011-04-29
tags: removed: regression
Ara Pulido (apulido) wrote :

Chris, this is an enablement system that failed certification for 11.04, can you have a look, please?

Changed in linux (Ubuntu):
assignee: nobody → Chris Van Hoof (vanhoof)

apport information

tags: added: apport-collected natty running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Jeff Lane (bladernr) on 2011-04-30
Changed in linux (Ubuntu):
status: Incomplete → New
Ara Pulido (apulido) on 2011-05-02
Changed in linux (Ubuntu):
importance: Undecided → Medium
Brad Figg (brad-figg) on 2011-05-03
Changed in linux (Ubuntu):
status: New → Confirmed
tags: removed: blocks-hwcert
Chris Van Hoof (vanhoof) on 2011-06-01
Changed in linux (Ubuntu):
assignee: Chris Van Hoof (vanhoof) → nobody
tags: added: hibernate needs-upstream-testing

Jeff Lane, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please provide the information following https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume ? As well, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux:
status: New → Won't Fix
Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers