8086:2a42 [eMachines E725] My backlight is off

Bug #772050 reported by Lucas Clemente Vella on 2011-04-27
70
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I just updated to Ubuntu 11.04 Beta to find that the backlight of my monitor is off (or very low) and I can't turn it on.

The backlight intensity control never worked on any previous version of Ubuntu (the Fn key controls responded, and changed a bar on screen, but never really changed the backlight). The Fn key On/Off worked before. In the new kernel, the backlight is off (or very low) by default and the controls does not work, so I can't turn it on.

Now I am using the old 2.6.35-28-generic kernel to report this bug.

BIOS update http://support.gateway.com/us/en/emac/product/default.aspx?modelId=1258

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272X Analog [ALC272X Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272X Analog [ALC272X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lucas 1822 F.... pulseaudio
 /dev/snd/pcmC0D0p: lucas 1822 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd6700000 irq 45'
   Mixer name : 'Realtek ALC272X'
   Components : 'HDA:10ec0272,10250212,00100001'
   Controls : 15
   Simple ctrls : 9
Date: Wed Apr 27 18:33:25 2011
HibernationDevice: RESUME=UUID=3e3ff916-ea57-411c-81e3-43861b6b198d
MachineType: eMachines eMachines E725
ProcEnviron:
 LANGUAGE=pt_BR:en
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: root=UUID=2cdcad63-4a14-4e12-9cd4-bf10a0d49acd ro locale=pt_BR quiet splash crashkernel=384M-2G:64M,2G-:128M
RelatedPackageVersions:
 linux-restricted-modules-2.6.35-28-generic N/A
 linux-backports-modules-2.6.35-28-generic N/A
 linux-firmware 1.52
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-04-27 (0 days ago)
WpaSupplicantLog:

dmi.bios.date: 03/11/2009
dmi.bios.vendor: eMachines
dmi.bios.version: V1.03
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: eMachines E725
dmi.board.vendor: eMachines
dmi.board.version: V1.03
dmi.chassis.type: 1
dmi.chassis.vendor: eMachines
dmi.chassis.version: V1.03
dmi.modalias: dmi:bvneMachines:bvrV1.03:bd03/11/2009:svneMachines:pneMachinesE725:pvrV1.03:rvneMachines:rneMachinesE725:rvrV1.03:cvneMachines:ct1:cvrV1.03:
dmi.product.name: eMachines E725
dmi.product.version: V1.03
dmi.sys.vendor: eMachines

lspci info with sudo:

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
 Subsystem: Acer Incorporated [ALI] Device 0212
 Flags: bus master, fast devsel, latency 0, IRQ 44
 Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
 Memory at c0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at 50f0 [size=8]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
 Capabilities: [d0] Power Management version 3
 Kernel driver in use: i915
 Kernel modules: i915

Samuel Cruz (silverpt) wrote :

This is not a Ubuntu bug.

Other distros, with the same 2.6.38 kernel are afected too, so this is a kernel bug.

Well, that is exactly why it was reported under package "linux". If Ubuntu ships a broken kernel, it is a Ubuntu bug.

@Samuel
As Lucas says, reporting this bug in linux in Ubuntu was appropriate. But you're right too--it should be reported upstream if it hasn't already. And this bug should be linked to the upstream bug report (with the "Also affects project" link near the top of this bug page). Do you know whether or not it's been reported upstream at https://bugzilla.kernel.org? Do you have links to bug reports for this from other distros?

Changed in linux (Ubuntu):
status: New → Confirmed

Hi
Looks like all ACER eMashines has the same problem
The same happend to me and i´m on a Acer eMashines g525

I have the same Intel Corporation Mobile 4 Series Chipset on my Gateway NV78 laptop. Had to perform a kernel downgrade to 2.6.35-28 to get things working. I'm guessing I've got the same issue.

delance (olivier-delance) wrote :

I have found this http://ubuntuforums.org/showthread.php?t=1744809 . I don't know if it can interest you.

Thanks for the link, delance! I've followed it and found that the same workaround is also posted in the description in bug 765438, and a second workaround is posted in comment #2 of that same bug. Also, this bug and bug 765438 are almost certainly the same bug, so I'm marking this as a duplicate of that one.

summary: - My backlight is off
+ 8086:2a42 My backlight is off
summary: - 8086:2a42 My backlight is off
+ 8086:2a42 [eMachines E725] My backlight is off

Lucas Clemente Vella, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-3.10 needs-upstream-testing
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: regression-release
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers