Ubuntu

Beagle XM lacks proper 1Ghz support

Reported by Tobin Davis on 2011-04-26
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Medium
Unassigned
Release Notes for Ubuntu
Undecided
Canonical ARM Developers
Precise
Undecided
Unassigned
linaro-landing-team-ti
Confirmed
Undecided
Unassigned
linux (Ubuntu)
Medium
Ricardo Salveti
Precise
Medium
Unassigned
Quantal
Medium
Ricardo Salveti

Bug Description

=== RELEASE NOTES TEXT ===
Beagle XM systems which are capable of running at 1GHZ will be initialised at 800MHZ leading to slower that optimal performance. (Bug:771537)
===

Setting the mpurate higher than 900 on beagleXM fails to properly get set by the kernel. The beagleXM is capable of 1000, and is what u-boot autosets. Ricardo Salveti is working on a patch to fix this. Will mark as in-progress with a target of natty-updates.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-omap 2.6.38.8.22
ProcVersionSignature: User Name 2.6.38-8.42-omap 2.6.38.2
Uname: Linux 2.6.38-8-omap armv7l
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices: Error: [Errno 2] No such file or directory
Architecture: armel
ArecordDevices: Error: [Errno 2] No such file or directory
Date: Tue Apr 26 15:43:59 2011
Lsusb:
 Bus 001 Device 005: ID 05d5:6781 Super Gate Technology Co., Ltd
 Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
 Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcKernelCmdLine: ro elevator=noop vram=12M omapfb.mode=dvi:1280x720MR-16@60 mpurate=1000 root=UUID=3b464b92-7561-4e08-98b4-67a5f5a97bbc fixrtc quiet splash console=ttyO2,115200n8
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)

Tobin Davis (gruemaster) wrote :
Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → Ricardo Salveti (rsalveti)
milestone: none → natty-updates
importance: Undecided → Medium
tags: added: iso-testing
Ricardo Salveti (rsalveti) wrote :

After looking over the proper fix to enable 1Ghz support, I found that upstream only recommends using at most 800MHz, as to have proper and safe 1GHz support we need Smart reflex class 1.5 and ABB. We can remove the limit for mpurate, but it doesn't seems a safe solution (at least that was the conclusion from upstream).

The patch that enables 800Mhz is already upstream, with hash 8743410. Will propose this fix to the kernel team, but mpurate is still going to fail for 1000Hz.

I'm just waiting the build to finish and will publish the packages to test, once it's confirmed that's working with 800Mhz I'll send the pull request.

Oliver Grawert (ogra) on 2011-04-27
Changed in ubuntu-release-notes:
assignee: nobody → Canonical ARM Developers (canonical-arm-dev)
Ricardo Salveti (rsalveti) wrote :

After looking for some alternatives, one that came into the picture is by increasing the core voltage to 1.35 and removing the mpurate restriction, but after some testing it seems that the kernel is not reliable.

Seems proper smart reflex implementation would be the way to go here if we want 1GB, that out of a SRU scope.

http://permalink.gmane.org/gmane.comp.hardware.beagleboard.user/14979

Ricardo Salveti (rsalveti) wrote :

Amit, any input from your side here?

Changed in linux-linaro:
status: New → Confirmed
Ricardo Salveti (rsalveti) wrote :

Still not fixed with linux-image-3.0.0-1004-linaro-omap 3.0.0-1004.5~ppa~natty (11.08 RC).

Changed in linaro-ubuntu:
status: New → Triaged
importance: Undecided → High
milestone: none → 11.08
summary: - mpurate=1000 fails on beagleXM
+ Beagle XM lacks proper 1Ghz support
Changed in linaro-ubuntu:
milestone: 11.08 → 11.09
Fathi Boudra (fboudra) on 2011-08-31
tags: added: beaglexm
Changed in linaro-ubuntu:
assignee: nobody → Ricardo Salveti (rsalveti)
Changed in linaro-ubuntu:
milestone: 11.09 → 11.10
Fathi Boudra (fboudra) on 2011-11-11
Changed in linaro-ubuntu:
milestone: 11.10 → 11.11
importance: High → Medium
Ricardo Salveti (rsalveti) wrote :

Still and issue with linux-linaro 3.1 from the 11.11 release.

Changed in linaro-ubuntu:
milestone: 11.11 → none
Andy Whitcroft (apw) on 2012-04-26
Changed in ubuntu-release-notes:
status: New → In Progress
description: updated
Changed in ubuntu-release-notes:
status: In Progress → Fix Released
Ash Charles (ashcharles) wrote :

I some success running a Gumstix Overo (Storm series, OMAP37xx) at 1GHz.
Started with
 * http://arago-project.org/git/projects/?p=linux-omap3.git;a=shortlog;h=refs/heads/OMAPPSP_04.02.00.07
Used tag
 *v2.6.37_OMAPPSP_04.02.00.07
And applied the attached patch (0001-am37x-....)

This is not a mainline-able solution.

The attachment "1GHz patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
John Rigby (jcrigby) wrote :

The patch from Ash Charles is one to linux so I gather that this is not a u-boot issue.

Changed in u-boot-linaro (Ubuntu):
status: New → Invalid
John Rigby (jcrigby) on 2012-08-02
no longer affects: u-boot-linaro (Ubuntu Precise)
no longer affects: u-boot-linaro (Ubuntu)
Paolo Pisati (p-pisati) wrote :

about this one?

people reported that they can drive their XM to 1ghz with it but it's not upstream yet - author contacted.

Paolo Pisati (p-pisati) wrote :

fixed the attachment.

On Mon, Sep 17, 2012 at 6:52 AM, Paolo Pisati <email address hidden> wrote:
> fixed the attachment.

Would indeed be something to check (the patch at least sounds ok).

Do you know if we need any other extra patch? This one seems to be
part of a series of 3 patches, but only the first one is attached.

Changed in linux (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Medium

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: In Progress → Won't Fix
tags: added: precise quantal
Fathi Boudra (fboudra) on 2013-03-29
Changed in linaro-ubuntu:
assignee: Ricardo Salveti (rsalveti) → nobody
status: Triaged → Won't Fix
Linus Walleij (triad) on 2013-09-16
affects: linux-linaro → linaro-landing-team-ti
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers