sound muted on live cd and first boot of fresh installation with many sound cards

Bug #770349 reported by Fabio Marconi on 2011-04-25
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hello
Testing an installaton with the screen reader enabled a blind person cannot install the system because live session start muted (meaning that the loudspeaker icon appear muted associated to the --, then immediatly convert to crossed x) on three of four different machines.
Also the installed system, only at the first boot, start muted.
Thanks
Fabio

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 Cannot stat file /proc/2986/fd/41: Stale NFS file handle
 Cannot stat file /proc/2986/fd/42: Stale NFS file handle
                      USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2980 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'ICH'/'Intel ICH with ALC850 at irq 23'
   Mixer name : 'Realtek ALC850 rev 0'
   Components : 'AC97a:414c4790'
   Controls : 42
   Simple ctrls : 27
Date: Mon Apr 25 16:05:55 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110425)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 0718:0628 Imation Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ProcEnviron:
 LANGUAGE=it_IT:en
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=it keyboard-configuration/layoutcode?=it
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/03/2005
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.asset.tag: 00000000
dmi.board.name: K8NF4G-SATA2
dmi.board.version: 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd11/03/2005:svn:pnK8NF4G-SATA2:pvr1.00:rvn:rnK8NF4G-SATA2:rvr1.00:
dmi.product.name: K8NF4G-SATA2
dmi.product.version: 1.00

Fabio Marconi (fabiomarconi) wrote :
tags: added: a11y
summary: - live session start muted, a11y install impossible
+ live session start muted, a11y installation impossible
description: updated
description: updated
tags: added: iso-testing

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I can confirm this using an Ensoniq sound card. Sound is muted on starting both the live cd and the first boot after an installation. When the sound is unmuted, it will not mute by itself again.

Thanks for taking the time to make Ubuntu better!

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Fabio Marconi (fabiomarconi) wrote :

Also reproduced in:
*-multimedia
             description: Audio device
             product: 5 Series/3400 Series Chipset High Definition Audio
             vendor: Intel Corporation
             physical id: 1b
             bus info: pci@0000:00:1b.0
             version: 06
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi pciexpress bus_master cap_list
             configuration: driver=HDA Intel latency=0
             resources: irq:42 memory:fbff8000-fbffbfff
        *-pci:0
             description: PCI bridge
             product: 5 Series/3400 Series Chipset PCI Express Root Port 1
             vendor: Intel Corporation
             physical id: 1c
             bus info: pci@0000:00:1c.0
             version: 06
             width: 32 bits
             clock: 33MHz
             capabilities: pci pciexpress msi pm normal_decode bus_master cap_list
             configuration: driver=pcieport
             resources: irq:16 ioport:1000(size=4096) memory:d7800000-d79fffff ioport:d7a00000(size=2097152)

summary: - live session start muted, a11y installation impossible
+ sound muted on live cd and first boot of fresh installation
summary: - sound muted on live cd and first boot of fresh installation
+ sound muted on live cd and first boot of fresh installation with some
+ sound cards
summary: - sound muted on live cd and first boot of fresh installation with some
+ sound muted on live cd and first boot of fresh installation with many
sound cards
description: updated
description: updated
tags: added: oneiric
Changed in linux:
importance: Unknown → High
status: Unknown → Confirmed
tags: added: precise
tags: added: rls-mgr-p-tracking
Changed in linux:
status: Confirmed → Invalid
Fabio Marconi (fabiomarconi) wrote :

this bug appear as fixed with this specific sound card, so I close it.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Fabio Marconi (fabiomarconi) wrote :

Obviously was linux related and persist on another intel card

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.