[ips-monitor] is in state 'D'

Bug #765082 reported by Tamas Papp on 2011-04-18
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Fedora)
Fix Released
Undecided
linux (Ubuntu)
High
Leann Ogasawara
Natty
Medium
Leann Ogasawara

Bug Description

SRU Justification:

Impact: ips-monitor is in 'D' state continuously and produces a constant load of 1

Fix: upstream commit a3424216e4935221fdaa5ca3c26e024f11297164

Test case: Boot a kernel with the patch applied and confirm ips-monitor is no loner is a 'D' state and load drops below 1.

=========

Binary package hint: linux-image-2.6.38-8-generic

root 17914 0.0 0.0 0 0 ? D 21:26 0:00 [ips-monitor]

It's in state 'D' continuously right after starting the my laptop. The load is +1.00 then in a normal case.
The CPU fan does not have a pause.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tompos 2215 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd4720000 irq 44'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:111d7603,103c7008,00100202 HDA:11c11040,103c3066,00100200 HDA:80862804,80860101,00100000'
   Controls : 23
   Simple ctrls : 14
Date: Mon Apr 18 21:18:05 2011
HibernationDevice: RESUME=UUID=dd4acc82-dce7-43f5-b81e-d64c05010c24
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Hewlett-Packard HP EliteBook 2540p
PccardctlIdent:
 Socket 0:
   product info: "RICOH", "Bay8Controller", "", ""
   manfid: 0x0000, 0x0000
   function: 254 (unknown)
PccardctlStatus:
 Socket 0:
   3.3V 16-bit PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=abf4030a-f3ce-4215-b87e-a9ca9ad15ac8 ro crashkernel=384M-2G:64M,2G-:128M
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.50
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/24/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CSU Ver. F.08
dmi.board.name: 7008
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 38.32
dmi.chassis.asset.tag: CZC0295P29
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CSUVer.F.08:bd11/24/2010:svnHewlett-Packard:pnHPEliteBook2540p:pvr:rvnHewlett-Packard:rn7008:rvrKBCVersion38.32:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 2540p
dmi.sys.vendor: Hewlett-Packard

Tamas Papp (tompos) wrote :
Tamas Papp (tompos) wrote :

It does not occur with linux-image-2.6.39-999-generic .

Julian Wiedmann (jwiedmann) wrote :

Per https://lkml.org/lkml/2011/3/19/37 , it's just a cosmetic bug in the load reporting - fixed in 2.6.39 with "ips: use interruptible waits in ips-monitor".

Tamas Papp (tompos) wrote :

It's not just a cosmetic bug.
It makes the fan of the laptop running all the time.

Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
Stéphane Graber (stgraber) wrote :

Is there any plan on backporting the fix for this issue, even if "cosmetic" ?

I would imagine it could be a problem in some cases where the load average or number of I/O wait processes is monitored.

Most monitoring scripts assume that a load average higher than the maximum number of possible threads should trigger a warning.
Quite a lot of scripts looking for I/O issues are also looking for processes in "D" state and so will wrongly flag ips-monitor as being the reason of slow disk access (or similar).

Description of problem:

This seems to be the same as this Ubuntu bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/765082

With all up to date Fedora 15, ips-monitor kernel thread is
constantly in D state, resulting in the load avg always being
over 1.0, resulting in the laptop fan running continuously.

Version-Release number of selected component (if applicable):

Linux spin.home.annexia.org 2.6.38.5-22.fc15.x86_64 #1 SMP Mon May 2 19:28:55 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

Always.

Steps to Reproduce:
1. Nothing, just boot the machine.
2.
3.

Additional info:

$ ps ax | grep ' D '
  723 ? D 0:04 [ips-monitor]
 3477 pts/0 S+ 0:00 grep --color=auto D

According to the Ubuntu bug, it is fixed by this patch:
https://lkml.org/lkml/2011/3/19/37

Patch will be in kernel-2.6.38.6-27.fc15

kernel-2.6.38.6-27.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.6-27.fc15

Package kernel-2.6.38.6-27.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.38.6-27.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.38.6-27.fc15
then log in and leave karma (feedback).

probably worth a commonbugs note; do we know what systems this will affect?

--
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

I've installed the update but not booted to test it yet.

Mine is a Thinkpad T510W.

I'm not sure this is common .. I seem to be the only one
that has noticed :-)

*** Bug 702775 has been marked as a duplicate of this bug. ***

(In reply to comment #6)
> probably worth a commonbugs note; do we know what systems this will affect?
>

Intel systems with integrated i915 graphics.
IPS controls power sharing between the CPU and the GPU.

kernel-2.6.38.6-27.fc15 has been pushed to the Fedora 15 stable repository. If problems still persist, please make note of it in this bug report.

(In reply to comment #10)
> kernel-2.6.38.6-27.fc15 has been pushed to the Fedora 15 stable repository. If
> problems still persist, please make note of it in this bug report.

I can confirm this fixes it for me. Load is down to near 0, and ips-monitor is no longer in D state.

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
status: Triaged → In Progress

Hi Tamas,

I've built a Natty test kernel with the patch noted in comment 6 applied. Care to give it a try and let us know your results? The test kernel can be found at the following location:

http://people.canonical.com/~ogasawara/lp765082/amd64/

Changed in linux (Ubuntu):
status: In Progress → Incomplete
Tamas Papp (tompos) wrote :

However already I'm Orienic, it looks fine, the state of ips-monitor is 'D'.

Thank you,

tamas

Brian Murray (brian-murray) wrote :

I'm still running natty and installed Leann's test kernel and observed that ips-monitor is no longer in a 'D' state and that my load has dropped below 1.

Natalia Bidart (nataliabidart) wrote :

I can confirm that using 2.6.38-9-generic #43+lp765082v1 on a Lenovo Thinkpad x201 the load finally goes down below 1. YEY!

Changed in linux (Ubuntu):
status: Incomplete → In Progress

I've sent this patch to upstream stable. I'll also submit it to Natty as a pre-stable patch.

description: updated

Setting the Natty nomination to In Progress. The actively developed linux task is being marked Fix Released as this patch is already included in the Oneiric kernel.

Changed in linux (Ubuntu Natty):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
Changed in linux (Ubuntu):
status: In Progress → Fix Released

--
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

kernel-2.6.38.7-30.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.7-30.fc15

Herton R. Krzesinski (herton) wrote :

This commit is an early application of a commit that will be coming in via upstream stable. As such it is not subject to the standard bug verification process.

tags: added: verification-done-natty
Tamas Papp (tompos) wrote :

When will be available in Natty repos?

Launchpad Janitor (janitor) wrote :
Download full text (26.1 KiB)

This bug was fixed in the package linux - 2.6.38-10.46

---------------
linux (2.6.38-10.46) natty-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #802464

  [ Upstream Kernel Changes ]

  * Revert "put stricter guards on queue dead checks"
  * Revert "fix oops in scsi_run_queue()"

linux (2.6.38-10.45) natty-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "af_unix: Only allow recv on connected seqpacket sockets."

linux (2.6.38-10.44) natty-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #792013

  [ Robert Nelson ]

  * SAUCE: omap3: beagle: detect new xM revision B
    - LP: #770679
  * SAUCE: omap3: beagle: detect new xM revision C
    - LP: #770679
  * SAUCE: omap3: beagle: if rev unknown, assume xM revision C
    - LP: #770679

  [ Stefan Bader ]

  * Include nls_iso8859-1 for virtual images
    - LP: #732046

  [ Thomas Schlichter ]

  * SAUCE: vesafb: mtrr module parameter is uint, not bool
    - LP: #778043

  [ Tim Gardner ]

  * Revert "SAUCE: acpi battery -- move first lookup asynchronous"
    - LP: #775809
  * updateconfigs after update to v2.6.38.6

  [ Upstream Kernel Changes ]

  * Revert "ALSA: hda - Fix pin-config of Gigabyte mobo"
    - LP: #780546
  * Revert "[SCSI] Retrieve the Caching mode page"
    - LP: #788691
  * Revert "USB: xhci - fix unsafe macro definitions"
  * Revert "USB: xhci - fix math in xhci_get_endpoint_interval()"
  * Revert "USB: xhci - also free streams when resetting devices"
  * ath9k_hw: fix stopping rx DMA during resets
    - LP: #775809
  * netxen: limit skb frags for non tso packet
    - LP: #775809
  * ath: add missing regdomain pair 0x5c mapping
    - LP: #775809
  * block, blk-sysfs: Fix an err return path in blk_register_queue()
    - LP: #775809
  * p54: Initialize extra_len in p54_tx_80211
    - LP: #775809
  * qlcnic: limit skb frags for non tso packet
    - LP: #775809
  * nfsd4: fix struct file leak on delegation
    - LP: #775809
  * nfsd4: Fix filp leak
    - LP: #775809
  * virtio: Decrement avail idx on buffer detach
    - LP: #775809
  * x86, gart: Set DISTLBWALKPRB bit always
    - LP: #775809
  * x86, gart: Make sure GART does not map physmem above 1TB
    - LP: #775809
  * intel-iommu: Fix use after release during device attach
    - LP: #775809
  * intel-iommu: Unlink domain from iommu
    - LP: #775809
  * intel-iommu: Fix get_domain_for_dev() error path
    - LP: #775809
  * drm/radeon/kms: pll tweaks for r7xx
    - LP: #775809
  * drm/nouveau: fix notifier memory corruption bug
    - LP: #775809
  * drm/radeon/kms: fix bad shift in atom iio table parser
    - LP: #775809
  * drm/i915/tv: Remember the detected TV type
    - LP: #775809
  * tty/n_gsm: fix bug in CRC calculation for gsm1 mode
    - LP: #775809
  * serial/imx: read cts state only after acking cts change irq
    - LP: #775809
  * ASoC: Fix output PGA enabling in wm_hubs CODECs
    - LP: #775809
  * ASoC: codecs: JZ4740: Fix OOPS
    - LP: #775809
  * ALSA: hda - Add a fix-up for Acer dmic with ALC271x codec
    - LP: #775809
  * ahci: don't enable port irq before handler is registered
    - LP: #775809
  * libata: Implement ATA_FLAG_NO_...

Changed in linux (Ubuntu Natty):
status: In Progress → Fix Released
Changed in linux (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.