atheros wifi cards cause kernel panic when connecting to wpa2 secured wifi networks

Bug #762496 reported by Jonathan Aquilina
56
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Natty
Medium
Tim Gardner

Bug Description

I have discovered a very serious bug with the kernel on ubuntu natty 64bit .

upon doing some digging on the upstream irc i was told there was a patch which fixed this issue from upstream.

when connecting to wpa networks this issue doesnt arise its only specific to wpa2.

I am unable to provide any more informamtion due to the kernel panic requiring me to do a hard reboot.

http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.38.3.tar.bz2

I am going to recompile the kernel from upstream source to test if this fixes the issue, but in the mean time can the patch be included in the kernel.

affects: ubuntu → linux (Ubuntu)
Revision history for this message
Stefan Bader (smb) wrote :

The information provided is unfortunately not very specific. At least not enough to pick the one patch that fixes the problem. Realistically today would be the last day for an upload and that makes it unlikely. But the updates from 2.6.38.3 are scheduled to be in the next update after release. And that should also happen quite close after release.

Revision history for this message
Jonathan Aquilina (eagles051387) wrote : Re: [Bug 762496] Re: atheros wifi cards cause kernel panic when connecting to wpa2 secured wifi networks

these are the patches for the atheros wifi cards

  drivers/net/wireless/ath/ath9k/hw.c <http://www.kernel.org/diff/diffview.cgi?file=%2Fpub%2Flinux%2Fkernel%2Fv2.6%2Fpatch-2.6.38.3.bz2;z=78> 11 + 10 - 0 !
  drivers/net/wireless/ath/ath9k/main.c <http://www.kernel.org/diff/diffview.cgi?file=%2Fpub%2Flinux%2Fkernel%2Fv2.6%2Fpatch-2.6.38.3.bz2;z=79> 4 + 0 - 0 !
  drivers/net/wireless/ath/ath9k/recv.c <http://www.kernel.org/diff/diffview.cgi?file=%2Fpub%2Flinux%2Fkernel%2Fv2.6%2Fpatch-2.6.38.3.bz2;z=80> 1 + 3 - 0 !
  drivers/net/wireless/ath/ath9k/xmit.c <http://www.kernel.org/diff/diffview.cgi?file=%2Fpub%2Flinux%2Fkernel%2Fv2.6%2Fpatch-2.6.38.3.bz2;z=81> 2 + 2 - 0 !

the above are listed at kernel.org. stefan it would greatly be appreciated if this gets in prior
to release, as things are there will be alot of disgruntled users who wont be able to connect
to the internet without it.

On 18/04/2011 10:40, Stefan Bader wrote:
> The information provided is unfortunately not very specific. At least
> not enough to pick the one patch that fixes the problem. Realistically
> today would be the last day for an upload and that makes it unlikely.
> But the updates from 2.6.38.3 are scheduled to be in the next update
> after release. And that should also happen quite close after release.
>

Revision history for this message
Andy Whitcroft (apw) wrote :

To include at patch at this late stage (before release) we would need a specific patch and direct confirmation that that fix resolves the issue for you, plus some regression testing. I suspect that we cannot get all that done in time for the release freeze which is basically the end of today. The block of fixes you mention above are planned for the first SRU kernel which is normally about a week after release.

Revision history for this message
Jonathan Aquilina (eagles051387) wrote :

andy if you make a kernel and put it in a ppa ill be more then willing to test it out. the problem is it would take me quite some time to compile the kernel myself on a netbook.

Revision history for this message
Tim Gardner (timg-tpi) wrote :

eagles051387 - you can always get the next kernel to be uploaded at:

https://launchpad.net/~kernel-ppa/+archive/pre-proposed

Changed in linux (Ubuntu Natty):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Fix Committed
Revision history for this message
Philippe Escarbassière (phil-esc) wrote :

I also got a kernel panic using natty on an notebook with an atheros AR2427 PCI-E adapter (32 bit kernel).

The new proposed kernel 2.6.38-9 seems to fix the problem, no more kernel panic for now...

Revision history for this message
Jonathan Aquilina (eagles051387) wrote :

thanks for the information. I am having a tough time with knetwork manager
but i fild a separate bug for that. hopefully it gets resolved soon and I
can also confirm it worked for me.

2011/4/19 Philippe Escarbassière <email address hidden>

> I also got a kernel panic using natty on an notebook with an atheros
> AR2427 PCI-E adapter (32 bit kernel).
>
> The new proposed kernel 2.6.38-9 seems to fix the problem, no more
> kernel panic for now...
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/762496
>
> Title:
> atheros wifi cards cause kernel panic when connecting to wpa2 secured
> wifi networks
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/762496/+subscribe
>

--
Jonathan Aquilina

Revision history for this message
Andy Whitcroft (apw) wrote :

There is a possible fix in the 2.6.38.3 patchset which may help here. I have pulled that into a test kernel which is at the URL below. If those of you affected could test this kernel and report back here. Kernels are here:

    http://people.canonical.com/~apw/lp762496-natty/

Thanks.

Revision history for this message
Philippe Escarbassière (phil-esc) wrote :

The 2.6.38.3 kernel with the patchset fixes the problem too, no kernel panic

Andy Whitcroft (apw)
Changed in linux (Ubuntu Natty):
importance: Undecided → Medium
Revision history for this message
John Johansen (jjohansen) wrote :

I have been successfully using an ath9k with wpa2 here. Attaching system information below

Revision history for this message
John Johansen (jjohansen) wrote :

Oops, apport want attach to the bug now that it has been closed. So attaching manually

02:00.0 Network controller [0280]: Atheros Communications Inc. AR5008 Wireless Network Adapter [168c:0024] (rev 01)
 Subsystem: Atheros Communications Inc. Device [168c:3072]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at febf0000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: <access denied>
 Kernel driver in use: ath9k
 Kernel modules: ath9k

> nmcli con list
NAME UUID TYPE SCOPE TIMESTAMP-REAL
Auto orthoroute 37cdf544-d037-4a86-ae82-ff13f884cb74 802-11-wireless user Tue 19 Apr 2011 08:59:30 AM PDT

Revision history for this message
Jonathan Aquilina (eagles051387) wrote :

On 19/04/2011 18:04, John Johansen wrote:
> Oops, apport want attach to the bug now that it has been closed. So
> attaching manually
>
> 02:00.0 Network controller [0280]: Atheros Communications Inc. AR5008 Wireless Network Adapter [168c:0024] (rev 01)
> Subsystem: Atheros Communications Inc. Device [168c:3072]
> Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
> Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast>TAbort-<TAbort-<MAbort->SERR-<PERR- INTx-
> Latency: 0, Cache Line Size: 32 bytes
> Interrupt: pin A routed to IRQ 17
> Region 0: Memory at febf0000 (64-bit, non-prefetchable) [size=64K]
> Capabilities:<access denied>
> Kernel driver in use: ath9k
> Kernel modules: ath9k
>
>> nmcli con list
> NAME UUID TYPE SCOPE TIMESTAMP-REAL
> Auto orthoroute 37cdf544-d037-4a86-ae82-ff13f884cb74 802-11-wireless user Tue 19 Apr 2011 08:59:30 AM PDT
>
yours might not be affected by this it seems this issue so far is on
atheros 2427 cards.

Revision history for this message
Robin Malburn (robin-malburn) wrote :

Also receiving a kernel panic on my ASUS 1001p netbook, which I believe runs the AR2427 chipset. Battery just died on my laptop, but will try to add more details to the bug report once I'm fully charged.

Revision history for this message
Jonathan Aquilina (eagles051387) wrote :

On 04/29/2011 12:11 AM, Robin Malburn wrote:
> Also receiving a kernel panic on my ASUS 1001p netbook, which I believe
> runs the AR2427 chipset. Battery just died on my laptop, but will try
> to add more details to the bug report once I'm fully charged.
>
The sru kernel seems to fix the issue. When will this be released for
general use?

Revision history for this message
Robin Malburn (robin-malburn) wrote :

After ending up in a kernel panic boot loop this morning until I disabled the wifi in the BIOS, I have now installed the kernel linked to by Andy Whitcroft (2.6.38-8-generic), and am happy to report that I can now connect to my home wifi without any problems at all.

Revision history for this message
Jonathan Aquilina (eagles051387) wrote :

I can confirm that the 2.6.38-9 kernel also works :)

On Fri, Apr 29, 2011 at 1:21 PM, Robin Malburn <email address hidden>wrote:

> After ending up in a kernel panic boot loop this morning until I
> disabled the wifi in the BIOS, I have now installed the kernel linked to
> by Andy Whitcroft (2.6.38-8-generic), and am happy to report that I can
> now connect to my home wifi without any problems at all.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/762496
>
> Title:
> atheros wifi cards cause kernel panic when connecting to wpa2 secured
> wifi networks
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/762496/+subscribe
>

--
Jonathan Aquilina

Revision history for this message
Robin Malburn (robin-malburn) wrote :

Moved to that kernel myself now (from the pre-proposed repos linked above) and everything's working great still.

Revision history for this message
CJLinSF (cjlemmon) wrote :

I'm downloading the 2.6.38-9 Kernel (~48M) for my asus eee pc from:

https://launchpad.net/~kernel-ppa/+archive/pre-proposed

The repository is very slow, 3K per second!

Revision history for this message
Mark Deneen (mdeneen) wrote :

I also had the crash with an asus 1001p netbook, and using the pre-proposed kernel worked for me.

I'm a bit confused as to what wlan chip this netbook really has because lspci suggests that it is an AR2427, but dmesg shows phy0 as AR9285.

Revision history for this message
cullio (romica-cullio) wrote :

Please see: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/719979

Seems to be the same problem if I'm not mistaken.

Revision history for this message
Julian Wiedmann (jwiedmann) wrote :

For Natty, this should be fixed now with 2.6.38-10.46.
Please reopen the Natty task if you still experience this issue.

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Anders Munk-Nielsen (superpronker) wrote :

I'm having a similar problem which has confuzzled me for a long time... but I'm fairly certain that it's the wifi card. I also have an Atheros card. However, when my box freezes there's no flashing numlock/capslock -- is it still a kernel panic?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers