Ubuntu

Natty Narwhal No Sound

Reported by tdeering on 2011-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

On my CyberpowerPC Gamer Xplorer N57001 laptop running the latest daily build of Natty Narwhal 64bit, there is no sound. The output of sudo aplay -l is:

card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Any suggestions? I've tried running through a multitude of sound troubleshooting guides for Ubuntu.

tdeering (tomdeering7) wrote :
tdeering (tomdeering7) wrote :

I also observe this in Maverick.

tags: added: audio bridge conexant sound ubuntu
David Henningsson (diwic) wrote :

Hi tdeering,

Please edit the file /etc/modprobe.d/alsa-base.conf and add this line:
options snd-hda-intel model=asus

(Yes it's asus although you have a different brand)

Save and reboot. Also make sure sound is not muted, according to https://wiki.ubuntu.com/Audio/CheckForMutedSpeakerVolume

If sound is still not working, please supply a new alsa-info with this configuration. Please report back whether this resolved your problem. Thanks!

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
tdeering (tomdeering7) wrote :

New alsa-info as requested by David Henningsson

tdeering (tomdeering7) wrote :

You can probably guess from me adding the attachment, but I forgot to mention that it didn't solve my problem.

David Henningsson (diwic) wrote :

With model=asus still added, could you please try the following command:

pasuspender -- speaker-test -c 2 -D plughw:PCH -t sine

...and see if you still have no sound, both with headphones and internal speaker?

tdeering (tomdeering7) wrote :

With that command, I DO have sound through the headphone jack but I do not hear anything through the external speakers.

David Henningsson (diwic) wrote :

Ok, I saw another thing in your alsa-info, it seems like the speaker pin is not powered up:

Node 0x1f [Pin Complex] wcaps 0x400501: Stereo
  Pincap 0x00000010: OUT
  Pin Default 0x90170110: [Fixed] Speaker at Int N/A
    Conn = Analog, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x40: OUT
  Power states: D0 D1 D2 D3 D3cold
  Power: setting=D3, actual=D3
  Connection: 2
     0x10* 0x11

Could you please try the following: download and install snd-hda-tools from ppa:diwic/ppa (this is for natty). Then run this terminal command:
sudo hda-verb /dev/snd/hwC0D0 0x1f SET_POWER_STATE 0

And see if that helps to get sound out of internal speakers (you mean *internal* speakers, right?).

tdeering (tomdeering7) wrote :

Yes, I meant external speakers :)

I did what you recommended, and the speakers make 2 "popping" sounds when I execute that command. However, still no sound afterwards. I hear the exact same popping sounds when Ubuntu boots up. Let me know if I can provide anything else.

tdeering (tomdeering7) wrote :

Sorry, I meant *internal*. Brain thought one thing while my hands typed another.

tdeering (tomdeering7) wrote :

I would speculate that the "popping" sounds corresponding to receiving and the losing power, respectively. I should add that I know the speakers function correctly, however, since they work in Windows.

David Henningsson (diwic) wrote :

Hmm, if you look at the file /proc/asound/card0/codec#0 , node 0x1f as quoted in comment #8. When you run the hda-verb command, does the power stay at "D0" or is it turning itself back to "D3"?

tdeering (tomdeering7) wrote :

It seems to be turning itself back to D3

SoloTurn (soloturn) wrote :

upgraded to natty and the sound is gone, at least for youtube and adobe flash.

Make sure you're using the appropriate native Flash for your arch.

SoloTurn (soloturn) wrote :

cannot reproduce it after an upgrade to current, and rebooting.

tdeering (tomdeering7) wrote :

Still no solution for me, and I've been looking. Advice?

David Henningsson (diwic) wrote :

@tdeering, I'm not sure why it turns itself back to D3 but as long as it's D3 it's not outputting any sound. I haven't seen this error before, do you think it could be a hardware error?

tdeering (tomdeering7) wrote :

I suppose it's possible, but I doubt it. I briefly had Windows 7 installed, and I was getting sound with the laptop speakers.

tdeering (tomdeering7) wrote :

Any more suggestions? I'm still stuck with sound through the headphone jack only.

tdeering (tomdeering7) wrote :

"Please edit the file /etc/modprobe.d/alsa-base.conf and add this line:
options snd-hda-intel model=asus"

That fixed my problem. Otherwise, it turned out to be a hardware problem with the speakers. Feel free to close this bug... I'm a n00b and I can't see how or I'd do it.

Changed in alsa-driver (Ubuntu):
status: Incomplete → Invalid
Daniel T Chen (crimsun) wrote :

Before we archive the bug, would you clarify whether you need the model
quirk by removing it and rebooting?

tdeering (tomdeering7) wrote :

Yes, removing that model line breaks the sound. It would still be awfully nice to have it work out of the box.

Daniel T Chen (crimsun) wrote :

Do recording and playback both work when you use that model quirk?

tdeering (tomdeering7) wrote :

Indeed they do.

Daniel T Chen (crimsun) on 2011-06-08
Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium
status: Invalid → In Progress
Daniel T Chen (crimsun) wrote :

Upstream is asking if you can test the latest snapshot without using the model=asus quirk; see https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules.

Please test using the model=auto quirk instead.

tdeering (tomdeering7) wrote :

I tested the latest snapshot and switched to the model=auto quirk. Good news- sound and recording work exactly the same as the model=asus quirk! Way to go upstream guys :)

David Henningsson (diwic) wrote :
Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
David Henningsson (diwic) wrote :

...and thanks to Daniel for fixing it :-)

Daniel T Chen (crimsun) wrote :

Fixed in oneiric's linux 3.0-1.2.

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions