8086:2a42 [Acer Aspire 5736Z] Upgrade to Natty wont load

Bug #759104 reported by johnlon on 2011-04-12
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Binary package hint: xorg

I upgraded to Natty via the Update Manager, and got to reboot and clicked on the kernal, and everything went black screen. Nothing works. Tried installing from fresh install, as soon as the cd was put in, screen went black, nothing happened. Funny thing though, I can enter Natty via Use older kernal option, and everything loads, so it works on the old driver, not the new one.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic
Uname: Linux 2.6.35-28-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
 status: disconnected
 enabled: disabled
 dpms: Off
 status: disconnected
 enabled: disabled
 dpms: Off
 status: disconnected
 enabled: disabled
 dpms: Off
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 status: disconnected
 enabled: disabled
 dpms: Off
Date: Tue Apr 12 20:25:03 2011
DistUpgraded: Log time: 2011-04-12 15:30:42.678123
DistroCodename: natty
DistroVariant: ubuntu
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:048a]
   Subsystem: Acer Incorporated [ALI] Device [1025:048a]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Acer Aspire 5736Z
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-28-generic root=UUID=a67db44a-b8d0-4a8e-97c7-b29d1c03694c ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: Upgraded to natty on 2011-04-12 (0 days ago)
dmi.bios.date: 09/23/2010
dmi.bios.vendor: Acer
dmi.bios.version: V1.04
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JE51_MV
dmi.board.vendor: Acer
dmi.board.version: V1.04
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.04
dmi.modalias: dmi:bvnAcer:bvrV1.04:bd09/23/2010:svnAcer:pnAspire5736Z:pvrV1.04:rvnAcer:rnJE51_MV:rvrV1.04:cvnAcer:ct10:cvrV1.04:
dmi.product.name: Aspire 5736Z
dmi.product.version: V1.04
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.4+bzr20110411-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu12
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 09)
     Subsystem: Acer Incorporated [ALI] Device [1025:048a]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09) (prog-if 00 [VGA controller])
     Subsystem: Acer Incorporated [ALI] Device [1025:048a]

johnlon (jakewc2) wrote :
Bryce Harrington (bryce) wrote :

There is an error message in the dmesg, although not one I recognize:

[ 15.625353] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 15.625359] i915 0000:00:02.0: setting latency timer to 64
[ 15.704281] [drm] detected 63M stolen memory, trimming to 32M
[ 15.704352] alloc irq_desc for 44 on node -1
[ 15.704354] alloc kstat_irqs on node -1
[ 15.704365] i915 0000:00:02.0: irq 44 for MSI/MSI-X
[ 15.704379] [drm] set up 32M of stolen space
[ 15.704523] [drm:init_ring_common] *ERROR* render ring head not reset to zero ctl 00000000 head 02001000 tail 00000000 start 02001000
[ 15.704528] [drm:init_ring_common] *ERROR* render ring head forced to zero ctl 00000000 head 00000000 tail 00000000 start 02001000
[ 15.822352] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem

One thing though, you mentioned "got to reboot and clicked on the kernal". Can you explain what you clicked on more specifically? I don't understand what you mean.

Changed in xorg (Ubuntu):
status: New → Incomplete
bugbot (bugbot) on 2011-04-13
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
johnlon (jakewc2) wrote :

I just tried to reinstall Natty, using alternative cd using 32 bit installation instead, and still had the same problem. Managed to get into Natty adding nomodeset and then updating using sudo apt-add-repository ppa:xorg-edgers/ppa. Updated using sudo apt-get update, apt-get upgrade and apt-get dist upgrade, and still no backlight.

Will try to add the /var/log/Xorg.0.log and /var/log/Xorg.0.log.old files

johnlon (jakewc2) wrote :
johnlon (jakewc2) wrote :

I hope that worked, I have not uploaded files before

Bryce Harrington (bryce) on 2011-04-21
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → High
bugbot (bugbot) on 2011-04-27
description: updated
bugbot (bugbot) on 2011-04-28
summary: - Upgrade to Natty wont load
+ [gm45] Upgrade to Natty wont load

I have the same Problem with 2 Acer eMachines 725 with Intel Graphic

AJenbo (ajenbo) wrote :

This seams be be a dub of bug 693273

AJenbo (ajenbo) wrote :

I marked the other bug as a dub of this one as it already has a priority.

I have been trying to install Ubuntu 11.04 on an Acer Aspire 5736Z. I installs, and gets to reboot, where as soon as the log in page appears, the backlight turns off, at the same time as the drums sound. I have tried all sorts, since Natty came out. I have tried installing using the update manager, fresh install, fresh install using alternative cd, and now installing using .deb install found here http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0-rc1-oneiric/ all of which the same problem occurs, as it is booting, just as the log in page appears, the back light is turned off. I have added 'GRUB_GFXPAYLOAD_LINUX=TEXT' to /etc/default/grub/ updated grub rebooted still nothing. I am convinced it is a backlight problem, if it could found out why the backlight is turned off, then I could get it to work. I can actually blindly once the log on page is there, click on enter, add my password, and Natty seems to load, as I get the music. But its just a black screen. Hope somebody can help?

Created attachment 47600
kern.log for not being able to load Ubuntu 11.04

Hi, I cannot work out where the fault is to edit the file, I have logged in to 3.0-rc1 logged out then into Maverick, and hopefully you can find at the end somewhere around timestamp 14.33 the information you need.

Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: Unknown → Confirmed
Timo Aaltonen (tjaalton) wrote :

try blacklisting the 'acer_wmi' kernel module from loading, by adding 'blacklist acer_wmi' to /etc/modprobe.d/local.conf, and reboot using the bad kernel.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
johnlon (jakewc2) wrote :

ok, well I installed oneiric kernel found here http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0-rc1-oneiric/ installing the .deb 64bit image. Added what was suggested changes to the module under 10.10 and still cannot get the backlight to work. Found the kernel log, where I logged into the Oneiric kernel, then logged into Maverick, which might show what the problem is. Its around 14.33 that I did that.

Created attachment 47617

Uberfly (mitch-n) wrote :

The backlight can be turned on by using setpci -s 00:02.0 F4.B=50. This bug is being reported a lot it seems. I think there is something wrong with the new Intel drivers because even the performance is slower than in 10.10! There is the same problem with openSUSE 11.4.

for the record; the latest logfile is with the acer_wmi module blacklisted, which was suggested to possibly interfere with the backlight functionality.

Timo Aaltonen (tjaalton) wrote :

Whoops, sorry for not replying earlier.. Anyway, hope it's fixed for you in oneiric, and in case it isn't, could you try the v3.2 kernel from the mainline ppa link I gave you?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete

On 23/04/2012 09:49, <email address hidden> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=37986
> Timo Aaltonen<email address hidden> changed:
> What |Removed |Added
> ----------------------------------------------------------------------------
> Priority|high |medium
> Daniel Vetter<email address hidden> changed:
> What |Removed |Added
> ----------------------------------------------------------------------------
> Summary|Install of Ubuntu 11.04 |[GM45] Install of Ubuntu
> |backlight problem...... |11.04 backlight
> | |problem......
> --- Comment #3 from Timo Aaltonen<email address hidden> 2011-06-08 22:35:39 PDT ---
> for the record; the latest logfile is with the acer_wmi module blacklisted,
> which was suggested to possibly interfere with the backlight functionality.
I still cant get 11.04, 11.10 and 12.04 to work on the computer, have
had to give up, as I dont have enough experience to do anymore with
it......which is a pity because I bought that computer to work with
Ubuntu.......I have had to reformat harddrive back to using just

Daniel is working on some patches to fix the backlight controller and is looking for victims^Wtesters.

Ok, I've created these patches, available at http://cgit.freedesktop.org/~danvet/drm/log/?h=backlight-confusion

Git link is git://people.freedesktop.org/~danvet/drm backlight-confusion

Please test them, thanks.

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
summary: - [gm45] Upgrade to Natty wont load
+ 8086:2a42 [gm45] Upgrade to Natty wont load

johnlon, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested. For example:

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:

If the mainline kernel does not fix this bug, please add the following tags:

As well, please remove the tag:

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-1.14 needs-upstream-testing regression-release
affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
summary: - 8086:2a42 [gm45] Upgrade to Natty wont load
+ 8086:2a42 [Acer Aspire 5736Z] Upgrade to Natty wont load
Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.