14e4:4727 [brcmsmac] Wireless LED does not give appropriate feedback on hardware status

Bug #753857 reported by Joaquín Ignacio Aramendía on 2011-04-07
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Wishlist
Unassigned

Bug Description

Noticed in Natty-Beta1 that the LED light of my wireless adapter doesn't turn on. Is not dead since it works in Maverick with proprietary drivers (Broadcom STA).
In Natty, don't even blinks. Installed Broadcom STA proprietary drivers and nothing changed.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.41
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: joaquin 1472 F.... pulseaudio
CRDA: Error: [Errno 2] No existe el fichero o el directorio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfb400000 irq 48'
   Mixer name : 'IDT 92HD81B1X5'
   Components : 'HDA:111d7605,10280441,00100105'
   Controls : 14
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xfa080000 irq 17'
   Mixer name : 'Nvidia GPU 0b HDMI/DP'
   Components : 'HDA:10de000b,10de0101,00100200'
   Controls : 16
   Simple ctrls : 4
Date: Thu Apr 7 14:38:55 2011
HibernationDevice: RESUME=UUID=d5351580-0833-43fe-ae8c-5434a1a56944
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
MachineType: Dell Inc. Vostro 3500
ProcEnviron:
 LANGUAGE=es:en
 LANG=es_AR.UTF-8
 LC_MESSAGES=es_ES.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=296a7f95-929d-4efb-a166-2da5eee4ed68 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.50
SourcePackage: linux
StagingDrivers: brcm80211
Title: [STAGING]
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/10/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 0NVXFV
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd09/10/2010:svnDellInc.:pnVostro3500:pvrNotSpecified:rvnDellInc.:rn0NVXFV:rvrA00:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Vostro 3500
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.

description: updated

Persistent in Natty Beta2

Works fine in today's Natty build (20110427.1)

Changed in linux (Ubuntu):
status: New → Fix Released

Well it seems to be an issue with the kernel driver.
Using the kernel module brcm80211 (now named brcmsmac) arises this issue. The embedded led does not give any feedback about the driver/hardware state.
Some kind of feedback is required to know if the card is on/off or if it is receiving data, specially when working with no desktop environment feedback about it.
But if I use the 'wl' kernel module, the led stays on when the adapter is on and off when the adapter is off. That's the kind of things is expected form the hardware led.

I know is just a light above the keyboard and I didn't see any changes in hardware functionality so far. But I think it's important to bring some state-aware feedback to the user about it's own hardware.

I'm reopening this issue as it's not "fixed" by the default kernel.

Changed in linux (Ubuntu):
status: Fix Released → New
summary: - [Natty-Beta1] Wireless LED does not turn on or blinks on a Dell Vostro
- 3500 laptop
+ Wireless LED does not give appropriate feedback on hardware status
Brad Figg (brad-figg) on 2011-06-11
Changed in linux (Ubuntu):
status: New → Confirmed

FYI: it's unlikely that this is getting added to the brcmsmac driver in the near future (almost certainly not for oneiric). The driver is still in the staging part of the kernel, where it's being cleaned up and converted to use proper kernel interfaces. Once that work is completed, new features can be (reviewed and) added.

LED support is on the "known missing features" list though, see: http://linuxwireless.org/en/users/Drivers/brcm80211

summary: - Wireless LED does not give appropriate feedback on hardware status
+ [brcmsmac] Wireless LED does not give appropriate feedback on hardware
+ status

Notebook HP ProBook 4525s:

wi-fi LED worked in 11.04, but since upgrade to 11.10 it's always off although wi-fi connection works fine.

lshw: product: BCM4313 802.11b/g/n Wireless LAN Controller
          vendor: Broadcom Corporation
          driver=brcmsmac driverversion=3.0.0-12-generic-pae firmware=N/A latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn

cespinal (cespinal17) wrote :

This bug is back in the precise beta 1

summary: - [brcmsmac] Wireless LED does not give appropriate feedback on hardware
- status
+ 14e4:4727 [brcmsmac] Wireless LED does not give appropriate feedback on
+ hardware status
Changed in linux (Ubuntu):
importance: Undecided → Wishlist

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/753857

tags: added: laptop-testing
To post a comment you must log in.