Ubuntu

Internal microphone not working in natty with VAIO VPCSB

Reported by Vincenzo Pii on 2011-04-06
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
David Henningsson
Natty
Undecided
Unassigned

Bug Description

The mic is switched on in KDE mixer sound settings.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: alsa-base 1.0.24+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC275 Analog [ALC275 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: puller 1449 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xc9400000 irq 51'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0275,104d5000,00100005 HDA:80862805,104d5000,00100000'
   Controls : 18
   Simple ctrls : 8
Date: Wed Apr 6 20:27:14 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110405)
ProcEnviron:
 LANGUAGE=
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/10/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: R0120H4
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnINSYDE:bvrR0120H4:bd02/10/2011:svnSonyCorporation:pnVPCSB1C5E:pvrC608BES2:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCSB1C5E
dmi.product.version: C608BES2
dmi.sys.vendor: Sony Corporation

Vincenzo Pii (vinc-pii) wrote :
David Henningsson (diwic) wrote :

You just have an internal mic, no external mic jack, right?

Seems like the problem is that the internal mic is connected to adc node 0x11 whereas adc node 0x08 is the one actually being used. I believe the patch attached will solve the problem.

Changed in alsa-driver (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)
David Henningsson (diwic) wrote :

Committed upstream, thanks for your bug report.

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
Vincenzo Pii (vinc-pii) wrote :

Yes, that's exactly as you said, I only have the internal mic, no external mic jack.
I'll apply the patch this evening.
Thanks.

tags: added: patch
Vincenzo Pii (vinc-pii) wrote :

I could not try the patch this evening because ftp://ftp.alsa-project.org/ is currently unreachable.
I'm looking forward to try it tomorrow!

Vincenzo Pii (vinc-pii) wrote :

I applied the patch and it works perfectly!!!
Thank you very much for fixing it so quickly!
Let me know if there's something else I can do.

David Henningsson (diwic) wrote :

> I applied the patch and it works perfectly!!!

Great, thanks for reporting back!

> Thank you very much for fixing it so quickly!
> Let me know if there's something else I can do.

If you feel like contributing to Ubuntu, there are plenty of things you can do, see http://www.ubuntu.com/community

madbiologist (me-again) wrote :

The abovementioned patch has been included in the upstream kernel 2.6.39-rc3, and cc'd to the stable kernel series.

madbiologist (me-again) wrote :

The abovementioned patch is also now included in the upstream kernel 2.6.38.3.

Lemuel Cantos (lemuelinchrist) wrote :

Hi guys,
Can you please give me instructions on how to apply the patch?
Thanks! :)

Vincenzo Pii (vinc-pii) wrote :

@Lemuel: take a look here: http://ubuntuforums.org/showthread.php?t=1719770&page=2 .
Which kernel are you using?
Currently I am using 2.6.38-8 with natty, and since I updated to it the mic is working fine.

Lemuel Cantos (lemuelinchrist) wrote :

I'm also using Natty, with the latest update - 2.6.38-8.

My mic isn't working at all. I also have the Vaio S series.

should I report this as another bug?

here's my audio hardware info:

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 04)

$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.23.

$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC275
Codec: Intel CougarPoint HDMI

Lemuel Cantos (lemuelinchrist) wrote :

Hello again.

@Vincenzo, I just patched up my system by following your instructions and MY MIC WORKED!! wooohoo!!

Thanks @Vincenzo and @David Henningsson for helping

but just one question. I thought this patch is already included in the latest Natty version. How come I still had to use manually fix it?

David Henningsson (diwic) wrote :

It is not yet released in Natty, when it will, this bug should be noticed. As for upgrading to newer ALSA versions, I generally recommend https://wiki.ubuntu.com/Audio/UpgradingAlsa - although the daily builds are not yet up for Natty, so there is no really good option there yet.

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Lemuel Cantos (lemuelinchrist) wrote :

Ok Thanks for the clarification David. Congrats on the new Natty release. You guys rock!

Accepted linux into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Natty):
status: New → Fix Committed
Lemuel Cantos (lemuelinchrist) wrote :

Hi,

I enabled natty-proposed, updated my system and rebooted. It looks like the mic is still working properly.

But did the update really overwrote my previous patch or should I have uninstalled the AlsaUpgrade first before doing the update to test if the update really worked?

Brad Figg (brad-figg) wrote :

The commit for this issue came in via a stable upstream release. As such it is not subject to the standard bug verification process.

tags: added: verification-done-natty
Launchpad Janitor (janitor) wrote :
Download full text (26.1 KiB)

This bug was fixed in the package linux - 2.6.38-10.46

---------------
linux (2.6.38-10.46) natty-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #802464

  [ Upstream Kernel Changes ]

  * Revert "put stricter guards on queue dead checks"
  * Revert "fix oops in scsi_run_queue()"

linux (2.6.38-10.45) natty-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "af_unix: Only allow recv on connected seqpacket sockets."

linux (2.6.38-10.44) natty-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #792013

  [ Robert Nelson ]

  * SAUCE: omap3: beagle: detect new xM revision B
    - LP: #770679
  * SAUCE: omap3: beagle: detect new xM revision C
    - LP: #770679
  * SAUCE: omap3: beagle: if rev unknown, assume xM revision C
    - LP: #770679

  [ Stefan Bader ]

  * Include nls_iso8859-1 for virtual images
    - LP: #732046

  [ Thomas Schlichter ]

  * SAUCE: vesafb: mtrr module parameter is uint, not bool
    - LP: #778043

  [ Tim Gardner ]

  * Revert "SAUCE: acpi battery -- move first lookup asynchronous"
    - LP: #775809
  * updateconfigs after update to v2.6.38.6

  [ Upstream Kernel Changes ]

  * Revert "ALSA: hda - Fix pin-config of Gigabyte mobo"
    - LP: #780546
  * Revert "[SCSI] Retrieve the Caching mode page"
    - LP: #788691
  * Revert "USB: xhci - fix unsafe macro definitions"
  * Revert "USB: xhci - fix math in xhci_get_endpoint_interval()"
  * Revert "USB: xhci - also free streams when resetting devices"
  * ath9k_hw: fix stopping rx DMA during resets
    - LP: #775809
  * netxen: limit skb frags for non tso packet
    - LP: #775809
  * ath: add missing regdomain pair 0x5c mapping
    - LP: #775809
  * block, blk-sysfs: Fix an err return path in blk_register_queue()
    - LP: #775809
  * p54: Initialize extra_len in p54_tx_80211
    - LP: #775809
  * qlcnic: limit skb frags for non tso packet
    - LP: #775809
  * nfsd4: fix struct file leak on delegation
    - LP: #775809
  * nfsd4: Fix filp leak
    - LP: #775809
  * virtio: Decrement avail idx on buffer detach
    - LP: #775809
  * x86, gart: Set DISTLBWALKPRB bit always
    - LP: #775809
  * x86, gart: Make sure GART does not map physmem above 1TB
    - LP: #775809
  * intel-iommu: Fix use after release during device attach
    - LP: #775809
  * intel-iommu: Unlink domain from iommu
    - LP: #775809
  * intel-iommu: Fix get_domain_for_dev() error path
    - LP: #775809
  * drm/radeon/kms: pll tweaks for r7xx
    - LP: #775809
  * drm/nouveau: fix notifier memory corruption bug
    - LP: #775809
  * drm/radeon/kms: fix bad shift in atom iio table parser
    - LP: #775809
  * drm/i915/tv: Remember the detected TV type
    - LP: #775809
  * tty/n_gsm: fix bug in CRC calculation for gsm1 mode
    - LP: #775809
  * serial/imx: read cts state only after acking cts change irq
    - LP: #775809
  * ASoC: Fix output PGA enabling in wm_hubs CODECs
    - LP: #775809
  * ASoC: codecs: JZ4740: Fix OOPS
    - LP: #775809
  * ALSA: hda - Add a fix-up for Acer dmic with ALC271x codec
    - LP: #775809
  * ahci: don't enable port irq before handler is registered
    - LP: #775809
  * libata: Implement ATA_FLAG_NO_...

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released

The patch noted to resolve this issue is already in the actively developed Oneiric kernel:

ubuntu-oneiric$ git describe --contains 262ac22d21ee2bf3e1655b2e5e45cc94b356e62f
v2.6.39-rc3~7^2^2~1

As such I'm marking changing the actively developed linux task from Fix Committed to Fix Released. Thanks.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions