[intel 82G35] HDMI color issues

Bug #751735 reported by 6arts
94
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
linux (Ubuntu)
Fix Released
High
Unassigned

Bug Description

Binary package hint: linux-image-generic

Since at least the 2.6.37 kernel version, there is an HDMI issue on the 82G35 intel video chipset drm driver. The colors are bad.

For example, on a tty consol, the screen background is green instead of black. I already submit an drm intel bug report.

https://bugs.freedesktop.org/show_bug.cgi?id=33760

As I only have a HMDI screen, this bug is really annoying for me.

This bug appears on ubuntu 11.04

6arts (deolivec)
description: updated
description: updated
affects: linux-meta (Ubuntu) → linux (Ubuntu)
Revision history for this message
Arek Olek (arekolek) wrote :

Before upgrading to Natty I had this issue, but only if I plugged HDMI cable in before the login screen would show up. Since I got Natty it now happens regardless of when I connect my laptop to the monitor (it also auto-configures and switches the output for external monitor only, maybe it's connected to the bug).

I have no idea how to triage this bug, or what information I could provide to help to fix it.

Revision history for this message
Andrew K (andrew-koebbe) wrote :

I'm in the same boat. Here's what lspci says about my card:

Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller

This is on a Dell Studio 1535 if it helps.

Revision history for this message
gerazo (gerazo80) wrote :

I'm also affected. I am using Shuttle SG33M with LCD TV connected to HDMI output. Important lspci lines:

VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
Display controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

Ubuntu 10.10 and previous versions all worked fine. Ubuntu 11.04 shows bad colors (after upgrade and reboot). Fresh 11.04 install CD also shows bad colors on installation screens as well. The LCD TV is constantly connected and always shows bad colors after first modeswitch. Same thing happens if I switch the TV on later.

Most of the colors are from green to bright white with some light purple. Black color is shown green, red is shown the same green, green is shown light green, blue is shown as black. I don't know what combination causes white and purple. The image does not seem to have any extra noise or pixels that should not be there. Only the colors which are changed always the same way I've described.

Revision history for this message
gerazo (gerazo80) wrote :

One more thing: If I remove xserver-xorg-video-intel the acceleration is gone, but the color problem is still the same.

Revision history for this message
Rémi (remi-pascal) wrote :

I've the same problem.

I've two hdmi devices connected to my pc: a lcd 1080p monitor and a tv Sony Bravia LCD.
The green/ping/purple color issue happens only on the Sony TV.

It appears immediately after booting on the natty live iso or after complete installation.

I've tried many things without success:
- latest version of the intel video drivers (2.15.00)
- power on tv before or after boot
- power on/off tv
- 32 and 64 bits

I have never had this problem with previous ubuntu versions.
I've finally reinstalled maverick and all is fine with it.

Revision history for this message
Robert Blenkinsopp (xenophoenix) wrote :

I have exactly the same issue,

However if i unplug and replug the HDMI connector it the colors are back and fixed from green, however if i turn the TV off and on again it is all green again!

I am on a different card however:

00:02.0 VGA compatible controller: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller (rev 03)

Revision history for this message
Arek Olek (arekolek) wrote :

This is how colours look like when i plug in my Acer with HDMI cable: http://i.imgur.com/Uq0sa.jpg
And this is how they should look like: http://i.imgur.com/ueafM.png

Additionaly one can see how the desktop has wrong size when viewed on bigger display (but that's Unity's fault I guess)

Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in dianosing the problem. From a terminal window please run:

apport-collect 751735

and then change the status of the bug back to 'New'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
6arts (deolivec) wrote :

Hello,

I didn't run the command, but it seems that a solution have been found by a kernel hacker.

https://bugs.freedesktop.org/show_bug.cgi?id=33760

=> https://bugzilla.kernel.org/show_bug.cgi?id=25732

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux:
status: Unknown → Confirmed
Revision history for this message
Robert Blenkinsopp (xenophoenix) wrote :

I can confirm that the solution posted by Jürg Billeter in https://bugs.freedesktop.org/show_bug.cgi?id=33760 solves this problem at least for me. Details of my kernel version can be found in my post in that thread.

Revision history for this message
Robert Blenkinsopp (xenophoenix) wrote :

Further to my previous comment that this was fixed, this appears to introduce instability into the system (my machine periodically crashes) I will attempt to investigate to see if this fix is the cause of this issue.

Revision history for this message
mahesh (mpatel0) wrote :

I am running an Asus board P8H67-M Evo with a Core i5 processor, and have a problem with color mapping on a Toshiba 42hp95 monitor, and have been unable to solve the problem. I was wondering if this is the same bug that I have posted not having originally seen the above post.

Please see: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/803094

I have not been able to solve this problem, and seems to be present with Natty Narwhal and with older 10.04 versions of Linux on a live CD. When I use Windows the problem does not occur.

I look forward to a solution for this problem.

tags: added: kernel-fixed-upstream natty
Changed in linux (Ubuntu):
status: Confirmed → Triaged
tags: added: patch
removed: kernel-fixed-upstream
Changed in linux:
status: Confirmed → Incomplete
Changed in linux:
status: Incomplete → Confirmed
Changed in linux:
status: Confirmed → Fix Released
Revision history for this message
david ammerlaan (daafies) wrote :

this problem still exists on 12.04 on dell studio hybrid.

Revision history for this message
Peter Ross (pross-au) wrote :

@daafies the problem is fixed in linux 3.5.0 (this is will be available in ubuntu 12.10)

Revision history for this message
david ammerlaan (daafies) wrote :

@pross-au cool, but what about 12.04 LTS? when will it get 3.5.0? at same time frame?

Revision history for this message
Sean Mahrt (sean-littleappleservice) wrote :

OK, so it's been sitting here a while... this is BROKEN in 12.04 (and the 11 series I believe). When will this be backported to the LTS branch? Do we need to be pestering the 3.5.0 kernel people, or is Ubuntu supposed to fix this?

Revision history for this message
david ammerlaan (daafies) wrote :

i just upgraded to 12.10. done

Revision history for this message
Sean Mahrt (sean-littleappleservice) wrote :

ugh... (fly with hammer)

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: quantal
tags: added: precise
removed: quantal
Revision history for this message
BavarianPH (bavarianph) wrote :

3.2.0-34-generic-pae linux kernel update for Ubuntu 12.04 reintroduced the color issue same as 2.6.37 kernel version.
Does the kernel update really have to degredate HDMI versus VGA signals?
Do gnome updates really have to regress gnome extensions?
Do people really have to lie about the Unity shell, saying that it's great, when over half of all linux users like the gnome shell better,
especially when the gnome shell is coupled with the cairo-dock, which effectively creates a main menu and upfront accessible apps?
And, yes you may not see the connection between kernel upgrades and the superiority of the gnome shell versus the unbelievable waste of time Unity is, both are examples of selfwill and lack of concern how drastic changes affect users like me.
Without users Ubuntu and gnome would be NOTHING! Fixing user issues should be first priority!
Sincerely,
BavarianPH,
Gnome-Ubuntu forever!

Revision history for this message
madbiologist (me-again) wrote :

For anyone still having this issue in Quantal (or when using a 3.5.x kernel on an earlier Ubuntu release), according to https://bugzilla.kernel.org/show_bug.cgi?id=25732 a further fix was introduced in kernel 3.7.

Revision history for this message
Arek Olek (arekolek) wrote :

Yesterday my Ubuntu 12.10 upgraded linux kernel from 3.2.0.37.45 to 3.2.0.38.46 and the problem came back after maybe a year of absence.

For anyone that would like to downgrade, just like I had to:

# remove bad kernel version so it won't be started with grub
sudo apt-get purge linux-headers-3.2.0-38 linux-headers-3.2.0-38-generic linux-image-3.2.0-38-generic
# downgrade linux version
sudo apt-get install linux-generic=3.2.0.37.45 linux-headers-generic=3.2.0.37.45 linux-image-generic=3.2.0.37.45
# lock version so it won't upgrade
echo "linux-generic hold\nlinux-headers-generic hold\nlinux-image-generic hold" | sudo dpkg --set-selections

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

6arts, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder, but the one all the way at the bottom) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Revision history for this message
BavarianPH (bavarianph) wrote : Re: [Bug 751735] Re: [intel 82G35] HDMI color issues

I have not had any [Intel 82G35] HDMI color issues for over two years.

I am running a 64 bit Linux OS - version 3.11.0-13-generic kernel on 13.10
[Saucy] GNOME-Ubuntu - 3.8 gnome-shell desktop.

BavarianPH

On Fri, Nov 8, 2013 at 1:02 AM, Christopher M. Penalver <
<email address hidden>> wrote:

> 6arts, this bug was reported a while ago and there hasn't been any
> activity in it recently. We were wondering if this is still an issue? If
> so, could you please test for this with the latest development release
> of Ubuntu? ISO images are available from http://cdimage.ubuntu.com
> /daily-live/current/ .
>
> If it remains an issue, could you please run the following command in
> the development release from a Terminal
> (Applications->Accessories->Terminal), as it will automatically gather
> and attach updated debug information to this report:
>
> apport-collect -p linux <replace-with-bug-number>
>
> Also, could you please test the latest upstream kernel available (not the
> daily folder, but the one all the way at the bottom) following
> https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional
> upstream developers to examine the issue. Once you've tested the upstream
> kernel, please comment on which kernel version specifically you tested. If
> this bug is fixed in the mainline kernel, please add the following tags:
> kernel-fixed-upstream
> kernel-fixed-upstream-VERSION-NUMBER
>
> where VERSION-NUMBER is the version number of the kernel you tested. For
> example:
> kernel-fixed-upstream-v3.12
>
> This can be done by clicking on the yellow circle with a black pencil icon
> next to the word Tags located at the bottom of the bug description. As
> well, please remove the tag:
> needs-upstream-testing
>
> If the mainline kernel does not fix this bug, please add the following
> tags:
> kernel-bug-exists-upstream
> kernel-bug-exists-upstream-VERSION-NUMBER
>
> As well, please remove the tag:
> needs-upstream-testing
>
> Once testing of the upstream kernel is complete, please mark this bug's
> Status as Confirmed. Please let us know your results. Thank you for your
> understanding.
>
> ** Changed in: linux (Ubuntu)
> Status: Triaged => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/751735
>
> Title:
> [intel 82G35] HDMI color issues
>
> Status in The Linux Kernel:
> Fix Released
> Status in “linux” package in Ubuntu:
> Incomplete
>
> Bug description:
> Binary package hint: linux-image-generic
>
> Since at least the 2.6.37 kernel version, there is an HDMI issue on
> the 82G35 intel video chipset drm driver. The colors are bad.
>
> For example, on a tty consol, the screen background is green instead
> of black. I already submit an drm intel bug report.
>
> https://bugs.freedesktop.org/show_bug.cgi?id=33760
>
> As I only have a HMDI screen, this bug is really annoying for me.
>
> This bug appears on ubuntu 11.04
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/751735/+subscriptions
>

Revision history for this message
david ammerlaan (daafies) wrote :
Download full text (4.1 KiB)

Me.neither. later kernels support

--- Original Message ---

From: "BavarianPH" <email address hidden>
Sent: November 8, 2013 3:30 PM
To: <email address hidden>
Subject: Re: [Bug 751735] Re: [intel 82G35] HDMI color issues

I have not had any [Intel 82G35] HDMI color issues for over two years.

I am running a 64 bit Linux OS - version 3.11.0-13-generic kernel on 13.10
[Saucy] GNOME-Ubuntu - 3.8 gnome-shell desktop.

BavarianPH

On Fri, Nov 8, 2013 at 1:02 AM, Christopher M. Penalver <
<email address hidden>> wrote:

> 6arts, this bug was reported a while ago and there hasn't been any
> activity in it recently. We were wondering if this is still an issue? If
> so, could you please test for this with the latest development release
> of Ubuntu? ISO images are available from http://cdimage.ubuntu.com
> /daily-live/current/ .
>
> If it remains an issue, could you please run the following command in
> the development release from a Terminal
> (Applications->Accessories->Terminal), as it will automatically gather
> and attach updated debug information to this report:
>
> apport-collect -p linux <replace-with-bug-number>
>
> Also, could you please test the latest upstream kernel available (not the
> daily folder, but the one all the way at the bottom) following
> https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional
> upstream developers to examine the issue. Once you've tested the upstream
> kernel, please comment on which kernel version specifically you tested. If
> this bug is fixed in the mainline kernel, please add the following tags:
> kernel-fixed-upstream
> kernel-fixed-upstream-VERSION-NUMBER
>
> where VERSION-NUMBER is the version number of the kernel you tested. For
> example:
> kernel-fixed-upstream-v3.12
>
> This can be done by clicking on the yellow circle with a black pencil icon
> next to the word Tags located at the bottom of the bug description. As
> well, please remove the tag:
> needs-upstream-testing
>
> If the mainline kernel does not fix this bug, please add the following
> tags:
> kernel-bug-exists-upstream
> kernel-bug-exists-upstream-VERSION-NUMBER
>
> As well, please remove the tag:
> needs-upstream-testing
>
> Once testing of the upstream kernel is complete, please mark this bug's
> Status as Confirmed. Please let us know your results. Thank you for your
> understanding.
>
> ** Changed in: linux (Ubuntu)
> Status: Triaged => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/751735
>
> Title:
> [intel 82G35] HDMI color issues
>
> Status in The Linux Kernel:
> Fix Released
> Status in “linux” package in Ubuntu:
> Incomplete
>
> Bug description:
> Binary package hint: linux-image-generic
>
> Since at least the 2.6.37 kernel version, there is an HDMI issue on
> the 82G35 intel video chipset drm driver. The colors are bad.
>
> For example, on a tty consol, the screen background is green instead
> of black. I already submit an drm intel bug report.
>
> https://bugs.freedesktop.org/show_bug.cgi?id=33760
>
> As I only have a HMDI screen, this bug is really annoying for me.
>
> This bug app...

Read more...

Dimitrenko (paviliong6)
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.