Ubuntu

eject cd doesn't work and "just should"

Reported by josh on 2006-12-09
82
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

When I press the button on my CD/DVD drive the CD doesn't eject. This is a bug. I don't care if it's mounted. I don't care if it's use. When I press that button, it should come out. I understand that forcefully unmounting a file system is in general a bad idea. Data can be corrupted, be lost or disappear into thin air -- but not on a read-only mount of a read only CD.

I shouldn't have to hold down the button. I shouldn't have to reboot my computer. Xine shouldn't lock up because I wanted my disc and neither should mplayer. They should exit gracefully and my disc should come out so that I can throw it on my desk full of other randon crap.

I shouldn't have to fight my CD-drive.

If I put in a scratched or otherwise damaged disc (unbeknownst to me) there should be some timeout period where it gives up and stops trying to mount it -- this makes things hang. It's annoying.

Give me back my disc.

Please, thanx :-)

kko (kko) wrote :

I sympathise with the initial reporter... yes, CD/DVD-drives can give grief to the user in Linux, and I have faced this issue myself (hence marking as confirmed). Ubuntu BTS (and most probably a number of others) contain a few reports against particular programs (like Nautilus) that sometimes prevent the ejection of a disc. Sometimes the command "eject" won't work, but "sudo eject" will, sometimes you have to repeat the "sudo eject" a few times, sometimes start by killing a stray process that was left behind preventing the ejection etc. See also bug #66609.

"I shouldn't have to fight my CD-drive." ;-) Indeed, ejecting media, especially read-only media, shouldn't be as hard as it sometimes seems to be.

But how to tackle this issue, that's the difficult question...

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. What version of Ubuntu do you use? Could you describe easy steps to get a situation where eject is not working correctly?

Changed in nautilus:
importance: Undecided → Low
status: Confirmed → Incomplete
  • unnamed Edit (1.6 KiB, text/html; charset=ISO-8859-1)

I filed this bug a while ago (I'm on 8.04 now) and can't say it's been too
bad a of a problem recently. But typically the problem would arise when
trying to play a DVD that was unreadable for whatever reason.. (libdvdcss2
couldn't decrypt the DVD, or if there was a scratch then ubuntu would try to
read it way too long and not eject the DVD)

I realize this is all kind of esoteric. I guess what would be the best
solution would be that hitting the eject button killed all of the running
processes that were using the dvd and then ejected it.

On Sun, Apr 27, 2008 at 5:13 AM, Sebastien Bacher <email address hidden> wrote:

> Thank you for your bug report. What version of Ubuntu do you use? Could
> you describe easy steps to get a situation where eject is not working
> correctly?
>
> ** Changed in: gnome-mount (Ubuntu)
> Sourcepackagename: nautilus => gnome-mount
> Importance: Undecided => Low
> Status: Confirmed => Incomplete
>
> --
> eject cd doesn't work and "just should"
> https://bugs.launchpad.net/bugs/75074
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Matthew Woerly (nattgew) wrote :

I agree. Rather than just killing them, I think there should be a dialog box that alerts the user that processes (maybe list them?) are using the drive, and give them the option to kill the processes and eject the disk.

Michael Rooney (mrooney) wrote :

Nattgew, for what you just suggested see http://bugzilla.gnome.org/show_bug.cgi?id=528559. Is there a launchpad bug for this downstream?

Cdr_RF (g-ford9) wrote :

Ubuntu Intrepid Ibex Alpha-4 8.10 CD trapped in computer - Live session user

 System > Shut Down > left-click [Restart] > Results: window with [Restart] & [Shut Down] buttons disappears, no Restart

 System > Shut Down > left-click [Shut Down] > Results: window with [Restart] & [Shut Down] buttons disappears, no Shut Down

 Push CD-ROM front panel eject button > Results: Error window: 'Unable to eject CD-RW Drive' (first-pass), similar message if push eject button again

  Workaround1: Poweroff computer for 10 seconds, Poweron computer, keep pressing CD-ROM eject button during startup until CD-ROM tray opens and stays open long enough to remove the CD.

  Workaround2: First-time Ubuntu Live session user should not be expected to know the following: Terminal > sudo reboot > You have a half-second window to grab CD before CD-ROM tray slams shut or if I recall correctly may be able to press eject button to get the tray to open during reboot. If Terminal > sudo poweroff > You have a half-second window to grab the CD before the CD-ROM tray slams shut.

  (Users need to be warned straight away if either workaround negates the following Ubuntu LiveCD start up statement: "Try Ubuntu without any change to your computer." I haven't looked for any changes yet.)

Cdr_RF (g-ford9) wrote :

Using Intrepid Alpha5 LiveCD and I would guess at least some earlier Ubuntu versions, but I would not expect a first-time Ubuntu Live CD user to know what was probably obvious to most experienced users except me:

Terminal > sudo reboot -f > short wait for computer's boot screen > press [Del] key > BIOS screen appears > press front-panel eject switch to open CD-ROM to get CD out > turn off computer power switch or reboot.

Sebastien Bacher (seb128) wrote :

there is bug #81239 about better handling the issue of the drive being used

Chris Hubick (chris-hubick) wrote :

I think that it doesn't matter if you are pressing the CD eject button, or the power button, or your laptop battery is running out of charge, or whatever, isn't there some framework to inform applications that "resource X is going away within approximately Y to Z timeunit from now, there isn't anything you can do about that, act accordingly". And then the resource should just go away. And if an application didn't react to the notification, that's it's problem - no need to outright kill it, just force it to then handle the error it will get the next time it tries to use the resource - at which point it will hopefully be smart about things as well, like your CD burning software saying "hey, I was in the middle of copying that to another disc, put it back or that will fail [Try Again] [Fail]".

kassa! (kbabeatbox) wrote :

I'm having this problem too, can get very frustrating. Took me a ridiculously long time to remove a scratched disk earlier. I eventually lost patience and had to hold the power button for 5 seconds, and then quickly retrieve the CD whilst it rebooted.

Martin Erik Werner (arand) wrote :

Why does the physical eject button work exactly as the nautilus (right-click>) "eject volume" action?

As is the case now, when you insert a CD you will be unable to retrieve it again without unmounting, even if _no application is using it whatsoever_

This seen on a dell M1530, Jaunty.

Ivo (ivo-onraedt-be) wrote :

My "eject-CD"-button (hardware-button on the desktop) doesn't work.

I have dual boot win7/ubuntu9.10.
My drives are all eSATA
BIOS is AMI v 02.67 (recent)

Eject-button works fine under windows7.

When I boot Ubuntu without a CD in the player I can't open the tray except by using a pin (not very elegant).
When I succeed in inserting a disk in the CD/DVD-player it is mounted automatically and then I can eject via software (e.g. sudo eject).

To work around this problem I always see to it that a disk is inserted while booting (or I always leave a disk in the player on exit so it is there when I boot). In this way I can always use the software eject to open the tray.

This is probably a bug and I would be very grateful if somebody could help me there.

Vish (vish) wrote :

Works on Ubuntu 10.04
If you are playing a video or an audio file and use the eject button , the CD/DVD is ejected. But of course the app will complain that the file is lost/corrupted ;)

BTW, gnome-mount isnt used now.

Changed in hundredpapercuts:
status: New → Fix Released
Vish (vish) wrote :

Ivo, the problem you mention is a bug and not related to this bug report , Kindly file a separate bug.

Fabián Rodríguez (magicfab) wrote :

Marking this confirmed, high, on Karmic. I have to sudo eject *both* my optical drives.

I'll submit proper details when I have acces to the system, tonight.

Changed in gnome-mount (Ubuntu):
status: Incomplete → Confirmed
importance: Low → High
igi (igor-cali) on 2010-04-09
tags: added: karmic lucid
Umang Varma (umang) wrote :

I'm not on Ubuntu anymore, but on Ubuntu and on Debian I've found myself facing this issue. I feel the system should be far more liberal in dealing with the CD drive. If I am not wrong, you cannot eject a CD mounted by another user even if the other user has logged out without using super-user privileges. Seriously, what's wrong with ejecting a disk for someone else when nothing at all is using the CD? Can't everyone be given "eject" permission for CD drives?

Don Cristóbal (doncristobal) wrote :

Ejecting with the physical eject button seems to work now (for me: on Xubuntu 11.04 alpha1). However, CDs don't get unmounted properly, at least in some cases. See bugs #660972, #588783, #510021.

igi (igor-cali) on 2011-03-26
tags: added: maverick
igi (igor-cali) on 2011-05-01
tags: added: natty
Thomas Hotz (thotz) wrote :

Can somebody confirm this bug please in supported Ubuntu versions?

Thomas Hotz (thotz) wrote :

Which CD drives are affected?

Thomas Hotz (thotz) on 2012-11-07
Changed in gnome-mount (Ubuntu):
status: Confirmed → Incomplete

josh, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

no longer affects: gnome-mount (Ubuntu)
affects: hundredpapercuts → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Fix Released → Incomplete
Phillip Susi (psusi) wrote :

Closing this since it should have auto expired some time ago, but is blocked by the remote bug watch.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.