www hot key ignored on HP 8440p

Bug #749839 reported by Glen Ditchfield on 2011-04-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

I installed ubuntu-11.04-beta1-desktop-amd64.iso on an EliteBook 8440p. I chose manual partitioning and installed "/" on a formatted partion, but used an existing partition for /home. The home directories had been used with Kubuntu Karmic releases and Kubuntu Natty pre-beta releases, and may have left-over preferences from older Gnome installations.

When I press the hot key that has a "globe" icon, which launches a web browser in Windows 7, nothing happens under Ubuntu. xev does not report any events when I press that key. In contrast, when I press the e-mail hot key, xev reports KeymapNotify events and the Evolution Setup Assistant starts.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gjditchf 1482 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x94720000 irq 44'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:111d7603,103c172a,00100202 HDA:11c11040,103c3066,00100200 HDA:80862804,80860101,00100000'
   Controls : 24
   Simple ctrls : 15
DistroRelease: Ubuntu 11.04
HibernationDevice: RESUME=UUID=12397bc9-7c92-473c-b610-3a23eefa1a9b
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
MachineType: Hewlett-Packard HP EliteBook 8440p
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   product info: "RICOH", "Bay8Controller", "", ""
   manfid: 0x0000, 0x0000
   function: 254 (unknown)
PccardctlStatus:
 Socket 0:
   3.3V 16-bit PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=894b75f9-dcf7-4c2d-8461-2b6b7fd403af ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Regression: No
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-7-generic N/A
 linux-backports-modules-2.6.38-7-generic N/A
 linux-firmware 1.49
Reproducible: Yes
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: natty running-unity kernel-uncat needs-upstream-testing
Uname: Linux 2.6.38-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/22/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CCU Ver. F.02
dmi.board.name: 172A
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 30.29
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CCUVer.F.02:bd12/22/2009:svnHewlett-Packard:pnHPEliteBook8440p:pvr:rvnHewlett-Packard:rn172A:rvrKBCVersion30.29:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8440p
dmi.sys.vendor: Hewlett-Packard
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gjditchf 1661 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x94720000 irq 47'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:111d7603,103c172a,00100202 HDA:11c11040,103c3066,00100200 HDA:80862804,80860101,00100000'
   Controls : 19
   Simple ctrls : 11
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=12397bc9-7c92-473c-b610-3a23eefa1a9b
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
MachineType: Hewlett-Packard HP EliteBook 8440p
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   product info: "RICOH", "Bay8Controller", "", ""
   manfid: 0x0000, 0x0000
   function: 254 (unknown)
PccardctlStatus:
 Socket 0:
   3.3V 16-bit PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=d73db3ec-49fc-40a8-99ed-da71d7fb3256 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-11-generic N/A
 linux-backports-modules-3.0.0-11-generic N/A
 linux-firmware 1.60
StagingDrivers: mei
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-11-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WifiSyslog:
 Sep 13 21:32:21 oneiric wpa_supplicant[1153]: WPA: Group rekeying completed with 00:24:01:29:bf:a3 [GTK=TKIP]
 Sep 13 21:42:21 oneiric wpa_supplicant[1153]: WPA: Group rekeying completed with 00:24:01:29:bf:a3 [GTK=TKIP]
 Sep 13 21:52:21 oneiric wpa_supplicant[1153]: WPA: Group rekeying completed with 00:24:01:29:bf:a3 [GTK=TKIP]
 Sep 13 22:02:21 oneiric wpa_supplicant[1153]: WPA: Group rekeying completed with 00:24:01:29:bf:a3 [GTK=TKIP]
 Sep 13 22:12:21 oneiric wpa_supplicant[1153]: WPA: Group rekeying completed with 00:24:01:29:bf:a3 [GTK=TKIP]
dmi.bios.date: 12/22/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CCU Ver. F.02
dmi.board.name: 172A
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 30.29
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CCUVer.F.02:bd12/22/2009:svnHewlett-Packard:pnHPEliteBook8440p:pvr:rvnHewlett-Packard:rn172A:rvrKBCVersion30.29:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8440p
dmi.sys.vendor: Hewlett-Packard

apport information

tags: added: apport-collected kernel-uncat natty needs-upstream-testing running-unity
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
Glen Ditchfield (gjditchfield) wrote :

The bug is still present in the released Natty desktop for AMD64.
This time I created an empty home directory when I installed Natty, so no there are no left-over settings.

Glen Ditchfield (gjditchfield) wrote :

The defect still exists in Oneric beta 1.

tags: added: oneiric staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel currently in the release pocket than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-11.18
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Low
Changed in linux (Ubuntu):
importance: Low → Undecided

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.19
Glen Ditchfield (gjditchfield) wrote :

Still present in 3.0.0-12.19

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Glen Ditchfield (gjditchfield) wrote :

Still present with linux-image 3.0.0-12.20

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: removed: needs-upstream-testing
Glen Ditchfield (gjditchfield) wrote :

I installed the 20111011 oneiric-desktop-amd64.iso daily build (md5sum dfe02b236f6d2a1ee1cba61afa4f6165), then installed
  linux-headers-3.1.0-0301rc9_3.1.0-0301rc9.201110050905_all.deb
  linux-headers-3.1.0-0301rc9-generic_3.1.0-0301rc9.201110050905_amd64.deb
  linux-image-3.1.0-0301rc9-generic_3.1.0-0301rc9.201110050905_amd64.deb
The WWW key was ignored in both.

FWIW, in either image, running "showkey" in a console reports keycode 155 press and release events for the Mail key, and keycode 425 press and release events for the WWW key. "showkey -s" reports "0xe0 0x6c 0xe0 0xec" on Mail key presses, and nothing on WWW key presses.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org? That will allow the upstream Developers examine the issue, and may provide a quicker resolution to the bug.

It would be great if you can report back the upstream bug number in this bug report, so this bug can be linked to the upstream report.

Glen Ditchfield (gjditchfield) wrote :

OK, but if the question comes up ... why do you think this is a kernel bug, not an X bug?

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/749839

tags: added: laptop-testing

Glen Ditchfield, chis bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please provide the information following https://wiki.ubuntu.com/Hotkeys/Troubleshooting ?

As well, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Please let us know your results. Thank you for your understanding.

tags: added: bot-stop-nagging needs-upstream-testing
removed: kernel-request-3.0.0-11.18 kernel-request-3.0.0-12.19 kernel-request-3.0.0-12.20
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Glen Ditchfield (gjditchfield) wrote :

This is a udev problem. I have filed a bug and fix against udev: see bug 1071579.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.