14f1:5b7a HVR-1600 kernel setup fails

Bug #746598 reported by Eric Munson on 2011-03-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mythbuntu
Expired
Undecided
Unassigned
linux (Ubuntu)
Low
Unassigned

Bug Description

Running on Mythbuntu 10.10 32 bit on 2.93 GHz Intel Core 2 Duo with nVidia GT 210 (proprietary drivers). The machine is both a front- and back-end for mythtv

Detection seems to work and the card is identified properly, but the DVB frontend setup fails. I have tried setting vmalloc to both 256m and 512m, neither helped.

Attached is the relevant dmesg output.
---
.etc.asound.conf: defaults.pcm.device 3
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/controlC0', '/dev/snd/hwC0D1', '/dev/snd/pcmC0D3p', '/dev/snd/by-path', '/dev/snd/by-id', '/dev/snd/controlC2', '/dev/snd/pcmC2D0c', '/dev/snd/controlC1', '/dev/snd/pcmC1D0c', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xf7e7c000 irq 17'
   Mixer name : 'Nvidia GPU 0b HDMI/DP'
   Components : 'HDA:10de000b,10de0101,00100200'
   Controls : 5
   Simple ctrls : 2
Card1.Amixer.info:
 Card hw:1 'CX180'/'CX23418 #0 Hauppauge HVR-1600 TV/FM Radio/Line-In Capture'
   Mixer name : ''
   Components : ''
   Controls : 0
   Simple ctrls : 0
Card1.Amixer.values:

Card2.Amixer.info:
 Card hw:2 'U0x46d0x821'/'USB Device 0x46d:0x821 at usb-0000:00:1d.7-3, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0821'
   Controls : 2
   Simple ctrls : 1
Card2.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 52
   Mono: Capture 18 [35%] [-53.00dB] [on]
DistroRelease: Ubuntu 11.04
HibernationDevice: RESUME=UUID=57644ce2-eebb-4193-a978-395bc2e20f12
InstallationMedia: Mythbuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: BIOSTAR Group G31D-M7
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=c97a9856-7e31-4b67-b043-c4adc6ef687d ro quiet splash vmalloc=256m vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-11.48-generic 2.6.38.8
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-11-generic N/A
 linux-backports-modules-2.6.38-11-generic N/A
 linux-firmware 1.52
RfKill:

Tags: natty
Uname: Linux 2.6.38-11-generic i686
UpgradeStatus: Upgraded to natty on 2011-04-30 (139 days ago)
UserAsoundrc: defaults.pcm.device 3
UserGroups: adm admin audio cdrom dialout dip lpadmin mythtv plugdev sambashare video
dmi.bios.date: 02/01/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080014
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: G31D-M7
dmi.board.vendor: BIOSTAR Group
dmi.chassis.asset.tag: None
dmi.chassis.type: 3
dmi.chassis.vendor: BIOSTAR Group
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080014:bd02/01/2010:svnBIOSTARGroup:pnG31D-M7:pvr:rvnBIOSTARGroup:rnG31D-M7:rvr:cvnBIOSTARGroup:ct3:cvr:
dmi.product.name: G31D-M7
dmi.sys.vendor: BIOSTAR Group

Eric Munson (emunson) wrote :
Eric Munson (emunson) wrote :

This has been addressed by several patches to the HVR-1600 driver and should no longer be an issue (once these patches are included in the ubuntu kernel).

Mario Limonciello (superm1) wrote :

Do you have some particulars about these patches? We can potentially try to get them pulled in as SRUs.

Eric Munson (emunson) wrote :

Let me o back through my mail, when I find the commit id's I will post them here.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 746598

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected natty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in mythbuntu:
status: New → Confirmed
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: needs-upstream-testing
removed: hvr-1600
summary: - HVR-1600 kernel setup fails
+ 14f1:5b7a HVR-1600 kernel setup fails
tags: added: cherry-pick
removed: needs-upstream-testing

Eric Munson, thank you for reporting this and helping make Ubuntu better. Natty reached EOL on October 2012.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://www.ubuntu.com/download/desktop .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Tips:
https://help.ubuntu.com/community/ReportingBugs

Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Thomas Mashos (tgm4883) wrote :

We really do appreciate you opening this ticket to help improve Mythbuntu, but it needs to be closed for a number of reasons. The biggest one is that upstream has moved on to a new version and believes this to be fixed. Could you please verify if this issue still exists in the latest version?

Please do not let the closing of this ticket dissuade you from opening a new ticket if this (or any other) problem occurs with the newer versions.

Thomas Mashos (tgm4883) on 2015-01-12
Changed in mythbuntu:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers