LCD backlight doesn't respond to brightness control keys

Bug #743352 reported by Mike on 2011-03-26
90
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Linux
Won't Fix
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

Pressing F1 or F2 on the keyboard brings up the little status indicator and the slider goes back and fourth, but the backlight doesn't actually get dimmer or brighter.
MacBook Pro 6,2 running 64-bit Mactel version of Alpha 3 of Natty Narwhal 11.04 fully updated as of March 26th

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6~3ubuntu11
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1440x900 1152x864 1024x768 800x600 640x480 720x400 640x400 640x350
 edid-base64: AP///////wAGEKOcAAAAAAATAQOAIRV4CvWVo1VPnCYPUFQAAAABAQEBAQEBAQEBAQEBAQEBqyKgoFCEGjAwIDYAS88QAAAYAAAAAQAGEDAAAAAAAAAAAAogAAAA/gBMUDE1NFdQNC1UTEExAAAA/gBDb2xvciBMQ0QKICAgAAA=
Date: Sat Mar 26 17:27:44 2011
DistUpgraded: Log time: 2011-03-21 07:46:42.331157
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-6-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-7-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation GT216 [GeForce GT 330M] [10de:0a29] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Apple Computer Inc. Device [106b:00c7]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64+mac (20110312)
MachineType: Apple Inc. MacBookPro6,2
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=daed62de-fdc0-40f1-b54f-2d6408f18d44 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: Upgraded to natty on 2011-03-24 (1 days ago)
dmi.bios.date: 07/26/10
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP61.88Z.0057.B0C.1007261552
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F22586C8
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro6,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22586C8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP61.88Z.0057.B0C.1007261552:bd07/26/10:svnAppleInc.:pnMacBookPro6,2:pvr1.0:rvnAppleInc.:rnMac-F22586C8:rvrMacBookPro6,2:cvnAppleInc.:ct10:cvrMac-F22586C8:
dmi.product.name: MacBookPro6,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Mike (bild85) wrote :
bugbot (bugbot) on 2011-03-28
affects: xorg (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Timo Aaltonen (tjaalton) on 2011-03-28
affects: xserver-xorg-input-evdev (Ubuntu) → linux (Ubuntu)
Graham Whelan (gawhelan) wrote :

This bug also affects me running 11.04 beta on a Macbook Pro 5,5

Daniel van Vugt (vanvugt) wrote :

This also happens on a Macbook Air 3,1 after installing the Nvidia driver. The backlight /did/ work before installing the Nvidia driver, when using the default vesa driver for xorg.

Reproduced with natty beta-1 and beta-2 (nvidia-current = 270.41.03-0ubuntu1).

Daniel van Vugt (vanvugt) wrote :

With the Macbook Air, you can take X out of the equation and reproduce the issue directly with the kernel by echoing various values into /sys/class/backlight/mbp_backlight/brightness

With the Nvidia driver active, doing so does nothing just like the brightness keys on the keyboard. Removing the Nvidia driver and rebooting (nomodeset) into the standard vesa xorg setup, both the brightness keys and writing values into the kernel (as above) work again.

Mario Vukelic (mario-vukelic) wrote :

Possibly there is some interest here for the similar bug #726692

Mike (bild85) wrote :

It is very similar. And I'll have to double-check, but I think my notifications stopped working too. Might be since I started using the Nvidia driver since the packaged one caused frequent system lock-ups.

Daniel van Vugt (vanvugt) wrote :

This hack fixes the bug for me (in /etc/X11/xorg.conf):

Section "Device"
 Identifier "Default Device"
 Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Now the control keys work, the notification bubble works and even direct control writing to /sys/class/backlight/mbp_backlight/brightness.

Changed in linux (Ubuntu):
status: New → Confirmed
Mike (bild85) wrote :

My /sys/class/backlight/ directory has no further items such as a mbp_backlight subfolder:

$ sudo ls -aFl /sys/class/backlight/
total 0
drwxr-xr-x 2 root root 0 2011-04-23 02:21 ./
drwxr-xr-x 49 root root 0 2011-04-23 02:21 ../
$

I tested it and the hack doesn't work for me. I modified /etc/X11/xorg.conf, rebooted, and the F1-F2 keys are still unresponsive:

$ cat /etc/X11/xorg.conf
Section "Screen"
 Identifier "Default Screen"
 DefaultDepth 24
EndSection

Section "Module"
 Load "glx"
EndSection

Section "Device"
 Identifier "Default Device"
 Driver "nvidia"
 Option "NoLogo" "True"
 Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection
$

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

The /sys/class/backlight/* folder will be populated by having the right
kernel module loaded. Try:
    sudo modprobe mbp_nvidia_bl
to load the Apple-specific backlight driver.

To see the other drivers available do:
    ls /lib/modules/`uname -r`/kernel/drivers/video/backlight/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNtFUQAAoJEAFPn4F5BP8oFmsH/jpKfTguyY5HkqVduJqCEo+x
g8jzMQkwPhdWIxG1Bc4TQBrQwhvaulXoBomxHDBPce+6XhnzAJKjGOJ78qXyEE52
BqI/YzkY3KTz3MyVJIexjTG2Y/4tTkRMBduAbc3+wwtkKXT2ddJiAGrqJBbUXWaV
RXuKUzn1+eF0ECjdcmzjtdE/pF0fe9lUGHF24apcYx8E9DyTcCBUJBNgB9VwCod5
4Ae4A1/r6V4Egcmpfm28X5Yzk0N0e9XHFyNxukdUPU/V8QqLL8b1/dDbjDu7ZQYo
Zk+LIPzqKAd+Ay/Mfg1/ZFw/oSGQ5I2aRRxySNX5Y1t8xAZsIaNgbJHz3vXvkrA=
=235l
-----END PGP SIGNATURE-----

Chad A. Davis (chadadavis) wrote :

Is this module specific to certain MacBook hardware. With MacBookPro6,2 it complains that I have "No such device". The xorg.conf setting described above also has no effect on my MBP6,2.

Mike (bild85) wrote :

Same here:
$ sudo modprobe mbp_nvidia_bl
FATAL: Error inserting mbp_nvidia_bl (/lib/modules/2.6.38-8-generic/kernel/drivers/video/backlight/mbp_nvidia_bl.ko): No such device
$

Mario Schwalbe (schwalbe) wrote :

With respect to the "No such device" error, please note that the upstream 2.6.38 version of mbp_nvidia_bl does not support more recent machines such as the MBP6,2. An updated package has always been available in the Mactel PPA for maverick. I didn't upload a natty package yet, because the driver has been renamed to apple_bl (and changed) in upstream 2.6.39, and I think it might be better to backport the newer upsteam driver for natty. However, new issues with the 8th generation might arise because the new version doesn't contain an explicit model list anymore. Please use the maverick version for now.

Daniel van Vugt (vanvugt) wrote :

I suggest finding a temporary setup where the backlight control works, in which the nvidia driver is not installed, and then looking at "lsmod | grep _bl" or the contents of /sys/class/backlight/ which should hint at the module name that controls it. We can't blame the nvidia driver if the backlight has never worked under any Linux on the machine (though that appears to be the problem on my MBA 3,1).

Also, you need to exclude the possibility that maybe your Macbook Pro hardware is still too new to be fully recognized by the 2.6.38 kernel in natty. So if you can't find a test setup above in which the backlight control ever works, please try temporarily installing the latest mainline kernel:
    http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.39-rc4-natty/ (linux-image-*.deb)
I notice there have been a couple of commits to the apple_bl (formerly mbp_nvidia_bl) module in those recent kernels.

Mario Schwalbe (schwalbe) wrote :

Update: Machines up to MacBookAir 2,1 and MacBook Pro 5,5 are supported by maverick's default mbp_nvidia_bl. The X-Org Option "RegistryDwords" "EnableBrightnessControl=1" might be necessary on some machines. Please, always check by writing to /sys/class/backlight/mbp_backlight/brightness, because function keys involve too much subsystems to reason about bugs.

Jonas Petersson (catellie) wrote :

For the record: I just made a quick test compiling the Maverick mbp_nvidia_bl package on my vanilla Natty MBP 6,1 and correctly finds the device now. However, as soon as I tried to adjust the level (F1) the screen went black and I had no way to get it sane again. I didn't have time to look deeper (I'm at work), but will try to dig deeper later.

(Off topic: I'm also unable to turn tapping off on the touchpad, but surprisingly hibernation worked at least once!)

Mike (bild85) wrote :

@Jonas - For your touchpad remark, take a look at bug #240738

mu3en (mu3en) wrote :

macbook 3,1 santa rosa:

keys work.
slider pops up.
/sys/.../brightness changes as expected (or can be changed manually).

but nothing happens to the brightness. this is intel GM965/GL960.

any other way to approach this?

Rainer Rohde (rainer-rohde) wrote :

I have the same issue on a MacBookPro5,2. The brightness adjustments only work when I use 'pommed', but 'pommed' does not provide an indicator. Since I want the full effects (brightness working and indicator working), I followed the tips here and still no joy.

Willem de Groot (gwillem) wrote :

I fixed this (on MBA3,2 with 64bit 11.04). I had the nvidia-bl-dkms package installed. Uninstalled, added the control lines to xorg.conf (as suggested above) and loaded the mbp_nvidia_bl module from 2.6.38-8-generic.

Bruno Beaufils (beaufils) wrote :

I fixed this too (on MBP6,2 with 64bit 11.04). I just have installed the mbp-nvidia-bl-dkms from the PPA archive from Maverick series after removed the nvidia-bl-dkms (apt-get install -t=maverick mbp-nvidia-bl-dkms) without any modifications in the xorg.conf file.

mu3en (mu3en) wrote :

on intel this problem still exists, not sure if the nvidia results would have any effect anyway.

derp herp (junkmail-trash) wrote :

Seeing this too on 11.04 and MBP 8,2. I could have sworn the backlight worked right after install, then never since.

Alex Murray (alexmurray) wrote :

@derp herp - make sure you don't have the nvidia_bl driver installed - instead I think you just need the mbp_nvidia_bl which comes with the standard kernel - if you have both, then the nvidia_bl conflicts and stops the mbp_nvidia_bl working correctly - uninstall nvidia_bl and then reboot and see if it works.

Alex Murray (alexmurray) wrote :

Ahh whoops just saw its 8,2 which has an ATI GPU instead - ignore my comments.

derp herp (junkmail-trash) wrote :

Yep, wasted two days trying to figure out what broke it. So far I have tried:

- Installing all the natty mactel ppa debs
- Uninstalling all the natty mactel ppa debs
- Adding Option "RegistryDwords" "EnableBrightnessControl=1" to my Device section
- Installed pommed
- Downgrading g-p-m
- Kernel 2.3.39-2 oneric with apple_bl module
- Trying to load mbp_nvidia_bl with 2.3.38
- various acpi settings

Still, nothing works.

derp herp (junkmail-trash) wrote :

What really chaps my ass is this worked immediately after install, but failed after a dist-upgrade so it must be a regression somewhere.

derp herp (junkmail-trash) wrote :

I'm going to build a 2.3.39 kernel with this patch and report back:

http://ubuntuforums.org/showpost.php?p=10685211&postcount=230

derp herp (junkmail-trash) wrote :

No joy.

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: noah 2940 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xb0900000 irq 46'
   Mixer name : 'Cirrus Logic CS4206'
   Components : 'HDA:10134206,106b1d00,00100301'
   Controls : 22
   Simple ctrls : 13
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xb0840000 irq 47'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 11.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64+mac (20110427.1)
MachineType: Apple Inc. MacBookPro8,2
NonfreeKernelModules: fglrx
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=7caf1bd6-e457-4a37-94e7-18fc8174d65a ro nomodeset noacpi reboot=acpi resume=/dev/mapper/cryptswap1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
RfKill:

StagingDrivers: r8712u
Tags: natty running-unity staging
Uname: Linux 2.6.38-8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WifiSyslog:
 Jul 19 09:38:36 paperweight kernel: [52723.030192] applesmc: FS! : read arg fail
 Jul 19 09:38:51 paperweight kernel: [52738.177781] applesmc: FS! : read arg fail
dmi.bios.date: 04/22/11
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP81.88Z.0047.B0E.1104221557
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-94245A3940C91C80
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro8,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-94245A3940C91C80
dmi.modalias: dmi:bvnAppleInc.:bvrMBP81.88Z.0047.B0E.1104221557:bd04/22/11:svnAppleInc.:pnMacBookPro8,2:pvr1.0:rvnAppleInc.:rnMac-94245A3940C91C80:rvrMacBookPro8,2:cvnAppleInc.:ct10:cvrMac-94245A3940C91C80:
dmi.product.name: MacBookPro8,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

tags: added: apport-collected staging

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

derp herp (junkmail-trash) wrote :

Hoping this will help

indium (indium) wrote :

I had the following problems (mbp6,2 + ubuntu 11.04):

no backlight control
no notifier-popup which usually shows that pommed is running/working

Then I noticed that (the standard) nvidia_bl was not loaded. I loaded it with sudo modprobe nvidia_nl.
Now the pop-up (on the upper righthand side of the screen) 'worked' again, but no change in brightness.

I stopped pommed (sudo service pommed stop) and ran it manually with debug mode which shows that it adjusts the level from 0 to 2047 when hitting F1/F2 (or Fn-F1/Fn-F2 if you have fn-mode set to 2 in /etc/pommed.conf).

similar, pommed -f showed it was happy with what it found (no backlight complaints).

I reverted to mbp_nvidia_bl as a test and this worked:
uninstall the nvidia_bl in 'synaptic package manager'.
go to the repository in the 'settings' menu there and add the old maverick repository for mactel:
click on add in the 'other software' tab and fill in 'deb http://ppa.launchpad.net/mactel-support/ppa/ubuntu maverick main'
back in the main window of the synaptic package manager you 'reload' and install the mbp_nvidia_bl

After a reboot, you first have to check whether mbp_nvidia_bl is loaded. (otherwise do 'sudo modprobe mbp_nvidia_bl')

My /etc/X11/xorg.conf does not contain the extra option (commented out):
    #Option "RegistryDwords" "EnableBrightnessControl=1"

I don't have a '_bl' anymore in the blacklists: 'grep bl /etc/modprobe.d/*' gives nothing.

MY RESUME FROM SUSPEND IS NOW MUCH FASTER!!!!!

indium (indium) wrote :

Follow-up from prev post: you might want to switch off the maverick repository again afterwards! and 'reload' the software lists.

derp herp (junkmail-trash) wrote :

apple-bl-dkms from here has resolved my issue:

https://launchpad.net/~alexmurray/+archive/ppa

Tomodachi (tomodachi) wrote :

how can one describe happines in simple words!

* Installed the apple-bl-dkms package form the ppa above
* load the new module ,

and brighness settings work!!

and im in EFI mode on my macbok 5.1
with one of my gpu:s disabled!

joy!!!!
:)

mu3en (mu3en) wrote :

macbook 4.1 santa rosa (intel graphics) brightness adjustment seems to work fine again with 64bit kubuntu 11.10 since a few weeks without special configuration. nice job.

Joseph Salisbury (jsalisbury) wrote :

@Mike and others

Can you test the latest release of 11.10 and confirm the issue is resolved without any special configuration?

Mike (bild85) wrote :

I installed 11.10 beta as an upgrade to 11.04 where I made some changes, so my current platform is not a good test subject. Will install 11.10 fresh when I figure out how to upgrade to Lion and preserve my other two OSes at the same time.

Li Li (lli5) wrote :

FYI. I'm not sure about 11.10. But at least 12.04 has fixed this issue.

mu3en (mu3en) wrote :

confirm working on 11.10 without specific configuration except:
ppa kubuntu-beta and kubuntu-backports enabled to provide kde4.8RC

macbook santarosa 4.1, Intel GM965/GL960

Mike, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please provide the information following https://wiki.ubuntu.com/Kernel/Debugging/Backlight#Report_Minimum_Requirements ?

As well, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Please let us know your results. Thank you for your understanding.

affects: mactel-support → linux
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux:
status: New → Won't Fix
Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers