Ubuntu

Natty: the driver sp5100_tco prevents PC startup

Reported by malbo on 2011-03-22
128
This bug affects 24 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Herton R. Krzesinski
Natty
Undecided
Herton R. Krzesinski

Bug Description

Binary package hint: gnome-system-monitor

So that my PC Acer Aspire M5100 can function normally with Natty, I have to blacklist the driver sp5100_tco. Otherwise, if the driver is not blacklisted (normal configuration of Natty) and if I restart the PC, the PC reboots every two seconds and never takes off. Then I have to unplug the power cord and reconnect a few seconds. In these conditions, the PC can start. I tried a "clear CMOS" but without success.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-system-monitor 2.28.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.37-generic-pae 2.6.38
Uname: Linux 2.6.38-7-generic-pae i686
Architecture: i386
Date: Tue Mar 22 08:36:34 2011
ExecutablePath: /usr/bin/gnome-system-monitor
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
SourcePackage: gnome-system-monitor
UpgradeStatus: No upgrade log present (probably fresh install)
XsessionErrors: (nautilus:1498): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed

malbo (pique-sel) wrote :
malbo (pique-sel) wrote :

Previously, I was able to meet the dmesg file ( dmesg_liveCD_Natty_Alpha3.txt) obtained in session live-CD Ubuntu Natty Alpha3. can be seen in this file the three lines for "SP5100 TCO timer" who is the driver that is causing problems

affects: gnome-system-monitor (Ubuntu) → linux (Ubuntu)
Herton R. Krzesinski (herton) wrote :

It would be good to get the dmesg/kernel log when the system fails to start, probably there is a warning/oops, so we can probably see exactly what the problem is.

In any case, this may be a recent bug discovered with some bioses and sp5100_tco, and a fix was made to sp5100_tco to avoid the specific situation. Can you install and test with sp5100_tco not blacklisted the kernel I uploaded at http://people.canonical.com/~herton/lp740011/ ? Also please attach the dmesg with this new kernel.

Changed in linux (Ubuntu):
status: New → Incomplete

Debian has blacklisted this module.

:~$ uname -r
2.6.38-1-amd64
:~$ grep -i sp5100 /boot/config-`uname -r`
# CONFIG_SP5100_TCO is not set

malbo (pique-sel) wrote :

Thanks Herton.
I hope the following can help :
1) start PC (driver sp5100_tco blacklisted)
2) driver sp5100_tco authorized
3) restart PC (no problem, no bug)
Just after restart, I store dmesg (dmesg_819.txt) and dmesg0 (dmesg0_819.txt)
4) restart PC (now the bug exist and I have to unplug the power cord and reconnect)
Just after restart, I store dmesg (dmesg_833.txt) and dmesg0 (dmesg0_833.txt).

Attached : the kern.log (kernlog_201103300922.txt) with the driver sp5100_tco authorized at the end of the log

malbo (pique-sel) wrote :
malbo (pique-sel) wrote :
malbo (pique-sel) wrote :
malbo (pique-sel) wrote :
malbo (pique-sel) wrote :

Herton,
You wrote : "Can you install and test with sp5100_tco not blacklisted the kernel I uploaded at http://people.canonical.com/~herton/lp740011/ ? Also please attach the dmesg with this new kernel."
I don't realize that immediately because I have never made that and I will ask for help in the French Ubuntu forum.

malbo (pique-sel) wrote :

After install of your parched kernel, the bug seems fixed.
1) first restart after install : I store dmesg (dmesg_1222.txt) and dmesg0 (dmesg0_1222.txt)
2) second restart : I store dmesg (dmesg_1234.txt) and dmesg0 (dmesg0_1234.txt)
I restart, restart and no more problem. All is solved.

malbo (pique-sel) wrote :
malbo (pique-sel) wrote :
malbo (pique-sel) wrote :
malbo (pique-sel) wrote :

I made the same on my wubi-install of natty (64bits) on the same PC because my wubi-install also had the bug.
After install of your patched kernel (amd64), I store store dmesg (dmesg_1339.txt) and dmesg0 (dmesg0_1339.txt)
The bug is also fixed for my wubi-install.
Bravo Herton.

malbo (pique-sel) wrote :
Herton R. Krzesinski (herton) wrote :

Thanks for the testing, indeed this is the case of a bios bug, with the patched kernel we have now:

[ 16.213098] SP5100 TCO timer: mmio address 0xfec000f0 already in use

sp5100_tco sees the address is already used now and doesn't load. The fix is on its way to stable, so should soon appear in a stable update and ubuntu kernel.

Changed in linux (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Herton R. Krzesinski (herton)
Tim Gardner (timg-tpi) on 2011-04-06
Changed in linux (Ubuntu Natty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-8.42

---------------
linux (2.6.38-8.42) natty; urgency=low

  [ David Henningsson ]

  * SAUCE: (drop after 2.6.38) ALSA: HDA: Fix dock mic for Lenovo
    X220-tablet
    - LP: #751033

  [ Gustavo F. Padovan ]

  * SAUCE: Revert "Bluetooth: Add new PID for Atheros 3011"
    - LP: #720949

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: (drop after 2.6.39) v4l: make sure drivers supply a zeroed
    struct v4l2_subdev
    - LP: #745213

  [ John Johansen ]

  * AppArmor: Fix masking of capabilities in complain mode
    - LP: #748656

  [ Leann Ogasawara ]

  * [Config] Disable CONFIG_RTS_PSTOR for armel, powerpc

  [ Manoj Iyer ]

  * SAUCE: (drop after 2.6.38) add support for Lenovo tablet ID (0xE6)
    - LP: #746652

  [ Steve Langasek ]

  * [Config] Make linux-libc-dev coinstallable under multiarch
    - LP: #750585

  [ Tim Gardner ]

  * [Config] CONFIG_RTS_PSTOR=m
    - LP: #698006

  [ Upstream Kernel Changes ]

  * Revert "tcp: disallow bind() to reuse addr/port"
    - LP: #731878
  * ALSA: HDA: Add dock mic quirk for Lenovo Thinkpad X220
    - LP: #746259
  * ALSA: HDA: New AD1984A model for Dell Precision R5500
    - LP: #741516
  * Input: sparse-keymap - report scancodes with key events
  * Input: sparse-keymap - report KEY_UNKNOWN for unknown scan codes
  * KVM: SVM: Load %gs earlier if CONFIG_X86_32_LAZY_GS=n
    - LP: #729085
  * watchdog: sp5100_tco.c: Check if firmware has set correct value in
    tcobase.
    - LP: #740011
  * staging: add rts_pstor for Realtek PCIE cardreader
    - LP: #698006
  * staging: fix rts_pstor build errors
    - LP: #698006
  * Staging: rts_pstor: fixed some brace code styling issues
    - LP: #698006
  * staging: rts_pstor: potential NULL dereference
    - LP: #698006
  * Staging: rts_pstor: fix read past end of buffer
    - LP: #698006
  * staging: rts_pstor: delete a function
    - LP: #698006
  * staging: rts_pstor: fix sparse warning
    - LP: #698006
  * staging: rts_pstor: fix a bug that a greenhouse sd card can't be
    recognized
    - LP: #698006
  * staging: rts_pstor: optimize kmalloc to kzalloc
    - LP: #698006
  * staging: rts_pstor: MSXC card power class
    - LP: #698006
  * staging: rts_pstor: modify initial card clock
    - LP: #698006
  * staging: rts_pstor: set lun_mode in a different place
    - LP: #698006
  * x86, hibernate: Initialize mmu_cr4_features during boot
    - LP: #752870
 -- Leann Ogasawara <email address hidden> Fri, 08 Apr 2011 09:24:59 -0700

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released
malbo (pique-sel) wrote :

I confirm. This bug was fixed on my PC after the last update : package linux 2.6.38-8.41 to 2.6.38-8.42

Using 2.6.38-8 kernel in lucid (https://launchpad.net/~kernel-ppa/+archive/ppa?field.series_filter=lucid)

After updating to 2.6.38-8.42 i noticed following warning, that appeared in tty console
"16.370050 SP5100 TCO timer: mmio address 0xfec000f0 already in use"
The only relevant boot problem was a failed boot in recovery mode
(motherboard beeping suggested power problem)

Blacklisted SP5100_tco and the warning does not appear anymore.

lavinog (lavinog) wrote :

I am having this problem with the beta2 live cd (64bit)
I started writing about the issue on the forum:
http://ubuntuforums.org/showthread.php?t=1733315

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

I was able to boot by disabling all of the F6 options.
I will try to isolate the option that allowed the boot later today.

mogliii (mogliii) wrote :

Using Linux Desktop 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux in 11.04.

The message "SP5100 TCO timer: mmio address 0xfec000f0 already in use" appears on the splash screen and breaks the high resolution. http://img824.imageshack.us/img824/7269/tcotimer.jpg

System boots and works besides that. Relevant lines in dmesg

[ 8.620666] EXT3-fs: barriers not enabled
[ 8.621803] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 8.621967] SP5100 TCO timer: mmio address 0xfec000f0 already in use
[ 8.622650] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[ 8.622656] Disabling lock debugging due to kernel taint

KeithG (grider-4) wrote :

Same deal. 64 bit 11.04 freah install. Found the udev problem: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622340 and this as well. This does not show up in dmesg, but does break the boot screen.

KeithG

KeithG (grider-4) wrote :

oops, It is in the log. I just could not find it initially:

[ 22.818332] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 22.818426] SP5100 TCO timer: mmio address 0xfec000f0 already in use

It is running on a Gigabyte GA-MA78LMT-S2 board with the latest V14 BIOS.

KeithG

Chris Morison (cmorison) wrote :

I get the "address .... already in use" message during plymouth splash:

[ 13.591205] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 13.591470] SP5100 TCO timer: mmio address 0xb8fe00 already in use

Running on an Acer Aspire One 522 (AO522) with 2.6.38-8-generic #42-Ubuntu.

Let me know if there's any more information I can provide or testing I can do. It's been a long while since I seriously used linux/unix though...

Sam L. (somethinginteres) wrote :

I'm using Natty 11.04 64bit on a Toshiba NB550D. All updates applied after a fresh install. I'm running the kernel "Linux ubuntu 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux"

dmesg shows the following error:

[ 8.330467] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 8.333813] SP5100 TCO timer: mmio address 0xb8fe00 already in use

The error on the second line also shows during plymouth splash. Please let me know if I can provide any further details.

michal plichta (mplichta) wrote :

same here on Dell Zino HD AMD Athlon 64 X2 6850E 2GB 1TB ATI

Gavin Faux (gavin-faux) wrote :

$ uname -a

Linux home 2.6.38-8-generic-pae #42-Ubuntu SMP Mon Apr 11 05:17:09 UTC 2011 i686 athlon i386 GNU/Linux

$ dmseg (clipped)

[ 19.695606] ACPI: resource piix4_smbus [io 0x0b00-0x0b07] conflicts with ACPI region SOR1 [io 0xb00-0xb0f]
[ 19.695608] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 19.837909] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 19.837970] SP5100 TCO timer: mmio address 0xfec000f0 already in use

Hardware list attached.

Geert (geert-x) wrote :

Same issue on HP Pavilion DM1.

 $ uname -a
Linux GeertNetbook 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

dmesg
[ 14.051466] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 14.051521] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[ 14.051625] SP5100 TCO timer: mmio address 0xb8fe00 already in use

Craig l300lvl (l300lvl) wrote :

Confirmed the above on HP DM1
[ 12.014989] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 12.015178] SP5100 TCO timer: mmio address 0xb8fe00 already in use

Tommy_CZ (t-kijas) wrote :

Confirmed in the Acer Aspire One 722 and latest fresh install of Kubuntu 11.04 64bit
dmesg:
[ 18.178665] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 18.178937] SP5100 TCO timer: mmio address 0xb8fe00 already in use

mick (mount-michael) wrote :

Also happens on my HP g61 11.04 and newest kernel (2.6.38-10-generic) with only the second message appearing.
I have noticed that most people that have this problem tend to have AMD processors and ATI graphics cards.
Perhaps the problem is related to this (sorry if this is either obvious or stupid, I am quite new to the linux framework)

Alex (alexandre-garce) wrote :

Same problem for me with a 64bit ubuntu and the latest update to the kernel : 2.6.38-10-generic.
I have an AMD processor and a nvidia graphic card.

Tony Whelan (tony-whelan) wrote :

Running Ubuntu Natty 2.6.38-10-generic, 32 bit.

AMD Phenom II quad core CPU
ATI Radeon HD5750 dual DVI graphics card

DMESG shows:

[ 25.680539] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 25.680610] SP5100 TCO timer: mmio address 0xfec000f0 already in use
[ 26.017930] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[ 26.017933] Disabling lock debugging due to kernel taint

mogliii (mogliii) wrote :

The behavior I reported 1st May (high-res splash screen broken and message displayed) appears to be connected to fglrx.
On a netbook with AMD C-50 APU (Radeon 6250) I can reversibly (already tested three times) restore the high-res splash by disabling the fglrx driver.
My theory (correct me if I am wrong):
1) Video driver breaks high res splash screen
2) Messages that are shown do always occur, but are hidden with high-res splash.

I am using luks full system encryption so there is a password prompt after grub. Without fglrx the input is very nice, but with fglrx the splash is already broken and the prompt is console like. "TCO timer" message appears after password input.

michal plichta (mplichta) wrote :

#moglii: by disabling driver u mean: https://help.ubuntu.com/community/RadeonDriver

mogliii (mogliii) wrote :

By disabling I mean using the jockey-gtk/jockey-kde dialog:
http://imageshack.us/photo/my-images/580/snapshot1bp.png/
(screenshot taken in a VM, so no driver offered)

mogliii (mogliii) wrote :

@mplichta: Did you try it? Did it restore the high-resolution splash?

michal plichta (mplichta) wrote :

#moglii: not yet

michal plichta (mplichta) wrote :

#moglii: removing close source graphics driver solved the problem.

mogliii (mogliii) wrote :

I upgraded my Kubuntu to 11.10, and the high resolution splash screen shows as it should. Also the passphrase prompt when using LUKS. I did not reinstall video driver, Ati fglx still used.

Can I recommend that, before closing this report, we wait for one more report if this was resolved.

So to all subscribers: Report here after upgrade if it resolved or not. Please!

Mike Mestnik (cheako) wrote :

3.2.0-9-generic-pae

I'd like to use this watchdog.

Mike Mestnik (cheako) wrote :

...ohh and I get the same warning.

OvermindDL1 (overminddl1) wrote :

Been experiencing this bug for about a year, perhaps more at this point, and in 11.10 it is still not fixed, thus fix is not confirmed (both the "SP5100 TCO timer: mmio address 0xb8fe00 already in use" message and the non-fancy splash/loading screen). Looking forward to if 12.04 fixes it.

Marco (marcodefreitas) wrote :

The problem persists in 12.04.

Christopher (soft-kristal) wrote :

I also have the issue in 12.04, but just the 32 bit version. This from dmsg:

 45.998733] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 45.998803] SP5100 TCO timer: mmio address 0xb8fe00 already in use

It doesn't seem to be doing anything evil, but it should be fixed.

Michael Lazarev (milaz) wrote :

I also have this issue in 12.04, but for 64 bit version. I am able to boot, but the warning appears in dmesg:

[ 8.035629] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[ 8.035741] SP5100 TCO timer: mmio address 0xb8fe00 already in use

nvbn (nvbn-rm) wrote :

Boot stuck with same error.
Ubuntu 12.04 amd64

Christopher (soft-kristal) wrote :

My comment #46 was not accurate - the bug exits on my 64 bit partition as well. It doesn't show at boot but it is in the dmsg log.

semitones (semitones) wrote :

Is anyone still working on this bug? I've read through the last few comments, and I still have this issue in 64bit 12.04

malbo (pique-sel) wrote :

@semitones :
See "Bug Description" : "the PC reboots every two seconds and never takes off". This very serious bug is fixed. You can see a few lines in your dmesg (like in comment #47), but that is not the bug.

Sasa Paporovic (melchiaros) wrote :

I have runned in situation wher SP5100 is also involved on a dual boot solution with Quantal and Precise.

I have filed it very specific for this.

Anyway, those ones who are affected on Ubuntu12.04 may want to look at this report:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1055096

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.