Ubuntu

Toshiba Satellite L305 hotkeys not working

Reported by Jeremy Bicha on 2011-03-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Seth Forshee

Bug Description

About half of my laptop hotkeys work so I've been trying to follow the steps in https://wiki.ubuntu.com/Hotkeys/Troubleshooting but I'm unable to get the scancodes for the non-working keys.

lsmod | grep toshiba_acpi produces nothing. dmesg doesn't produce any messages about keys.

sudo /lib/udev/findkeyboards reports
AT keyboard: input/event3

sudo /lib/udev/keymap -i input/event3 & sudo input-events 3 show scancodes for the working hotkeys but nothing for the non-working ones. xev wasn't useful either.

Examples of working keys are: Mute, VolumeUp, and Play. Nonworking keys include MediaPlayer, & several Fn combinations like BrightnessUp, WiFi on/off, Touchpad On/Off.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-6-generic 2.6.38-6.34
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jeremy 15795 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd6700000 irq 47'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,1179ff66,00100003 HDA:11c11040,11790001,00100200'
   Controls : 13
   Simple ctrls : 8
Date: Tue Mar 15 17:19:05 2011
HibernationDevice: RESUME=UUID=24a8bfc3-3ab7-4f40-9580-696a993fca73
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: TOSHIBA Satellite L305
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic root=UUID=f5f5a49b-02ef-43a4-a8c8-e436a4a08f21 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-6-generic N/A
 linux-backports-modules-2.6.38-6-generic N/A
 linux-firmware 1.48
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-01-01 (73 days ago)
dmi.bios.date: 09/23/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: 2.10
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr2.10:bd09/23/2009:svnTOSHIBA:pnSatelliteL305:pvrPSLB8U-05202F:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Satellite L305
dmi.product.version: PSLB8U-05202F
dmi.sys.vendor: TOSHIBA

Jeremy Bicha (jbicha) wrote :
description: updated
Seth Forshee (sforshee) wrote :

Can you also supply the output from lsinput ? Thanks.

Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) on 2011-03-15
summary: - Toshia Satellite L305 hotkeys not working
+ Toshiba Satellite L305 hotkeys not working
Seth Forshee (sforshee) wrote :

I suspect the multimedia keys are reported via ACPI, and perhaps some of the others. Hopefully the toshiba_acpi driver will support this model with a few modifications. Can you run the following commands and attach the DSDT.dsl file that gets created? You'll need to install the fwts package if you don't already have it.

  sudo fwts --disassemble-aml

Jeremy Bicha (jbicha) wrote :
Seth Forshee (sforshee) wrote :

Unfortunately it looks like Toshiba has changed their ACPI interfaces from the ones the toshiba_acpi driver currently supports. It does look like someone has attempted to get these machines working though and may have already done most of the hard work though. The lkml thread below has a few versions of a patch, but it looks like the discussion stopped in December without anything being merged. I'll put together a test build with the patch when I get a chance.

https://lkml.org/lkml/2010/10/26/350

Changed in linux (Ubuntu):
status: New → In Progress
Seth Forshee (sforshee) wrote :

Adding a link to another thread with patches related to these machines. It looks like there may still be some issues to work out.

https://lkml.org/lkml/2011/1/17/164

Seth Forshee (sforshee) wrote :

I put some amd64 debs up for testing at http://people.canonical.com/~sforshee/lp735756/. Let me know whether or not they get your hotkeys working.

It looks like maybe the upstream maintainers thought the patch itself needed a little work before it was ready to be merged, so I'll take a closer look at it when I get a chance.

Changed in linux (Ubuntu):
status: In Progress → Incomplete
Jeremy Bicha (jbicha) wrote :

Ok, I'm running your patched kernel now.

sudo lsmod | grep tosh
toshiba_acpi 18687 0
sparse_keymap 13890 1 toshiba_acpi

from dmesg:
[ 28.777868] toshiba_acpi: Toshiba Laptop ACPI Extras version 0.20
[ 28.777878] toshiba_acpi: HCI type 3 (SPFC)
[ 28.778431] input: Toshiba input device as /devices/virtual/input/input5

By the way, my keyboard looks like this: http://209.167.114.38/support/techsupport/tsbs/all/-TSB001343.htm

No additional hotkeys were working...but I was playing with fwts earlier today. I was doing pretty well on the interactive test until it asked me to press the powerbutton which turned off my computer. When I restarted, none of the events were working...until I suspended the computer and rewoke the computer. So I tried suspending and resuming the patched kernel. Now Fn+F8 (wifi on/off) works, Fn+Esc (mute) works but the dedicated mute button doesn't work (this did work on the normal Natty kernel). The other Fn keys (except for numlock, cursorlock, and scrollock) still don't work. (Brightness keys for instance worked with fwts but doesn't work with the current Natty kernel or this patched one).

So I tried keymap again with input 5, which recognized the Fn keys (except for numlock, cursor, and scrolllock), except it says "no scan code received, key code: mute" for instance. sudo input-events 5 worked so I'm attaching the results I got from that.

Jeremy Bicha (jbicha) wrote :

I was having problems with gnome-power-manager because I was also testing gnome3. I can confirm now that the brightness keys, lock screen, suspend and probably hibernate Fn keys are working now.

Still not working: dedicated mute & media player buttons, wifi Fn key and the 3 "zoom" buttons but generally this is a lot better than the normal Ubuntu kernel.

Seth Forshee (sforshee) wrote :

At least we've got some progress!

Do you get anything for the hotkeys that aren't working from keymap or input-events? You'll probably have to check a different input device than your AT keyboard. If findkeyboards doesn't show anything new use lsinput and look for a device named "Toshiba input device".

If you don't see events for the keys, check dmesg for strings like "toshiba_acpi: Unknown key" followed by a scancode value. If you're seeing these report back the scancodes and intended functions, and I can augment the scancodes toshiba_acpi knows about to include these keys.

Seth Forshee (sforshee) wrote :

@Jeremy:

I put up a new build (2.6.38-7.38~saf02lp735756). It includes a newer version of the patch as well as some changes that will give you some output from keymap/input-events even if toshiba_acpi doesn't know about the hotkeys yet.

http://people.canonical.com/~sforshee/lp735756/

Seth Forshee (sforshee) wrote :

The upstream subsystem maintainer isn't going to take the changes to support these models -- he sees it as too risky and has plans to completely rewrite the driver. Hotkey support for these models is in limbo until that gets sorted out. Marking Won't Fix.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
Paul Weiss (interweiss) wrote :

This ACPI bug also affects the Toshiba L745D. The brightness, suspend, hibernate, and wireless keys do not work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers