BUG: unable to handle kernel NULL pointer dereference at 000001e4

Bug #735450 reported by Bluppie on 2011-03-15
190
This bug affects 18 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Herton R. Krzesinski

Bug Description

file manager is starting over and over, even more than 10 times. This was the first time I get an kernel issue. I don't now off the file manager is an part off the problem. Ubuntu 11.04 troubles?

ProblemType: KernelOops
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-6-generic 2.6.38-6.34
Regression: Yes
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Annotation: Your system might become unstable now and might need to be restarted.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ben 2034 F.... pulseaudio
 /dev/snd/controlC0: ben 2034 F.... pulseaudio
CRDA: Error: [Errno 2] Bestand of map bestaat niet
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd0340000 irq 45'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,10250000,00100002 HDA:11c13026,10250110,00100700'
   Controls : 26
   Simple ctrls : 16
Card1.Amixer.info:
 Card hw:1 'Speaker'/'ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ Logitech Speake'
   Mixer name : 'USB Mixer'
   Components : 'USB08bb:2704'
   Controls : 2
   Simple ctrls : 1
Date: Tue Mar 15 11:24:52 2011
Failure: oops
Frequency: I don't know.
HibernationDevice: RESUME=UUID=daac492d-2c2b-48a5-b2b4-dc70694ce852
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: Acer, inc. Aspire 3680
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic root=UUID=57d38d9d-4214-4ae9-9d3e-25e16e2d83d7 ro splash vga=795 quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-6-generic N/A
 linux-backports-modules-2.6.38-6-generic N/A
 linux-firmware 1.48
SourcePackage: linux
Title: BUG: unable to handle kernel NULL pointer dereference at 000001e4
UpgradeStatus: Upgraded to natty on 2011-03-10 (4 days ago)
dmi.bios.date: 10/27/06
dmi.bios.vendor: Acer
dmi.bios.version: v1.3216
dmi.board.name: Prespa1
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3216:bd10/27/06:svnAcer,inc.:pnAspire3680:pvrNotApplicable:rvnAcer,Inc.:rnPrespa1:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 3680
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.

Bluppie (benhyper) wrote :
Herton R. Krzesinski (herton) wrote :

Please test the kernel which I uploaded at http://people.canonical.com/~herton/lp735450/ and see if the problem still happens with it.

Changed in linux (Ubuntu):
status: New → Incomplete
assignee: nobody → Herton R. Krzesinski (herton)
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Bluppie (benhyper) wrote :

Solved after an update and removing Bazaar.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-8.40

---------------
linux (2.6.38-8.40) natty; urgency=low

  [ Brad Figg ]

  * [Config] Set CONFIG_NR_CPUS=256 for amd64 generic
    - LP: #737124

  [ Henrik Rydberg ]

  * SAUCE: HID: hid-ntrig: add support for 1b96:0006 model
  * SAUCE: HID: ntrig: fix suspend/resume on recent models

  [ Kees Cook ]

  * [Config] packaging: adjust perms on vmlinuz as well
  * SAUCE: nx-emu: further clarify dmesg reporting
    - LP: #745181

  [ Leann Ogasawara ]

  * rebase to v2.6.38.1
  * [Config] update configs after v2.6.38.1 rebase
  * rebase to v2.6.38.2

  [ Manoj Iyer ]

  * SAUCE: thinkpad-acpi: module autoloading for newer Lenovo ThinkPads.
    - LP: #745217

  [ Tim Gardner ]

  * SAUCE: INR_OPEN=4096
    - LP: #663090

  [ Upstream Kernel Changes ]

  * (drop after v2.6.38) HID: ntrig don't dereference unclaimed hidinput
  * (drop after v2.6.38) HID: ntrig: apply NO_INIT_REPORTS quirk
  * (drop after v2.6.38) HID: hid-ntrig: init settle and mode check
  * eeepc-wmi: add hotplug code for Eeepc 1000H
  * eeepc-wmi: serialize access to wmi method
  * eeepc-wmi: return proper error code in eeepc_rfkill_set()
  * eeepc-wmi: add an helper using simple return codes
  * eeepc-wmi: add hibernate/resume callbacks
  * eeepc-wmi: switch to platform_create_bundle()
  * eeepc-wmi: reorder defines
  * eeepc-wmi: use the presence bit correctly
  * eeepc-wmi: add camera and card reader support
  * eeepc-wmi: add wimax support
  * eeepc-wmi: set the right key code for 0xe9
  * eeepc-wmi: support backlight power (bl_power) attribute
  * eeepc-wmi: respect wireless_hotplug setting
  * eeepc-wmi: real touchpad led device id is 0x001000012
  * eeepc-wmi: comments keymap to clarify the meaning of some keys
  * eeepc-wmi: add touchpad sysfs file
  * eeepc-wmi: reorder device ids

  [ Major Kernel Changes ]

  * rebase from v2.6.38 to v2.6.38.1
    - LP: #735640, #735450
  * rebase from v2.6.38.1 to v2.6.38.2
    - LP: #733780
 -- Leann Ogasawara <email address hidden> Mon, 28 Mar 2011 06:20:13 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

MAybe a stupid question, but I'm relatively new to Ubuntu and could not find an answer so far: This new kernel version does not yet seem to be known to apt.
Do I need to add ppa:kernel-ppa/ppa or a similar ppa, or will I simply have to wait until the newly built package hits the mirrors?

Herton R. Krzesinski (herton) wrote :

@Gunter -- just wait the packages to appear on mirrors

ianr (mrzx4l-ubuntu) wrote :

Hello all, I am on linux 2.6.38-10-generic and still get this crash on a regular basis, as soon as I turn the screen on in my 11.04 media server, consequently it's largely useless now and will be downgrading to 10 sometime soon-ish. I've attached the oops report, the running process is normally either upowerd or Xorg.

tags: added: i915
tags: added: kernel-driver-i915
To post a comment you must log in.