kvm_amd and qemu: BUG: unable to handle kernel NULL pointer dereference at 00000014

Bug #729085 reported by Andreas Moog on 2011-03-04
56
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Herton R. Krzesinski
Natty
Undecided
Herton R. Krzesinski

Bug Description

When running qemu with kvm_amd module loaded I get this error. Running without kvm module is fine, but of course much slower.

[12021.561658] BUG: unable to handle kernel NULL pointer dereference at 00000014
[12021.561664] IP: [<f8e0fa92>] x86_decode_insn+0x12/0x9b0 [kvm]
[12021.561681] *pde = bf3ce067
[12021.561683] Oops: 0000 [#4] SMP
[12021.561685] last sysfs file: /sys/devices/virtual/misc/kvm/uevent
[12021.561688] Modules linked in: kvm_amd kvm cryptd aes_i586 aes_generic dm_crypt nvidia(P) snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq bridge stp snd_timer snd_seq_device snd i2c_nforce2 soundcore snd_page_alloc ppdev parport_pc k10temp lp parport usbhid hid pata_amd sata_nv forcedeth
[12021.561705]
[12021.561708] Pid: 22238, comm: qemu Tainted: P D 2.6.38-5-generic #32-Ubuntu MSI MS-7309/K9N6PGM2-V2 (MS-7309)
[12021.561712] EIP: 0060:[<f8e0fa92>] EFLAGS: 00010292 CPU: 1
[12021.561722] EIP is at x86_decode_insn+0x12/0x9b0 [kvm]
[12021.561724] EAX: ebae9454 EBX: ebae9454 ECX: 00000000 EDX: 00000000
[12021.561725] ESI: f8e226e0 EDI: 00000000 EBP: f50b3de0 ESP: f50b3d8c
[12021.561727] DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[12021.561729] Process qemu (pid: 22238, ti=f50b2000 task=ed706500 task.ti=f50b2000)
[12021.561731] Stack:
[12021.561732] f50b3dd0 f50b3dcc f50b3dc0 f8df1949 000f0000 00000000 0000ffff 010bf000
[12021.561736] 00010000 00000000 f8da0020 ebae8000 00000000 f50b3de0 f8dfa585 ebae9484
[12021.561739] 00000000 00000000 ebae8000 ebae9454 00000000 f50b3e00 f8dfaa02 f8da0020
[12021.561743] Call Trace:
[12021.561753] [<f8df1949>] ? kvm_get_cs_db_l_bits+0x29/0x50 [kvm]
[12021.561762] [<f8dfa585>] ? init_emulate_ctxt+0x45/0x130 [kvm]
[12021.561771] [<f8dfaa02>] x86_emulate_instruction+0x162/0x450 [kvm]
[12021.561775] [<f8d96f53>] emulate_on_interception+0x23/0x30 [kvm_amd]
[12021.561778] [<f8d99c9f>] cr_interception+0x7f/0x210 [kvm_amd]
[12021.561781] [<f8d9c13f>] handle_exit+0x15f/0x405 [kvm_amd]
[12021.561786] [<c10e8659>] ? __alloc_pages_nodemask+0xf9/0x710
[12021.561795] [<f8df95dd>] ? kvm_get_cr8+0x2d/0x30 [kvm]
[12021.561798] [<f8d97296>] ? svm_vcpu_run+0x1b6/0x370 [kvm_amd]
[12021.561807] [<f8dff672>] vcpu_enter_guest+0x1a2/0x440 [kvm]
[12021.561816] [<f8dffe9f>] __vcpu_run+0x12f/0x280 [kvm]
[12021.561819] [<c105ffba>] ? sigprocmask+0x7a/0x100
[12021.561828] [<f8e000b1>] kvm_arch_vcpu_ioctl_run+0xc1/0x1b0 [kvm]
[12021.561836] [<f8debfda>] kvm_vcpu_ioctl+0x49a/0x5f0 [kvm]
[12021.561839] [<c127b714>] ? _copy_from_user+0x44/0x70
[12021.561841] [<c1062642>] ? sys_rt_sigtimedwait+0x102/0x210
[12021.561844] [<c106bfec>] ? common_timer_set+0xfc/0x160
[12021.561848] [<c150946f>] ? _raw_spin_lock_irqsave+0x2f/0x50
[12021.561855] [<f8debb40>] ? kvm_vcpu_ioctl+0x0/0x5f0 [kvm]
[12021.561858] [<c113665b>] do_vfs_ioctl+0x7b/0x2e0
[12021.561860] [<c127b782>] ? copy_to_user+0x42/0x60
[12021.561862] [<c1136947>] sys_ioctl+0x87/0x90
[12021.561864] [<c15096f4>] syscall_call+0x7/0xb
[12021.561866] Code: 30 89 c2 e9 63 ff ff ff 90 8b 4d e0 89 f2 ff 51 30 89 c2 eb c1 8d 74 26 00 55 89 e5 57 56 53 83 ec 48 3e 8d 74 26 00 89 c3 8b 33 <65> a1 14 00 00 00 89 45 f0 31 c0 8d 45 d0 89 45 c8 31 c0 89 75
[12021.561887] EIP: [<f8e0fa92>] x86_decode_insn+0x12/0x9b0 [kvm] SS:ESP 0068:f50b3d8c
[12021.561897] CR2: 0000000000000014
[12021.561899] ---[ end trace 0bfe930b26b091f1 ]---

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-5-generic 2.6.38-5.32
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: andreas 1341 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xdbf78000 irq 22'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,14627309,00100202'
   Controls : 26
   Simple ctrls : 15
Date: Fri Mar 4 15:02:44 2011
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=73a60130-5cd6-4337-a7c6-77a52fcb592a
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 br0 no wireless extensions.
Lsusb:
 Bus 002 Device 002: ID 046d:c00c Logitech, Inc. Optical Wheel Mouse
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: MSI MS-7309
ProcEnviron:
 LANGUAGE=en
 LANG=de_DE.UTF-8
 LC_MESSAGES=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=ae79abc8-481a-408b-aff3-4ba19e5b9625 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-5-generic N/A
 linux-backports-modules-2.6.38-5-generic N/A
 linux-firmware 1.47
RfKill:

SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-02-28 (3 days ago)
dmi.bios.date: 03/10/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V2.4
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: K9N6PGM2-V2 (MS-7309)
dmi.board.vendor: MSI
dmi.board.version: 2.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 2.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV2.4:bd03/10/2010:svnMSI:pnMS-7309:pvr2.0:rvnMSI:rnK9N6PGM2-V2(MS-7309):rvr2.0:cvnMSI:ct3:cvr2.0:
dmi.product.name: MS-7309
dmi.product.version: 2.0
dmi.sys.vendor: MSI

Andreas Moog (ampelbein) wrote :
Herton R. Krzesinski (herton) wrote :

This issue was also reported/discussed at http://thread.gmane.org/gmane.comp.emulators.kvm.devel/68736

Herton R. Krzesinski (herton) wrote :

Please test the kernel available at http://people.canonical.com/~herton/lp729085/ and report if the problem is fixed with it.

Changed in linux (Ubuntu):
status: New → Incomplete
Dmitry G. (hint) wrote :

I test this patched kernel and it's Ok for me, problem fixed.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Herton R. Krzesinski (herton) wrote :

Patch should come in next stable update accordingly to http://article.gmane.org/gmane.linux.kernel.stable/7938

So we should get it when updating natty kernel to next stable.

Changed in linux (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Herton R. Krzesinski (herton)
Tim Gardner (timg-tpi) on 2011-04-06
Changed in linux (Ubuntu Natty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-8.42

---------------
linux (2.6.38-8.42) natty; urgency=low

  [ David Henningsson ]

  * SAUCE: (drop after 2.6.38) ALSA: HDA: Fix dock mic for Lenovo
    X220-tablet
    - LP: #751033

  [ Gustavo F. Padovan ]

  * SAUCE: Revert "Bluetooth: Add new PID for Atheros 3011"
    - LP: #720949

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: (drop after 2.6.39) v4l: make sure drivers supply a zeroed
    struct v4l2_subdev
    - LP: #745213

  [ John Johansen ]

  * AppArmor: Fix masking of capabilities in complain mode
    - LP: #748656

  [ Leann Ogasawara ]

  * [Config] Disable CONFIG_RTS_PSTOR for armel, powerpc

  [ Manoj Iyer ]

  * SAUCE: (drop after 2.6.38) add support for Lenovo tablet ID (0xE6)
    - LP: #746652

  [ Steve Langasek ]

  * [Config] Make linux-libc-dev coinstallable under multiarch
    - LP: #750585

  [ Tim Gardner ]

  * [Config] CONFIG_RTS_PSTOR=m
    - LP: #698006

  [ Upstream Kernel Changes ]

  * Revert "tcp: disallow bind() to reuse addr/port"
    - LP: #731878
  * ALSA: HDA: Add dock mic quirk for Lenovo Thinkpad X220
    - LP: #746259
  * ALSA: HDA: New AD1984A model for Dell Precision R5500
    - LP: #741516
  * Input: sparse-keymap - report scancodes with key events
  * Input: sparse-keymap - report KEY_UNKNOWN for unknown scan codes
  * KVM: SVM: Load %gs earlier if CONFIG_X86_32_LAZY_GS=n
    - LP: #729085
  * watchdog: sp5100_tco.c: Check if firmware has set correct value in
    tcobase.
    - LP: #740011
  * staging: add rts_pstor for Realtek PCIE cardreader
    - LP: #698006
  * staging: fix rts_pstor build errors
    - LP: #698006
  * Staging: rts_pstor: fixed some brace code styling issues
    - LP: #698006
  * staging: rts_pstor: potential NULL dereference
    - LP: #698006
  * Staging: rts_pstor: fix read past end of buffer
    - LP: #698006
  * staging: rts_pstor: delete a function
    - LP: #698006
  * staging: rts_pstor: fix sparse warning
    - LP: #698006
  * staging: rts_pstor: fix a bug that a greenhouse sd card can't be
    recognized
    - LP: #698006
  * staging: rts_pstor: optimize kmalloc to kzalloc
    - LP: #698006
  * staging: rts_pstor: MSXC card power class
    - LP: #698006
  * staging: rts_pstor: modify initial card clock
    - LP: #698006
  * staging: rts_pstor: set lun_mode in a different place
    - LP: #698006
  * x86, hibernate: Initialize mmu_cr4_features during boot
    - LP: #752870
 -- Leann Ogasawara <email address hidden> Fri, 08 Apr 2011 09:24:59 -0700

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers