compiz crashed with SIGSEGV in intel_miptree_image_copy()

Bug #728672 reported by Kamal Mostafa on 2011-03-03
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
High
Tim Gardner
Natty
High
Tim Gardner

Bug Description

Running my own build of the natty 'master-next' kernel branch (2.6.38-6.33 at SHA1-ID "57545cb"; based on linux 2.6.38-rc7), the default unity desktop session makes compiz crash immediately upon login (100% reproducible):

  compiz[1388]: segfault at 20 ip 00007ff0cee9702a sp 00007fffc50a9580 error 4 in i965_dri.so[7ff0cee6b000+ac000]

The crash does NOT occur when running the natty main kernel (2.6.38-5.32), so this appears to be a regression caused by the master-next branch.

Note that I the gnome-panel (classic) session works fine. Also, after unity/compiz crashes, I can then switch to a VT and launch gnome-panel and compiz manually... In that state, "unity --replace" does make the same crash occur immediately. (Effectively, only unity seems to provoke this compiz crash, and it always does so).

uname: Linux marconi 2.6.38-6-generic #33~kamal~57545cb (my build from master-next)
unity: Installed: 3.6.0-0ubuntu2 (from natty/main)
compiz: Installed: 1:0.9.4-0ubuntu3 (from natty/main)
libgl1-mesa-dri: Installed: 7.10.1~git20110215.cc1636b6-0ubuntu2 (from natty/main)

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.30-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.33~username~57545cb-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
Architecture: amd64
Date: Thu Mar 3 11:36:56 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101214)
ProcCmdline: compiz
ProcCwd: /home/kamal
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7ff0cee9702a <intel_miptree_image_copy+42>: cmpb $0x0,0x20(%rsi)
 PC (0x7ff0cee9702a) ok
 source "$0x0" ok
 destination "0x20(%rsi)" (0x00000020) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 intel_miptree_image_copy () from /usr/lib/dri/i965_dri.so
 intel_finalize_mipmap_tree () from /usr/lib/dri/i965_dri.so
 brw_validate_textures () from /usr/lib/dri/i965_dri.so
 brw_draw_prims () from /usr/lib/dri/i965_dri.so
 ?? () from /usr/lib/dri/libdricore.so
Title: compiz crashed with SIGSEGV in intel_miptree_image_copy()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kamal 1392 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0a00000 irq 45'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:111d7675,10280413,00100103 HDA:80862804,80860101,00100000'
   Controls : 25
   Simple ctrls : 15
DistroRelease: Ubuntu 11.04
HibernationDevice: RESUME=UUID=e4c5fd19-ee8c-4877-9ab4-cb3d05e19cdf
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101214)
MachineType: Dell Inc. Studio 1558
Package: linux 2.6.38.6.20
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic root=UUID=0093eb61-9197-497b-913d-31a6a13b2a49 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-6.33~username~57545c-generic 2.6.38-rc7
Regression: Yes
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-6-generic N/A
 linux-backports-modules-2.6.38-6-generic N/A
 linux-firmware 1.48
Reproducible: Yes
Tags: natty running-unity kernel-graphics regression-proposed needs-upstream-testing
Uname: Linux 2.6.38-6-generic x86_64
UnreportableReason: This is not a genuine Ubuntu package
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 03/11/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0G939P
dmi.board.vendor: Dell Inc.
dmi.board.version: A04
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A04
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd03/11/2010:svnDellInc.:pnStudio1558:pvrA04:rvnDellInc.:rn0G939P:rvrA04:cvnDellInc.:ct8:cvrA04:
dmi.product.name: Studio 1558
dmi.product.version: A04
dmi.sys.vendor: Dell Inc.

Kamal Mostafa (kamalmostafa) wrote :

StacktraceTop:
 intel_miptree_image_copy (intel=0x1592fc0, dst=0x0, face=0, level=0, src=0x2e0a2a0) at intel_mipmap_tree.c:435
 copy_image_data_to_tree (intel=0x1592fc0, unit=<value optimized out>) at intel_tex_validate.c:91
 intel_finalize_mipmap_tree (intel=0x1592fc0, unit=<value optimized out>) at intel_tex_validate.c:232
 brw_validate_textures (brw=0x1592fc0) at brw_tex.c:56
 brw_try_draw_prims (ctx=0x1592fc0, arrays=0x15e3b60, prim=0x7fffc50a97b0, nr_prims=1, ib=0x0, index_bounds_valid=<value optimized out>, min_index=0, max_index=3) at brw_draw.c:319

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Robert Hooker (sarvatt) on 2011-03-03
description: updated
Chris Van Hoof (vanhoof) on 2011-03-03
tags: added: hwe-blocker
Kamal Mostafa (kamalmostafa) wrote :

On Robert Hooker's advice, I tried reverting the following commit and determined that reverting it does fix the crash:

  c2e0eb167070a6e9dcb49c84c13c79a30d672431 drm/i915: fix corruptions on i8xx due to relaxed fencing

Robert Hooker (sarvatt) on 2011-03-04
affects: nux (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Medium → High
status: New → Confirmed
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Andy Whitcroft (apw) wrote :

Interestingly I am running this same kernel here, so it presumably is not a widespread effect? From the description of the patch reverted this implies only 8x00 is affected? @kamal -- what graphics h/w is this. We should likely get an apport-collect 728672 run now we have it against linux.

Robert Hooker (sarvatt) wrote :

this only affects gen4 (965) and newer, what are you using?

apport information

tags: added: apport-collected kernel-graphics needs-upstream-testing regression-proposed
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux:
status: Confirmed → Fix Released
Kamal Mostafa (kamalmostafa) wrote :

Per https://bugs.freedesktop.org/show_bug.cgi?id=35016#c11 (Chris Wilson) the proper fix for this is indeed to revert commit c2e0eb167070a6e9dcb49c84c13c79a30d672431.

Tim Gardner (timg-tpi) on 2011-03-08
Changed in linux (Ubuntu Natty):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → Fix Committed
Kamal Mostafa (kamalmostafa) wrote :

I confirm that this is fixed in Ubuntu-2.6.38-6.34.

Note that natty's patch applied by Andy W can now be dropped:
df74c3984b8888140944fc981d952e08fdc7e7ba Revert "drm/i915: fix corruptions on i8xx due to relaxed fencing"

... has identical content to the patch now in mainline 2.6.38-rc8:
0ee537abbd10a9abf11e1c22ee32a68e8c12ed4a Revert "drm/i915: fix corruptions on i8xx due to relaxed fencing"

Robert Hooker (sarvatt) on 2011-04-04
Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.