Ubuntu

Laptop subwoofer is not functional on ASUS G73JH

Reported by bdoe on 2011-03-03
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

This issue is nearly identical to that reported in Bug 673051, but on a different ASUS laptop model. Like the ASUS G73JW, the ASUS G73JH has a built-in subwoofer. This subwoofer works perfectly under Windows, but does not work at all under Ubuntu Linux 10.10. As a result, sound coming from the laptop speakers sounds thin and tinny on Ubuntu, instead of the rich, full sound under Windows.

Linux Distribution: Ubuntu x86 Desktop, 10.10
Linux kernel: 2.6.35-27-generic-pae
ALSA version: 1.0.23+dfsg-1ubuntu4
nonfree kernel modules: fglrx_pci (Catalyst 10.11)

$ sudo lspci -vv output (for default audio device):
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Defini
tion Audio (rev 06)
        Subsystem: ASUSTeK Computer Inc. Device 1373
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Step
ping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 50
        Region 0: Memory at d3e00000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3ho
t+,D3cold+)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
                Address: 00000000fee8800c Data: 41b1
        Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1
<1us
                        ExtTag- RBE- FLReset+
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
                LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
        Capabilities: [100 v1] Virtual Channel
                Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
                Arb: Fixed- WRR32- WRR64- WRR128-
                Ctrl: ArbSelect=Fixed
                Status: InProgress-
                VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
                        Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=01
Status: NegoPending- InProgress-
                VC1: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
                        Ctrl: Enable+ ID=2 ArbSelect=Fixed TC/VC=04
                        Status: NegoPending- InProgress-
        Capabilities: [130 v1] Root Complex Link
                Desc: PortNumber=0f ComponentID=00 EltType=Config
                Link0: Desc: TargetPort=00 TargetComponent=00 AssocRCRB- LinkType=MemMapped LinkValid+
                        Addr: 00000000fed1c000
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

David Henningsson (diwic) wrote :

Hi, could you please follow the procedure here to give us more information about your hardware: https://wiki.ubuntu.com/Audio/AlsaInfo

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
bdoe (bdoe-att) wrote :

Here's the requested ALSA-INFO output.

description: updated
David Henningsson (diwic) wrote :

Hi bdoe. I've run your codec in an emulator and noticed that subwoofer node 0x16 is ignored due to not having the right association.

bdoe (bdoe-att) wrote :

Is that something I need to fix myself, a result of misconfiguration?

David Henningsson (diwic) wrote :

Oh sorry for the confusing reply. I wrote that, then got busy with other stuff, and forgot to return to it. I have now made a dkms package for you to test, please try this:
1) Make sure you don't have alsa driver overrides installed (such as these: https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules )
2) Download and install http://people.canonical.com/~diwic/temp/alsa-hda-diwic-asus-g73jh-dkms_1.0.23.diwic_all.deb
3) Reboot and test.

Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
David Henningsson (diwic) wrote :

For my own reference, here's the patch applied to the dkms package.

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
bdoe (bdoe-att) wrote :

I installed the package and rebooted, then tried playing something over the speakers, but nothing seems to have changed. I looked in ALSAMIXER settings, and nothing looks different there either.

David Henningsson (diwic) wrote :

That's surprising. Could you please give a new alsa-info with my dkms package installed? Thanks!

bdoe (bdoe-att) wrote :

Here you go!

alek (slen) wrote :

I recently purchased an ASUS G73JH laptop and installed ubuntu 11.04 64bit version.
Unfortunately subwoofer doesn't work.
I don't have any alsa driver overrides installed.
It would be very gratifying if the problem could be solved.

I've attached a zip.file (alsa.zip), containing following files:

general.txt - output of
lsb_release -a
uname -rm
lspci | grep -i audio
lspci -nnk | grep -iA2 audio
cat /proc/asound/cards
ps -C pulseaudio
lsmod | grep "snd"
aplay -l
aplay '/usr/share/sounds/alsa/Side_Right.wav'

other files:

alsa-info.txt.boBLP3VAIF: information according to https://wiki.ubuntu.com/Audio/AlsaInfo
lspci_vvnn.txt: output of "lspci -vvnn > lspci_vvnn.txt"
lsmod.txt: output of "lsmod > lsmod.txt"
lshw.txt: output of "sudo lshw > lshw.txt"
dmesg.txt: output of "dmesg > dmesg.txt"
kern_log.txt: output of"cat /var/log/kern.log > kern_log.txt"
syslog.txt: output of "cat /var/log/syslog > syslog.txt"

alek (slen) wrote :

Sorry, sent a wrong alsa-info.txt file. Here ist the right one

alek (slen) wrote :

I have found now a workaround, which solves subwoofer problem under ubuntu 10.10. Here is what I did:

1. installed David Henningssons alsa-hda-diwic-asus-g73jh-dkms_1.0.23.diwic_all.deb package

(thanks David)

see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/728161/comments/5

Download: http://people.canonical.com/~diwic/temp/alsa-hda-diwic-asus-g73jh-dkms_1.0.23.diwic_all.deb

2. opened file /etc/pulse/daemon.conf and replaced

a) entry

; enable-lfe-remixing = no

with

enable-lfe-remixing = yes

and
b) entry

; default-sample-channels = 2

with

default-sample-channels = 6

3. opened file /etc/modprobe.d/alsa-base.conf and added

options snd-hda-intel model=auto

at the end of this file

4. opened file /etc/modules and added

snd-hda-intel model=auto

at the end of this file

5. Then I rebooted laptop.

Subwoofer is now working. I have the same rich, full sound as under Windows.

Unforunately above mentioned solution ist not working under ubuntu 11.04

alek (slen) wrote :

I have meanwhile also found a workaround for ubuntu 11.04

1. installed linux-alsa-driver from repository ppa:ubuntu-audio-dev/ppa
see http://ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu/pool/main/l/linux-alsa-driver-modules-2.6.38/

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
sudo apt-get install linux-alsa-driver-modules-$(uname -r)

note:
at the moment there are only packages for kernel 2.6.38-8 available

2. opened file /etc/pulse/daemon.conf and replaced

a) entry

; enable-lfe-remixing = no

with

enable-lfe-remixing = yes

and
b) entry

; default-sample-channels = 2

with

default-sample-channels = 6

3. opened file /etc/modprobe.d/alsa-base.conf and added

options snd-hda-intel model=basic

at the end of this file

4. opened file /etc/modules and added

snd-hda-intel model=basic

at the end of this file

5. Then I rebooted laptop.

Subwoofer is now working unter ubuntu 11.04 (with same rich, full sound as under Windows).

bdoe (bdoe-att) wrote :

I just recently upgraded to Linux Mint 11 RC ("Katya"), which is based on Ubuntu 11.04. I can confirm Alek's solution in Reply#13 works for enabling the subwoofer. Audio from the laptop speakers now sounds great. There is a catch, however:

With snd-hda-intel set as "model=basic", the subwoofer works, but the front speakers no longer mute when headphones are plugged in.
With snd-hda-intel set as "model=auto", "model=laptop" (or laptop-amic), the speakers mute properly when headphones are plugged in, but the subwoofer stops working again. I will play around with some of the other snd-hda-intel options to see what they do.

One thing that's interesting to note: With "model=auto" set, the following options show up under Output:Connector within Sound Preferences: Analog Headphones, Analog Speakers, Analog Output. However, these settings are a bit goofy. Looking at ALSAMIXER while changing these settings, I can see that "Analog Speakers" has both Headphone and Speaker volumes set at 96 (default) - however, the speakers do mute when headphones are plugged in though ALSAMIXER does not reflect this. "Analog Headphones" properly mutes the speakers as shown in ALSAMIXER. Now, here's the weird part: "Analog Output" sets Speaker volume to 0 and leaves Headphone at 96. If I adjust the speaker volume, then change output mode to something else and back to "Analog Output", Speaker volume reverts to 0 again, even if "alsactl store 0" was issued before changing output modes. This leads me to believe the volume levels are hard-coded somewhere. Does anyone know where these are set? This might fix the speaker muting issue with "snd-hda-intel model=basic" option set.

bdoe (bdoe-att) wrote :

I noticed that this bug is marked as Incomplete. Is there still information one of us needs to provide?

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
assignee: David Henningsson (diwic) → nobody
status: Confirmed → Triaged
Rudd-O (rudd-o) wrote :

Same problem with the ASUS G73Sw. The diwic DKMS fixes it, but with one caveat, the subwoofer is only triggered by signals on the LEFT channel, rather than from both the LEFT and RIGHT channel.

I have another question: is this already upstream in 3.3 or will it continue to be maintained in a split fashion? Thanks in advance.

tags: added: patch
Changed in linux (Ubuntu):
importance: Undecided → Medium
Rudd-O (rudd-o) wrote :

A fix is coming in kernel 3.3. Takashi Iwai was kind enough to port the bass slave volume fix to his tree, and ping Linus about upstreaming his fix:

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=blobdiff;f=sound/pci/hda/patch_realtek.c;h=6c8ef04c9c49965bb054f9e7d1efcc5862c9ca3f;hp=a8e82be3d2fc4327a429ea0117ca30f66a114a55;hb=28f6c6b4f1c16c74ee6a3a7230685525b679df7d;hpb=b5bcc189401c815988b7dd37611fc56f40c9139d

This bug should be closed nextrelease if the next Ubuntu is going to have 3.3.

Roberto Leinardi (leinardi) wrote :

Someone managed to make the internal subwoofer work with the VIA VT1802?

I tried with “options snd-hda-intel model=auto” in /etc/modprobe.d/alsa-base.conf and “default-sample-channels = 6” in /etc/pulse/daemon.conf but nothing has change: alsamixer only sees two channels.

I'm on Ubuntu 12.10 beta2

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Mark (mark814) wrote :

Hi All,

I just found this old thread and am having the same problem.

Ubuntu 13.10, Asus G73JH and no subwoofer (hasn't worked at all since 12.04 when I started with Ubuntu).

Any help still out there?

Mark

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers