linux: 2.6.35-28.49 -proposed tracker

Bug #726796 reported by Brad Figg on 2011-02-28
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

This bug is for tracking the 2.6.35-28.49 upload package. This bug will contain status and testing results releated to that upload.

Brad Figg (brad-figg) on 2011-02-28
tags: added: kernel-release-tracking-bug
Changed in linux (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Brad Figg (brad-figg) on 2011-02-28
Changed in linux (Ubuntu Maverick):
status: New → In Progress
Changed in linux (Ubuntu Maverick):
importance: Undecided → Medium

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu):
status: In Progress → Invalid
Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Committed
Erick Brunzell (lbsolost) wrote :

This kernel fails to boot for me. X never really appears and Alt+SysReq options fail. I just get a truly "blank screen" with no blinking cursor or anything. I tried apport-collect after booting back into "-27" but it fails with the error:

Error showing url: Failed to execute child process "/opt/firefox/firefox" (No such file or directory)

Other than providing my hardware specs I'm not sure what else you'd need.

JetWay JATOM-GM1-230-LF Motherboard
Intel Atom 230 CPU @ 1.60GHz
System Memory 2GB DIMM
Intel 82945G/GZ Integrated Graphics
Intel N10/ICH 7 Family High Def Audio Controller

I have even tried recovery mode/single and I don't see any apparent errors, but the common options following a recovery boot never appear. I'll be glad to provide any logs requested but keep it simple. I'm a dummy when it comes to kernel bugs.

Erick Brunzell (lbsolost) wrote :

I spent some time this AM giving this a closer look and one of the first things I tried was removing "quiet splash" from the kernel boot parameters thinking that may provide some clues, but doing so resulted in a successful boot. Restoring the "quiet splash" once again resulted in a failed boot.

Now, I've been fiddling with 'grub-customizer' for a few weeks:

https://launchpad.net/~danielrichter2007/+archive/grub-customizer

Since I multi-boot, I next tried booting the new kernel using a different OS's grub and it succeeded every time. Then I purged grub-customizer, grub-pc and grub-common - and also rm -R'ed both /etc/grub.d and /boot/grub. After reinstalling grub-pc all seems fine.

That is I can no longer reproduce the failed boot so I can only assume that some custom mods I'd made to the grub 2 configuration broke things. Sorry for the false alarm.

Hardware Certification has completed testing 75 systems and no regressions were found. Results can be found here: http://people.canonical.com/~hwcert/sru-testing/wk10_2011/maverick-proposed.html

Pedro Villavicencio (pedro) wrote :

We ran the QA regression test suite on the proposed Maverick kernel and did not encounter any regression with it, full results are available at: https://wiki.ubuntu.com/QATeam/KernelSRU-maverick-2.6.35-28.49. Following the workflow, i'm marking this as verification-done, Thanks all.

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.35-28.49

---------------
linux (2.6.35-28.49) maverick-proposed; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #726796

  [ Colin Ian King ]

  * SAUCE: Dell All-In-One: Remove need for Dell module alias

  [ Manoj Iyer ]

  * SAUCE: add ricoh 0xe823 pci id.
    - LP: #717435

  [ Upstream Kernel Changes ]

  * virtio_net: Add schedule check to napi_enable call
    - LP: #579276
  * mmc: make sdhci work with ricoh mmc controller
    - LP: #717435
  * NFS: fix the return value of nfs_file_fsync()
    - LP: #585657
  * rt2x00: Pad beacon to multiple of 32 bits.
    - LP: #659143
  * rt2x00: Fix firmware loading regression on x86_64.
    - LP: #659143
  * rt2x00: Check for errors from skb_pad() calls
    - LP: #659143
  * block: check for proper length of iov entries earlier in
    blk_rq_map_user_iov(), CVE-2010-4163
    - LP: #721504
    - CVE-2010-4163
  * tty: Make tiocgicount a handler, CVE-2010-4076, CVE-2010-4077
    - LP: #720189
    - CVE-2010-4077
    - CVE-2010-4076
  * rds: Integer overflow in RDS cmsg handling, CVE-2010-4175
    - LP: #721455
    - CVE-2010-4175
 -- Brad Figg <email address hidden> Mon, 28 Feb 2011 13:02:53 -0800

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers