Ubuntu

bug on fs/inode.c:1422

Reported by Phillip Susi on 2011-02-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

While doing some testing with dmsetup and gparted on dmraid devices in today's Natty daily live cd, I hit this bug twice. The relevant code seems to be:

void iput(struct inode *inode)
{
 if (inode) {
  BUG_ON(inode->i_state & I_CLEAR);

  if (atomic_dec_and_lock(&inode->i_count, &inode_lock))
   iput_final(inode);
 }
}

This was tripped when I tried manually removing a linear partition mapping with dmsetup remove, and again when I started a patched gparted I am testing.

Phillip Susi (psusi) wrote :

This bug seems a bit randomish. I tried to reproduce it the same way I did the first time and could not. A while later it happened when I run dmraid -an. I've hit it by doing several things, all of which seem to involve removing a dm device. I wrote down the call stack on one:

bdput
free_dev
__dm_destroy
dev_remove
ctl_ioctl
dm_ioctl

Jeremy Foshee (jeremyfoshee) wrote :

Hi Phillip,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 722925

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Phillip Susi (psusi) wrote :

Tested with build from Linus's tree post 2.6.38-rc6+ and it happens there too. Starting to git bisect.

tags: removed: needs-kernel-logs needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Phillip Susi (psusi) wrote :

Setting to high priority since, well, it's a kernel BUG.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Invalid
Andy Whitcroft (apw) wrote :

Based on the upstream bug it seems this will be fixed when we upload the current rebased Natty. Closing Fix Committed.

Changed in linux (Ubuntu Natty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-6.33

---------------
linux (2.6.38-6.33) natty; urgency=low

  [ Andy Whitcroft ]

  * d-i -- enable speakup-modules udeb
    - LP: #672699
  * rebase to 493f3358cb289ccf716c5a14fa5bb52ab75943e5
  * [Config] debian PPC64 configuration
  * [Config] cleanup powerpc config fixing unexpected inconsistancies
  * [Config] resync ppc64 configuration
  * SAUCE: match up ENTRY/END naming for 32/64 bit
  * rebase to fb62c00a6d8942775abc23d1621db1252e2d93d1
  * [Config] update configs after rebase to
    fb62c00a6d8942775abc23d1621db1252e2d93d1
  * [Config] pps_gen_parport no longer built

  [ Corentin Chary ]

  * SAUCE: (drop after 2.6.38) eeepc-wmi: reorder keymap
    - LP: #689393
  * SAUCE: (drop after 2.6.38) eeepc-wmi: add wlan key found on 1015P
    - LP: #689393

  [ John Johansen ]

  * SAUCE: Fix aufs calling of security_path_mknod
    - LP: #724456

  [ Kees Cook ]

  * SAUCE: proc: hide kernel addresses via %pK in /proc/<pid>/stack

  [ Tim Gardner ]

  * rebase to 2.6.38-rc7

  [ Upstream Kernel Changes ]

  * Revert "drm/i915: fix corruptions on i8xx due to relaxed fencing"

  [ Major Kernel Changes ]

  * rebase from v2.6.38-rc6 to v2.6.38-rc7 +
    fb62c00a6d8942775abc23d1621db1252e2d93d1
    - LP: #721389
    - LP: #722925
    - LP: #723672
    - LP: #723676
    - LP: #715318
 -- Andy Whitcroft <email address hidden> Mon, 07 Mar 2011 15:33:17 +0000

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.