Ubuntu

[natty] kernel panic on reboot with (U)EFI

Reported by James Lewis on 2011-02-18
156
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
linux-2.6 (Debian)
Fix Released
Unknown
linux (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned
Quantal
High
Unassigned

Bug Description

=== RELEASE NOTES TEXT ===
 * Some EFI systems fail to boot in EFI mode, BIOS mode is advised in these situations. (Bug:721576)
===

Call trace seems to show this is related to EFI, it happens every time on reboot with 2.6.38-1 and 2.6.38-4 see attached images.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image (not installed)
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Uname: Linux 2.6.38-4-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xfb620000 irq 57'
   Mixer name : 'Realtek ALC892'
   Components : 'HDA:10ec0892,10438469,00100302'
   Controls : 32
   Simple ctrls : 18
Card1.Amixer.info:
 Card hw:1 'default'/'Logitech EasyCall Speakerphone at usb-0000:00:1d.0-1.1.2, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0a06'
   Controls : 10
   Simple ctrls : 6
Card2.Amixer.info:
 Card hw:2 'NVidia'/'HDA NVidia at 0xfb080000 irq 17'
   Mixer name : 'Nvidia GPU 18 HDMI/DP'
   Components : 'HDA:10de0018,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Fri Feb 18 23:16:15 2011
HibernationDevice: RESUME=UUID=9f0f4960-5c3c-486e-a7ce-febfc8b21760
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-4-generic root=UUID=160ca738-b158-4323-a87d-f6c753543745 ro rootflags=subvol=@ quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-4-generic N/A
 linux-backports-modules-2.6.38-4-generic N/A
 linux-firmware 1.47
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
dmi.bios.date: 01/20/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1253
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8P67 PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1253:bd01/20/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8P67PRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

James Lewis (james-fsck) wrote :
Jeremy Foshee (jeremyfoshee) wrote :

Hi James,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
exactt (giesbert) wrote :

problem here too. see screenshot attached.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Florian Heyer (heyho-flanto) wrote :

Problem confirmed on hardware Lenovo Ideapad S205 (see duplicate bug).

The problem also occurs with latest ubuntu mainline kernel (version 2.6.39-rc3).

exactt (giesbert) wrote :

problem still exists with release version of natty...

exactt (giesbert) on 2011-04-28
summary: - natty's 2.6.38 kernel panics on reboot with EFI
+ [natty] kernel panic on reboot with (U)EFI
Jarrett Miller (spook) wrote :

I can confirm this on an Intel DQ57TM motherboard (see bug #773364). As I noted in my duplicate bug report you can easily work around this bug by adding "reboot=a,w" to the kernel command line. So an easy fix is to push out an update to grub-efi that adds that to the kernel command line in /etc/default/grub.

I am pretty sure this is how Windows works as well. EFI systems are required by spec to also have ACPI as a result I think Windows uses the ACPI tables as the reboot vector. It only uses EFI runtime services when booting or using the bcdedit.exe program.

Cheers.

Florian Heyer (heyho-flanto) wrote :

@Jarrett Miller: thanks for this hint!

I added "reboot=a,w" to the kernel command line in /etc/defaults/grub and now rebooting works on my Lenovo IdeaPad S205.

However, halt and suspend still don't work.

Anders Strömqvist (dizzey) wrote :

 Adding noefi fixes the issues for me reboot, halt and suspend now works perfekt on my ibm s205

## in /etc/defaults/grub ##
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noefi reboot=a,w"

I believe noefi makes the reboot=a,w not needed anymore but i haven't tried.

This bug should still be here since i guess all of this stuff is suposed to work with efi in the kernel,
but the importance of the bug decreases. Well at least if this trick work on the other machines that is showing this problem.

Anders Strömqvist (dizzey) wrote :

sorry not ibm it is a Lenovo IdeaPad S205

Spock112 (spock112) wrote :

Hi,
the reboot=a,w works for me.
the noefi command leads to no booting of ubuntu.

I installt ubuntu (and win7) in Uefi mode with gtp.

And Windows has the same problems with halt and reboot. Could it be, that the efi in the s205 dosen't understand efi halt and reboot commands?!?

Anders Strömqvist (dizzey) wrote :

I only run ubuntu in uefi mode (well gpt partition etc) without the noefi the computer crashes on reboot halt and suspend.
I also had trouble with my wireless card without noefi ie the card would say disabled by hardware switch if i did not try to boot from lan in the boot order. also my bluetooth started working. either linux has a new and buggy efi support in the kernel or my hardware has a relly buggy uefi implementation.

Grub2 and all of that is in uefi mode so i relly dont know what the noefi cmd does to the kernel. Im guessing that the kernel just skips the uefi tables and that uefi has the old tables for backward combability

Spock112 (spock112) wrote :

strange ...
when I insert noefi the kernel has sata errors and wont find the root partion ...
I dont think that it is linux ... because i have the same problems with windows ...

Jarrett Miller (spook) wrote :

I wanted to report in that I attempted to test mainline but was unable.
I tried using the 2.6.38.6 debs from the kernel ppa:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.38.6-natty/

unfortunately when I use these the kernel crashes during boot with a message about plymouthd.

I will attach a capture of the stack trace.

Roderick Smith (rodsmith) wrote :

Another report on this: I'm using an Intel DG43NB motherboard (Intel G43 Express chipset, AMI EFI 2.00) with a Celeron E3300 CPU. I'd previously been booting in BIOS mode with no problems, but I tried UEFI mode for Ubuntu 11.04. I had the kernel panic on reboot, but not on shutdown. I've tried this with both the Ubuntu precompiled 2.6.38-8-generic kernel and a locally-compiled 2.6.39 kernel from the source at http://www.kernel.org, with the same results with both. Adding "reboot=a,w" to my ELILO options (GRUB 2 is unreliable for me) fixes the problem (although I've not yet tested shutdown). Adding "noefi" to the boot options prevented the system from booting. Also and FWIW, I found a Debian bug report that seems to be of the same problem:

http://lists.debian.org/debian-kernel/2011/05/msg00211.html

I took a photo, but it turned out illegibly blurry.

I would say I am having a similar problem on MSI GX733.

Full BUG report here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/784484

P.S. Tried Your fixes- didn't help :/

Anyone got any ideas on my case? :(

In addition- I don't know if my setup is EFI or not- it's a default setup. (64 bit)

Also, if this info is of any use- suspend and hibernate work fine in my case.

Igor Mitrenko (igor-mitrenko) wrote :

Having all the same on Lenovo IdeaPad s205.
Kernel panic, related to efi call. Tried (maybe I made something wrong, I'll re-try it later) to add noefi (with and without reboot=a,w) to /etc/defaults/grub and right in the grub console to kernel options - kernel even won't boot.

Shutdown/suspend/sleep works fine with Ubuntu 10.04 LTS.

Igor Mitrenko (igor-mitrenko) wrote :

reboot=a,w made reboot working.

But shutdown/suspend to ram and disk are still broken.

Igor Mitrenko (igor-mitrenko) wrote :

Yesterday I tried to downgrade to 2.6.32-21 kernel (from lucid), and nothing changed - still freezes on shutdown/suspend.

It seems that problem is not related to kernel itself, but related to grub or efi bios.

Keith Ward (keithward) wrote :

All,

I've discovered a note on: https://help.ubuntu.com/community/UEFIBooting#Kernel%20panic%20on%20Reboot regarding this.

Apparently this is as a result of buggy Sandybridge UEFI firmware?

-Keith

Keith Ward (keithward) wrote :

I've gone ahead and added an entry for the Ubuntu Release Notes Team,

Ideally we need a mention of this in the natty release notes (especially as there is already 4 other duplicate bugs with regards to this issue).

-Keith

Roderick Smith (rodsmith) wrote :

It's possible that the bug is caused by buggy firmware, but if so it's NOT restricted to Sandy Bridge systems. My own computer uses an Intel DG43NB motherboard (Intel G43 Express chipset with AMI EFI 2.00) with a Celeron E3300 CPU, which predates Sandy Bridge by quite a while. As noted earlier, I've got the problem when rebooting, although shutdown is fine on my system.

Florian Heyer (heyho-flanto) wrote :

The Lenovo Ideapad S205 has a different architecture by AMD, no sandy bridge in there.

Xeelee (alex-gaponline) wrote :

Also appears on a Lenovo X220 with Natty AMD64, EFI-Grub and 3.0.0-rc4 kernel from PPA-Mainline.

Appending "reboot=a,w" in /etc/default/grub line GRUB_CMDLINE_LINUX_DEFAULT solved the problem for me.

Florian Heyer (heyho-flanto) wrote :

@Xeelee: what about halt/restart/suspend? Does it work for all three commands?

On my Lenovo S205 with reboot=a,w only restart works. Halt and suspend are still faulty.

Igor Mitrenko (igor-mitrenko) wrote :

@Florian:
Don't entertain the vain hope, reboot=a,w fixes only restart. Moreover, it affects only restart. There is a lot information in the net, what a and w arguments really do.
We, "lucky" owners of lenovo s205 crap are in the quite a deep trouble. I even updated "bios" firmware in hope that fix of the XP suspend awake issue will also affect our problem (I thought that abovementioned issues related to single firmware bug, but I was wrong), but my new lenovo is still a pile of useless iron.

@all:
The only temporary workaround I see is to force the kernel to forget damned UEFI. In fact, (K)Ubuntu 10.04 LiveUSB works fine with reboot/halt and even suspend, but it couldn't boot installed system. So I'm gonna try to install normal, UEFI-less grub on /dev/sda, then boot linux by chainload from UEFI-ed grub. I know, it looks crazy, but it seems that s205's bios unable to work with MBR loaders =(

I really hope that they will fix this issue in the nearest future. Otherwise it's better to return laptop to the store.

jar_ohty (jar-ohty) wrote :

I found the work around this bug on Lenovo S205.
Enter the BIOS SETUP (F2 on start) and choose "Boot" entry. You can see "ubuntu" item on the top of boot sequence list and a name of your HDD below. It is need to raise this item to the top instead of "ubuntu". Press F10 to save. After that kernel can boot with "noefi" option and with that, halt/reboot/sleep working properly.
Sorry for my English...

Igor Mitrenko (igor-mitrenko) wrote :

@jar_ohty, thank you very much!

I confirm, this woraround works on my Lenovo s205. Also it SHOULD work for others cases when kernel panics on uefi call, cause this workaround prevents kernel to use uefi.

Florian Heyer (heyho-flanto) wrote :

@jar_ohty: great! On my Lenovo S205 it works too. Thanks!

Doki (lkishalmi) wrote :

With recent oneiric kernel (just upgraded from Alpha 2) restart works with EFI (grub-efi).

tags: added: kernel-oops
Changed in linux-2.6 (Debian):
status: Unknown → Confirmed
Mr.Jack (mr-jack1501) wrote :

On Fedora 15 the lenovo ideapad s205 shut down, reboot and suspend to ram work correctly. Maybe this is because it uses systemd instead of upstart?

Timothy Mayoh (timothy-m) wrote :

I believe Fedora 15 uses a newer version of Linux where the problem has already been fixed. It doesn't seem to occur for me when attempting to replicate it in Oneiric either.

I upgraded to Ubuntu 11.10, but still have the same problem with 3.0 based kernel. Linux kernel still crashes during reboot or shutdown. I've a Gateway FX6850-51u desktop (with an hard to identify motherboard, all it says is it was made by Acer).

exactt (giesbert) wrote :

This is fixed for me in Oneiric.

Timothy Mayoh (timothy-m) wrote :

Confirmed - no longer a problem in Oneiric but still exists in previous versions.

It's odd. For me it seems to be fixed for "reboot" case. But my system still hangs for "shutdown" (power off) case. Are you sure you tested both cases?

Timothy Mayoh (timothy-m) wrote :

Yes, I am personally not seeing this issue with hardware very similar to the original reporter's on shutdown, restart, suspend, hibernate or resume.

monochromec (monochromec) wrote :

Grub-efi in combination with "reboot=a,w" fixed the kernel crash issue on reboot for an AMI-based BIOS (dated April of this year, will provide more details soon) for an Athlon II X2 245e-based system both for kernel version 2.6.38 and 3.0.0. Halting the system with either shutdown -P or -H still crashes the kernel, pm-hibernate works though.

monochromec (monochromec) wrote :

PS: This is the exact BIOS information as reported by dmidecode:

Vendor: American Megatrends Inc.
 Version: 080014
 Release Date: 04/02/2011

OliFre (freyermuth) wrote :

@monochromec:
If your motherboard really has a bios and your are not running in (U)EFI-mode, you are hit by another bug likely unrelated to this one.
Please check your motherboard-datasheet whether you are using a BIOS or an EFI-based system.

monochromec (monochromec) wrote :

@OliFre: good question - couldn't check as neither the BIOS setup nor the motherboard specs could tell me. How can I find out? My initial assumption was that a BIOS that new would support (U)EFI but maybe I'm simply wrong....

OliFre (freyermuth) wrote :

@monochromec:
If a search for the motherboard model and (U)EFI reveals nothing, and you have no BIOS-emulation-options in the EFI-setup, I am not sure how to check.
Maybe a "dmesg | grep -i efi" could give an answer.

In my case grepping dmesg output for EFI string results in:

[ 0.000000] EFI v2.10 by American Megatrends
[ 0.000000] Kernel-defined memdesc doesn't match the one from EFI!

Followed by bunch of (mem00 through mem188):

[ 0.000000] EFI: mem00: type=3, attr=0xf, range=[0x0000000000000000-0x0000000000008000) (0MB)
[ 0.000000] EFI: mem01: type=7, attr=0xf, range=[0x0000000000008000-0x0000000000077000) (0MB)
[ 0.000000] EFI: mem02: type=4, attr=0xf, range=[0x0000000000077000-0x0000000000078000) (0MB)
[ 0.000000] EFI: mem03: type=3, attr=0xf, range=[0x0000000000078000-0x00000000000a0000) (0MB)
[ 0.000000] EFI: mem04: type=2, attr=0xf, range=[0x0000000000100000-0x000000000056d000) (4MB)
[ 0.000000] EFI: mem05: type=7, attr=0xf, range=[0x000000000056d000-0x0000000001000000) (10MB)

etc (through mem188)... I could provide all memXXX lines if needed. Followed by:

[ 1.264080] efifb: probing for efifb
[ 1.264341] efifb: framebuffer at 0xd9000000, mapped to 0xffffc90012880000, using 1920k, total 1920k
[ 1.264343] efifb: mode is 800x600x32, linelength=3200, pages=1
[ 1.264344] efifb: scrolling: redraw
[ 1.264345] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[ 1.264390] fb0: EFI VGA frame buffer device
[ 1.535400] EFI Variables Facility v0.08 2004-May-17

So, I'd guess based on the above output that my Gateway system is indeed EFI based.

Andy Whitcroft (apw) on 2012-04-26
description: updated
Changed in ubuntu-release-notes:
status: New → Fix Released
monochromec (monochromec) wrote :

The issue went away for me with a kernel update. Unfortunately, I can't remember which exact version was involved but I think it was one of the earlier 3.1.x ones. I'm now able to reboot and halt without EFI parameters on the kernel cmdline.

monochromec: Are you also able to power off? Currently, on my system, attempting to power off results in machine halting, but not powering off.

monochromec (monochromec) wrote :

@Alex: Both powering off and halting works with this kernel version.

My system is on 3.2.0-27, but powering off still doesn't work. If I switch to console during shutdown, the last message printed by kernel is that the system is halted, but my system stays powered on.

monochromec (monochromec) wrote :

@Alex: here's my cmdline that I use for this machine: "usbcore.autosuspend=-1 loglevel=3 hpet=disable acpi_sleep=nonvs". Most of this stuff is hibernate/suspend related but maybe the hpet setting helps...

Changed in linux (Ubuntu Precise):
status: New → Confirmed
Changed in linux (Ubuntu Quantal):
importance: Undecided → High

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Changed in linux-2.6 (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.