slow wifi (atheros [ath9k] driver issue)

Bug #721449 reported by Mauricio Pretto on 2011-02-18
112
This bug affects 21 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

wifi doesn't goes as fast as 15kb/s

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image (not installed)
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Uname: Linux 2.6.38-4-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mauricio 1529 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xb4400000 irq 43'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:111d7605,103c1435,00100402 HDA:80862804,80860101,00100000'
   Controls : 18
   Simple ctrls : 10
Date: Fri Feb 18 16:48:46 2011
HibernationDevice: RESUME=UUID=6ad34996-363b-4128-acd8-106c367a7227
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
MachineType: Hewlett-Packard HP Pavilion dv5 Notebook PC
ProcEnviron:
 LANGUAGE=en
 LANG=pt_BR.utf8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-4-generic root=UUID=d41c324c-2de3-40c5-ab8a-013ce21bec4d ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-4-generic N/A
 linux-backports-modules-2.6.38-4-generic N/A
 linux-firmware 1.47
SourcePackage: linux
dmi.bios.date: 05/24/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.08
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1435
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 58.1D
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.08:bd05/24/2010:svnHewlett-Packard:pnHPPaviliondv5NotebookPC:pvr049F100000243010000020000:rvnHewlett-Packard:rn1435:rvrKBCVersion58.1D:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv5 Notebook PC
dmi.product.version: 049F100000243010000020000
dmi.sys.vendor: Hewlett-Packard

Mauricio Pretto (pretto) wrote :
Mauricio Pretto (pretto) wrote :

Also described here : https://bugs.launchpad.net/ubuntu/+source/kernel-package/+bug/709564
I'm downloadig the 2.6.38-rc5 to test it

Mauricio Pretto (pretto) wrote :

     Linux kernel image for version 2.6.37 on x86/x86_64
ii linux-image-2.6.38-020638rc5-generic 2.6.38-020638rc5.201102160907
gives me kernel panic on boot time

Mauricio Pretto (pretto) wrote :

ii linux-image-2.6.38-020638rc4-generic 2.6.38-020638rc4.201102081010 Linux kernel image for version 2.6.38 on x86/x86_64

iHR linux-image-2.6.38-999-generic 2.6.38-999.201102181625 Linux kernel image for version 2.6.38 on x86/x86_64

both kernel panic

Mauricio Pretto (pretto) wrote :
tags: added: regression-release
removed: regression-update
Mauricio Pretto (pretto) wrote :

okay, finally got installed a 2.6.38 branch .

Linux koontz 2.6.38-999-generic #201102181625 SMP Fri Feb 18 16:29:21 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

the problem happens the same way

there is a download limit around 15/25 kb/s

Mauricio Pretto (pretto) wrote :

I wish someone would just take a look at that.
And give me some steps of what else can I do to find the root of the problem.
last update for kernel still have the same problem.

Mauricio Pretto (pretto) wrote :

Attached
downloading from cdimages with 2.6.38-5

Mauricio Pretto (pretto) wrote :

Now the same download, in the same machine, with kernel 2.6.37

Mauricio Pretto (pretto) wrote :

This seems to be related to N support in my chipset
I have disabled the N support in my wi-fi router and the problem is gone
other problem showed up , but this one is gone without using N

Tobias Wolf (tobias-mr-wolf) wrote :

Thanks for the workaround, I just tried it. Using G instead of N-standard resolves it. Nevertheless, I like having a fast N wireless connection...

What helped me with this issue was to use the old kernel that was installed in ubuntu 10.10 before the upgrade (I think it was linux kernel 2.6.35). But using G-standard I can actually use the newer kernel 2.6.38...

Tobias Wolf (tobias-mr-wolf) wrote :

Sorry, I accidently posted my bug report seperately instead of here (i'm rather unfamiliar with launchpad).
It can be found here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/737505

Mauricio Pretto (pretto) wrote :

hi tobias can you past the output of lspci on your machine

Mauricio Pretto (pretto) wrote :

One side effect of the work around for is that I have good performance, but .....
if I download a very large file for example a iso image from cdimages.ubuntu at some point the wi-fi will become completely unresponsive . So I have reconnect to the wi-fi network

Tobias Wolf (tobias-mr-wolf) wrote :

This the output of lspci:

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev 02)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV380 [Radeon X600 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV380 [Radeon X600]
03:02.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)
03:08.0 Ethernet controller: Intel Corporation N10/ICH 7 Family LAN Controller (rev 01)

---------------------
Since I'm using a USB device (bus 1 device 4) to connect to my wireless network I'll also post output of lsusb:

Bus 005 Device 002: ID 04b4:0060 Cypress Semiconductor Corp.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0471:0815 Philips (or NXP) eHome Infrared Receiver
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 1058:0901 Western Digital Technologies, Inc. MyBook External HDD
Bus 001 Device 004: ID 0cf3:1002 Atheros Communications, Inc. TP-Link TL-WN821N v2 [Atheros AR9001U-(2)NG]
Bus 001 Device 003: ID 0644:0200 TEAC Corp. All-In-One Multi-Card Reader CA200/B/S
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Mauricio Pretto (pretto) wrote :

This is your device:
Bus 001 Device 004: ID 0cf3:1002 Atheros Communications, Inc. TP-Link TL-WN821N v2 [Atheros AR9001U-(2)NG]

This is mine:
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

So I would guess (I'm far to be any kernel engineer) this is related to atheros drivers .

Changed in linux (Ubuntu):
status: New → Confirmed
Mauricio Pretto (pretto) wrote :

As we have more than one reporter now , I marked as confirmed to try to bring some attention to this bug.

summary: - slow wifi
+ slow wifi (atheros driver issue)

I'm also experiencing the same problem with the following hardware

$sudo lspci -v
03:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)
 Subsystem: D-Link System Inc Device 3a70
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fdcf0000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 2
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
 Capabilities: [60] Express Legacy Endpoint, MSI 00
 Capabilities: [90] MSI-X: Enable- Count=1 Masked-
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Virtual Channel
 Kernel driver in use: ath9k
 Kernel modules: ath9k

The following workaround originally found here http://aptosid.com/index.php?name=PNphpBB2&file=viewtopic&p=6499 seems to work for me as a workaround.

create the file /etc/modprobe.d/ath9k.conf and add

options ath9k nohwcrypt=1

Save and reload the module or reboot.

Tobias Wolf (tobias-mr-wolf) wrote :

Thank you very much Terry for the workaround and for sharing your experience with us.

Unfortunately it did NOT help in my case, even though I tried this little trick with all atheros kernel modules I could find.

It's quite disappointing... especially that this regression does not seem to draw much attention by developers. (although I must admit that it doesn't seem to be a grave bug... it is really frustrating, still ...)

tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Tobias Wolf (tobias-mr-wolf) wrote :

So... I finally resolved the issue effectively without any remaining restrictions. But in order to do that I made a rather 'radical' move...

I installed the carl9170 firmware and compiled the carl9170 kernel module from compat-wireless package. (This might take about 10-15 minutes of your time)

Firmware:
http://wireless.kernel.org/en/users/Drivers/carl9170#Firmware-1
Kernel Modules:
http://wireless.kernel.org/en/users/Download/stable/#compat-wireless_2.6.38_stable_releases

!!! Warning !!! I won't guarantee that this won't harm your system. I will NOT be responsible for any damage.

1) To install the firmware, I ran:
sudo wget http://www.kernel.org/pub/linux/kernel/people/chr/carl9170/fw/1.9.2/carl9170-1.fw

2) To compile and install the module, I downloaded and unpacked:
http://www.orbit-lab.org/kernel/compat-wireless-2.6-stable/v2.6.38/compat-wireless-2.6.38.2-2.tar.bz2

If it is not already the case you must boot to the kernel 2.6.38 (I had to do this because I was using kernel 2.6.35 until now)
Open a terminal and change dir to the one you just unpacked and run:
 ./scripts/driver-select atheros
make
sudo make install

Either you make a reboot at that point or you run following commands:
sudo make unload
sudo modprobe 'carl9170'
(also have a look into 'ReadMe', it says essentially the same)

Unplugging and plugging my usb device in again, I could already enjoy a stable and fast wifi connection.
(If at some point you want to uninstall these kernel-modules again just run "make uninstall" in the directory in which you ran "make" from...)

Tobias Wolf (tobias-mr-wolf) wrote :

Sorry, I forgot one important point:

BEFORE running wget in point 1) you will need to change directory to /lib/firmware/ by running:
cd /lib/firmware/

Tobias Wolf (tobias-mr-wolf) wrote :

Oh, carl9170 already seems to be part of the kernel, so you might just try this:

https://wiki.archlinux.org/index.php/Wireless_Setup#carl9170

Mauricio Pretto (pretto) wrote :

Okay, I sold that machine, so I'm unsubscribe from that bug
I hope this get fixed

Jaromir Obr (jaromir-obr) wrote :

It happens to me after upgrade 10.10 -> 11.04, but sometimes only.

$ uname -a
Linux turion 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

$ lspci -v
05:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
 Subsystem: Askey Computer Corp. Device 7141
 Flags: bus master, fast devsel, latency 0, IRQ 18
 Memory at d3200000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: <access denied>
 Kernel driver in use: ath9k
 Kernel modules: ath9k

Bug isn't in older kernel 2.6.35

Krzysztof Janowicz (janowicz) wrote :

same slow wifi problem here for Network controller: Intel Corporation Ultimate N WiFi Link 5300 max connection about 20kbs, installing the backports help but does not solve the issue

Tobias Wolf (tobias-mr-wolf) wrote :

Sorry for posting this often, but for my USB device the solution turned out to be even simpler than what I described before:

(1) Type into terminal:
gksu gedit /etc/modprobe.d/blacklist.conf

(2) Add those to lines to the file and save
blacklist arusb_lnx
blacklist ar9170usb

(3) Reboot your system

This is all that is needed to make your usb networking device work if you experience this bug.

I have AR9285 and also experience this bug. I lose connections with remote systems and have low speed. Kernel .35 was fine.

There is no working workaround for my issue.

summary: - slow wifi (atheros driver issue)
+ slow wifi (atheros [ath9k] driver issue)
Gleb Mazovetskiy (glex-spb) wrote :

I am having the same problem (With Atheros AR9285)

Info:

gleb ~ $ iwconfig wlan0
wlan0 IEEE 802.11bgn ESSID:"WLAN_6C26"
          Mode:Managed Frequency:2.422 GHz Access Point: 64:68:0C:75:6C:29
          Bit Rate=54 Mb/s Tx-Power=12 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=54/70 Signal level=-56 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:1820 Invalid misc:1946 Missed beacon:0

lspci -v

02:00.0 Network controller: Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
 Subsystem: Foxconn International, Inc. Device e030
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at e8e00000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: <access denied>
 Kernel driver in use: ath9k
 Kernel modules: ath9k

Joachim R. (jro) wrote :

I have an Atheros AR9285 on my netbook (Ubuntu 11.04, Linux 2.6.38-10) and installing 2.6.39 backports solved the upload problem? I have no download problem (wifi g)

I also have an Atheros AR922X with a slow download problem : download never goes up 250kiB, while upload reaches 500kiB (and knowing signal quality, expected download speed is nearly 3MiB (wifi g))

Nico_argentina (ferrettinico) wrote :

This problem still occurs in Oneiric Beta 1...

Nico_argentina (ferrettinico) wrote :

Ok, just for you to know, during these days I tested with the following releases:

Oneiric Beta 1 -> The problem is there
Natty -> The problem is there
10.10 -> Here it works fine!

I hate the Atheros wireless cards. I've met this problem on so many laptops. Anyway, one of my older laptops have a "Intel Corporation Ultimate N WiFi Link 5300" (as reported from lspci -v). It seems this does not use the ath9k driver, so the reported workaround does not work. However, this workaround seems to work "modprobe iwlagn swcrypt=1" (or put it in /etc/modprobe.d similar to how it's done with the ath9k driver). Hopefully that will work better until a real fix is implemented.

Sorry, use "swcrypto=1", which seems to work better (I forgot the "o" at the end in my previous message).

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers