Headphone and Speakers are switched on Amilo Xi1526

Bug #71737 reported by KamiKasi
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

First I thought that the jack sense of the Amillo isn't working but now I found out the I control the headphone with the front channel and the speakers with headphone.

Now I think the headphone jack isn't recognized because the hardware 'thinks' this is speaker but I could not unplug the real speakers to test this out... ;)

My system is Edgy, Kernel 2.6.17-10-generic.
Soundcard is snd_hda_intel (82801G??)
Intelchipset is Intel 945PM+ICH7-M

Do not know if this is a Kernel or ALSA problem...

PS: Sorry for my bad english!

KamiKasi (rungeka)
description: updated
Revision history for this message
FraGe (fragebuntu) wrote :

Hi @ all,

sorry for my late reply, but here it comes. I'd like to confirm this bug in Dapper Drake.
Same machine, a FSC Amilo Xi1526.
Furthermore I guess because of the problem with the switched controls the volume wheel doesn't work.

thx, and all the best for christmas!!
FraGe

Revision history for this message
KamiKasi (rungeka) wrote :

Added lspci -n -v

Revision history for this message
KamiKasi (rungeka) wrote :

I've updated to festy yesterday.

Hoped it ould be better with the new version but its getting worse. :(

First there was no sound at all.
Then I tried some tips from an other bugreport: #94373

Adding 'options snd-hda-intel model=3stack' to /etc/modprobe.d/alsa-base helped but only Headphone is working. Speakers are still dead.

I've turned up every levler in alsamixer but nothing helped.

I think one problem could be that tail -2 /proc/asound/oss/sndstat shows only 0: Motorola Si3054 which seems to be the modem...

Don't know what to do next please help!

Revision history for this message
KamiKasi (rungeka) wrote :

My entry in the Ubuntu hardware database: 2bdbe65746be9be50924705d362882da

Revision history for this message
KamiKasi (rungeka) wrote :

The used codec for snd_hda_intel is Realtek ALC880

I've read that there are many problems with Realtec chips. I hope you find a solution fast - or I've to downgrade to Edgy. :(

Revision history for this message
trollord (trollenlord) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

The issue that you reported is one that should be reproductable with the live environment of the Desktop CD of the development release - Gutsy Gibbon. It would help us greatly if you could test with it so we can work on getting it fixed in the actively developed release. You can find out more about the development release at [WWW] http://www.ubuntu.com/testing/

In case you still have the problem, could you please attach the information requested in https://help.ubuntu.com/community/DebuggingSoundProblems

Thanks in advance.

Revision history for this message
KamiKasi (rungeka) wrote :

Hello trollord,

yes the problem still occurs.

I've testet with Gusty Tribe 4 and 5.

In Tribe 4 I can activate the sound with Tribe 5 it is not possible anymore...
There are much lesser levelers/channels in Tribe 5.

To activate sound in Tribe 4 I had to use H-Phone & one other (I do not remember right now) channel to hear any sound. Heaphone Jack was working right (no switched sound!) and the jack-sense was working too!

I will add the debugging information for both Versions as soon as possible! (Could take some days, sorry...)

Revision history for this message
KamiKasi (rungeka) wrote :

Sorry I was quite busy last time...

Now I have already installed Gutsy on the Amilo Xi 1526 and was a little unhappy cause sound didn't work.
But after adding

      options snd-hda-intel model=auto

to /etc/modprobe.d/alsa-base I had Sound. But with the same problems as with Feisty. :(

Today I've tried with the snd-hda-intel devices and found that

      options snd-hda-intel model=6stack-dig

works perfectly! :D
Sound from Speakers, when I plug in the Headphone sound mutes on speakers and headphone works! Gr8!
Mic works too!

I'm now absolutly satisfied!

Revision history for this message
trollord (trollenlord) wrote :

Could someone make that setting default for that specific pci id or something?

Revision history for this message
Daniel T Chen (crimsun) wrote :

There is already an entry for this machine in patch_realtek.c::alc880_cfg_tbl[]:

SND_PCI_QUIRK(0x1734, 0x10ac, "FSC", ALC880_UNIWILL),

Changed in alsa-driver:
status: Confirmed → Fix Released
Revision history for this message
KamiKasi (rungeka) wrote :

Now Sound really works!

Everything ist OK now after adding

  options snd-hda-intel model=fujitsu

to /etc/modprobe.d/alsa-base.
Speaker and headphone works right, and the volume wheel also works now!

Revision history for this message
Kiketom (kike-bsk-deactivatedaccount) wrote :

Hi!
I have the Amilo Xi 1526 and i installed the Ubuntu 8.10 on it.
The sound on front speakers and headphones works well.
But when i put the headphones, the sound on the speakers continous playing and the little wheel for adjusting the volume is not working.

I have insert at bottom of my alsa-base file
    options snd-hda-intel model=fujitsu

But it stills not working.
What I am missing?

Revision history for this message
Marc VB (marc-van-ballaert) wrote :

Hi,

On my Amilo Xi 1526 I had Ubuntu 7.04, 7.10, 8.04, 8.10 and now 9.04 installed.
The problem with the sound has always been the same.
Settings with the best result are : options snd-hda-intel model=6stack-dig.
(There seems to be an ALC885 in there)

This allows me to regulate volume of speakers (surround leveler) and Headphone (master leveler) separately.

issues:
Plugging in the headphones does not silence the speakers.
The volume wheel of the headphone does not work at all.

Any suggestions?

Tnx,

Marc

Revision history for this message
Ptitphysik (amalpeyre) wrote :

options snd-hda-intel model=fujitsu in /etc/modprobe.d/alsa-base.conf works.
But installation of Karmic or Lucid doesn't include this.

Is it possible to really fix that ?

Thx

Changed in linux (Ubuntu):
status: Fix Released → New
assignee: FraGe (fragebuntu) → nobody
tags: added: kernel-sound
tags: added: kj-triage
Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Ptitphysik,
    Please open a new bug for your issue.

Thanks!

~JFo

Changed in linux (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers