natty, ppc kernel linux-image-2.6.38-2-powerpc fails to boot

Bug #714165 reported by Jonathan Hudson on 2011-02-06
This bug report is a duplicate of:  Bug #745358: PowerPC images unbootable.. Edit Remove
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Attempting to boot linux-image-2.6.38-2-powerpc on a PPC G4 (ancient powerbook) results in the following error:

ext2: i/o error 2133571364 in read

As the kernel does not boot, it is impossible to run the commands listed in the 'report a bug' page against this kernel.

 linux-image-2.6.38-1-powerpc boots fine.

The boot loader is yaboot (not grub2), as the machine has been dist-upgraded from earlier versions. root fs is ext4, /boot is a directory on the root partition.

Reinstalling the kernel package does not help.

Jonathan Hudson (jh+lpd) wrote :

Same problem with linux-image-2.6.38-3-powerpc. Not booting the kernel is something of a regression.

Jonathan Hudson (jh+lpd) wrote :

Neither of the 2011-02-11 or 2011-02-12 Install CDs (live or alternative) boot:

Please wait, loading kernel...
Read failed

Jonathan Hudson (jh+lpd) wrote :

Doesn't boot from grub either (but linux-image-2.6.38-1-powerpc does), so maybe I should rebuild the machine with grub as the bootloader (needs a bigger hd:2, alas).

Dave McIntosh (mcintoshd) wrote :

I'm having the same problem exactly as described on my iBook G4 (powerpc)
with either a dist upgrade from 10.10 to 11.04 or trying to boot from the daily
build CDs.

Frans van Berckel (fberckel) wrote :

Confirming the bug on a PPC G4 desktop.

Andrew Holmes (llama233) wrote :

Confirming the bug on my PPC G4 PowerBook

Jonathan Hudson (jh+lpd) wrote :

Same bug in linux-image-2.6.38-4-powerpc .... alas

Jeremy Foshee (jeremyfoshee) wrote :

Hi jh,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 714165

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jonathan Hudson (jh+lpd) wrote :

I'm not sure the automated message hints are much help:

* As I cannot boot the kernel, running the apport-collect command will be challenging;

* I'm not aware there are mainline builds for powerpc at http://kernel.ubuntu.com/~kernel-ppa/mainline/ (are there?). I'm happy to build from kernel.org sources (e.g.-rc6) if that helps; just takes a while on an old G4. Please advise.

-jh

Jonathan Hudson (jh+lpd) wrote :

linux-image-2.6.38-5-powerpc fails in exactly the same way.

kernel.org 2.6.38-rc6 boots (at least as far as failing to mount the root device, which is probably mea culpa for failing to compile something important in).

-jh

Jonathan Hudson (jh+lpd) wrote :

The somewhat static (no-initrd) kernel.org -rc6 kernel boots, at least as far as losing a fight with Plymouth / udev. But it does boot, which is more that the Ubuntu variants do.

Next steps: Build k.org rc6 using config-2.6.38-5-powerpc for 'make oldconfig'. If that fails to boot, then use config-2.6.38-1-powerpc.

Will probably take a couple of days given the time to compile and the time I'm available to play with the results.

-jh

Jonathan Hudson (jh+lpd) wrote :

k.org rc6 using config-2.6.38-5-powerpc fails to boot in the same way as ubuntu built kernels. I'll try config-2.6.38-1-powerpc next.

-jh

Jonathan Hudson (jh+lpd) wrote :

Progress. Building kernel.org -rc6 kernel against the config-2.6.38-1-powerpc results in a booting kernel and usable machine (X seems broken, but it is with the Ubuntu 2.6.38-1-powerpc kernel).

So it's something in the config changes? Out of my depth here, but available to build / test on direction.

-jh

Geoffrey Pursell (geoffp) wrote :

Will GRUB2 boot an old G4 machine now? It would be interesting to see if that would work where yaboot fails, but I'm not willing to risk further breakage right now.

I can still boot using the "old" kernel. It looks like the upgrade process left a 2.6.35 in the yaboot menu. I can boot to that fine, though I get corruption on my X desktop.

tags: removed: needs-upstream-testing

Please no grub, but go on with yaboot.
Have Natty running on G4 now with linux-image-2.6.38-1-powerpc kernel.
The X Desktop does in Classic Desktop mode, what it got to do.

Frans van Berckel

On Wed, 2011-03-09 at 21:28 +0000, Geoffrey Pursell wrote:
> Will GRUB2 boot an old G4 machine now? It would be interesting to see
> if that would work where yaboot fails, but I'm not willing to risk
> further breakage right now.
>
> I can still boot using the "old" kernel. It looks like the upgrade
> process left a 2.6.35 in the yaboot menu. I can boot to that fine,
> though I get corruption on my X desktop.
>
> ** Tags removed: needs-upstream-testing
>

Geoffrey Pursell (geoffp) wrote :

> The X Desktop does in Classic Desktop mode, what it got to do.

I'm not sure what you're trying to say.

Jonathan Hudson (jh+lpd) wrote :

linux-image-2.6.38-7-powerpc fails in exactly the same way.

My theory (which I'm unlikley to be able to test, at least in the medium term) is that the new config changes that cause the problem (based on new kernels built against 2.6.38-1 configs working).

CONFIG_LOWMEM_SIZE=0x30000000
CONFIG_PAGE_OFFSET=0xc0000000
CONFIG_KERNEL_START=0xc0000000
CONFIG_PHYSICAL_START=0x00000000
CONFIG_TASK_SIZE=0xc0000000

vice

CONFIG_LOWMEM_SIZE=0x30000000
CONFIG_PAGE_OFFSET=0xc0000000
CONFIG_KERNEL_START=0xc2000000
CONFIG_PHYSICAL_START=0x02000000
CONFIG_TASK_SIZE=0xc0000000

Just a guess .....

-jh

Jeremy Huddleston (jeremyhu) wrote :

This is a huge issue. A non-booting default kernel seems like something to be concerned about... why is there no motion on this ticket?

Jonathan Hudson (jh+lpd) wrote :

The latest yaboot update causes the failure to boot to emit different error messages, which gives perhaps further credibility to the config kernel memory change theory offered in #17 <https://bugs.launchpad.net/ubuntu/+source/linux/+bug/714165/comments/17>

Attempting to boot linux-image-2.6.38-7-powerpc,

Error messages:
Claim error, can't allocation b00000 at 0xc2000000
Claim error, can't allocate kernel memory

linux-image-2.6.38-1-powerpc boots just fine with the updated yaboot.

-jh

Jonathan Hudson (jh+lpd) wrote :

I do not think this is a dup, as the kernel does not boot with the new yaboot

Jeremy Huddleston (jeremyhu) wrote :

Based on the state of bug #745358, you probably don't have the fix yet. You need to wait for the next kernel as well. Also, don't forget to run 'sudo ybin'

Dave McIntosh (mcintoshd) wrote :

I can confirm the experience of jh in #19 in this thread as of natty-desktop-powerpc daily build dated april 03, 2011.
This will still not boot for me with the same error messages as indicated. If this issue has been fixed, when can we expect
it to show up in the daily builds?

When the next revision of the Linux kernel is uploaded to natty. When that will be I don't know, but a notification will be added to the original bug as to when the upload is made.

Frans van Berckel (fberckel) wrote :

from bug #745358. -> Changed in linux (Ubuntu Natty) Status: Fix Committed → Fix Released Now

Frans van Berckel (fberckel) wrote :

from bug #745358. -> 2.6.38-8-powerpc #41-Ubuntu Tue Apr 5 21:53:50 UTC 2011 ppc ppc ppc GNU/Linux does boot!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers