Ubuntu

ExpressCard compact flash card fails to hotplug

Reported by Damon Lynch on 2011-02-05
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using Natty alpha 2 with the latest updates, running on a Lenovo T400s. When inserting a Lexar ExpressCard CompactFlash (CF) reader into the ExpressCard slot after Ubuntu is already booted, nothing happens. There is nothing in dmesg to indicate an event has occurred.

This is the product: http://www.lexar.com/products/lexar-professional-expresscard-compactflash-cf-reader?category=213

If the card reader and card is present at boot time, the card is mounted as expected. I will reboot and attach some relevant information that shows the hardware messages in dmesg when the card is mounted at boot time.

The machine is in AHCI mode. Hotplugging worked under Maverick.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-1-generic 2.6.38-1.28
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: damon 1367 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf2620000 irq 46'
   Mixer name : 'Conexant CX20585'
   Components : 'HDA:14f15069,17aa2132,00100302'
   Controls : 8
   Simple ctrls : 5
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6HHT14WW-1.02'
   Mixer name : 'ThinkPad EC 6HHT14WW-1.02'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Fri Feb 4 21:12:12 2011
HibernationDevice: RESUME=UUID=bc754809-bf19-44d5-ace4-6e4028ee147c
HotplugNewDevices:

HotplugNewMounts:

InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
MachineType: LENOVO 2801CTO
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=1a217fba-4cce-4ad8-b624-8d17416b2f1c ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-1-generic N/A
 linux-backports-modules-2.6.38-1-generic N/A
 linux-firmware 1.46
SourcePackage: linux
Symptom: storage
UdevMonitorLog:
 monitor will print the received events for:
 UDEV - the event which udev sends out after rule processing
UdisksMonitorLog: Monitoring activity from the disks daemon. Press Ctrl+C to cancel.
dmi.bios.date: 12/09/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6HET34WW (1.19 )
dmi.board.name: 2801CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6HET34WW(1.19):bd12/09/2010:svnLENOVO:pn2801CTO:pvrThinkPadT400s:rvnLENOVO:rn2801CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2801CTO
dmi.product.version: ThinkPad T400s
dmi.sys.vendor: LENOVO

Damon Lynch (dlynch3) wrote :
Damon Lynch (dlynch3) wrote :
Download full text (7.5 KiB)

Relevant information from sudo lspci -vv, when after booting with the ExpressCard CF reader and CF card inserted before boot:

05:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller (prog-if 85 [Master SecO PriO])
 Subsystem: JMicron Technology Corp. JMB368 IDE controller
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 19
 Region 0: I/O ports at 4020 [size=8]
 Region 1: I/O ports at 4014 [size=4]
 Region 2: I/O ports at 4018 [size=8]
 Region 3: I/O ports at 4010 [size=4]
 Region 4: I/O ports at 4000 [size=16]
 [virtual] Expansion ROM at f2900000 [disabled] [size=64K]
 Capabilities: [68] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] Express (v1) Legacy Endpoint, MSI 01
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-
  LnkCap: Port #1, Speed 2.5GT/s, Width x1, ASPM L0s, Latency L0 <1us, L1 <16us
   ClockPM- Surprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [70] MSI: Enable- Count=1/1 Maskable- 64bit-
  Address: 00000000 Data: 0000
 Kernel driver in use: pata_jmicron
 Kernel modules: pata_jmicron

Some relevant output from dmesg, when after booting with the ExpressCard CF reader and CF card inserted before boot:

[ 1.308314] udev[74]: starting version 165
[ 1.355564] pata_jmicron 0000:05:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 1.355610] pata_jmicron 0000:05:00.0: setting latency timer to 64
[ 1.362895] scsi0 : pata_jmicron
[ 1.366095] scsi1 : pata_jmicron
[ 1.366145] ata1: PATA max UDMA/100 cmd 0x4020 ctl 0x4014 bmdma 0x4000 irq 19
[ 1.366148] ata2: PATA max UDMA/100 cmd 0x4018 ctl 0x4010 bmdma 0x4008 irq 19
[ 1.382061] e1000e: Intel(R) PRO/1000 Network Driver - 1.2.20-k2
[ 1.382063] e1000e: Copyright(c) 1999 - 2011 Intel Corporation.
[ 1.382095] e1000e 0000:00:19.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[ 1.382106] e1000e 0000:00:19.0: setting latency timer to 64
[ 1.382248] e1000e 0000:00:19.0: irq 43 for MSI/MSI-X
[ 1.560701] ata1.00: CFA: TRANSCEND, 20091215, max UDMA/133
[ 1.560704] ata1.00: 125059072 sectors, multi 0: LBA
[ 1.560707] ata1.00: limited to UDMA/33 due to 40-wire cable
[ 1.580098] usb 1-6: new high speed USB device using ehci_hcd and address 3
[ 1.600683] ata1.00: configured for UDMA/33
[ 1.600837] scsi 0:0:0:0: Direct-Access ATA TRANSCEND 2009 PQ: 0 ANSI: 5
[ 1.600983] sd 0...

Read more...

Brad Figg (brad-figg) on 2011-04-07
Changed in linux (Ubuntu):
status: New → Confirmed
Damon Lynch (dlynch3) wrote :

I don't think this bug is specific to a CompactFlash reader. I have since learned that this bug also affects a ExpressCard USB 3 device I have. Another user (presumably using a recent spin of Fedora) reports that his ExpressCard Firewire device also has the exact same problem.

Ricardo Restituyo (warchiefx) wrote :

I have a similar problem since upgrading to Natty (release). My Echoaudio Indigo DJX is no longer detected when mounted, even though I setup the parameter pciehp.pciehp_force=1 on the kernel command line.

This used to work on Maverick. The card works if it's inserted at boot time, but hotplugging it doesn't work anymore.

leelo12345 (karstenlinnow) wrote :

Hi,

i am not shure if this is the right place for my problem . I am an newbie on linux but it seems that my problem is the same as the above listed bug.

After upgrading to Natty (fresh install) Natty will not detect my SD Card in my Samsung Omnia phone (USB plugged). Under Maverick, everything runs fine and without any problem. If my Handy is plugged in, the second HD in my PC is blocked and there is no detection of my SD card. A workaround to solve the problem with no really satisfaction is the following:

looking for the following line on "/lib/udev/rules.d/40-usb_modeswitch.rules" and wrote it out with a #

ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="1000", RUN+="usb_modeswitch '%b/%k'"

then:

sudo service udev reload

Now, after waiting 5 - 15 minutes the 8 GB SD-card appears in Nautilus. Then it is possible to open the SD Card after clicking on the second HD but I have no rhights to rename or delete something. After logging in as root I can do such things as renaming or delete files.

In a flash card reader my card will be detect almost imediatly, but there is an coding problem with UTF8 and the filenames will be shown with questionmarks when there are ÄÖÜ etc.

Attached an txt file with my dmesg, lsusb, fstab and fdisk comments

I am running an AMD Athlon 64 bit dual core processor 3800+ on Natty

Please excuse my bad english..... Broken english, spoken perfectly.... ;-)

Veovis (masterkedri) wrote :

I too see this problem, Express card for USB 3 support not recognizing devices. To add some more info, in my case when I booted the computer with the card in and the flash drive already plugged in I was able to look at the contents, format the drive, but I was not able to do much more than that. After unmounting the drive I was not able to remount it. Any information needed in addition to what is provided above I can give, just ask.

Cristian Arezzini (macavity80) wrote :

Similar problem here - with a Creative X-fi ExpressCard audio card. Works if inserted at boot, nothing happens (even in dmesg) if inserted later.
Is there at least a command to make the laptop see this card if I insert it after boot? Something like a "re-scan ExpressCard port"?

Damon Lynch (dlynch3) wrote :

This is fixed with kernel revision 2.6.38-10. I've tested it with a USB 3 device and an express card compact flash reader.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers