does not detect resolution correctly(xserver-xorg-video-nouveau causes graphic corruption were you cant do anything)

Bug #711591 reported by zeruke on 2011-02-02
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
Nouveau Xorg driver
Fix Released
Critical
linux (Ubuntu)
High
Andy Whitcroft

Bug Description

Binary package hint: xorg

this is probably a known issue...but xorg chooses wrong resolution on live discs which causes bad graphical issues untill you figure out how to get the resolution lower.....for me it used to be were i could figure it out but it seems now i cant because its really messed up as shown on the jpeg i added

and usually it does the same after installing which really causes problems so it might be good to put it as safe graphics by default.

this one shown on the screenshot is from the 31-Jan-2011 daily live using a cell phone camera

----edit:
for some more info im useing a HP Pavilion dv6605us with a nvidia GeForce 7150M /nForce 630M built-in graphics the max screen resolution is 1280x800 for the screen which is a 15"

----edit2:
it seems nouveau is part of the problem because now no matter the resolution i use i get the same graphical issues and i know that nouveau loads at default when using nvidia till a different driver is loaded for it
---
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1024x768 800x600 640x480 720x400 640x400 640x350
 edid-base64: AP///////wBMo0UzAAAAAAAOAQOAIRV4Cof1lFdPjCcnUFQAAAABAQEBAQEBAQEBAQEBAQEB7hoAgFAgEDAQMBMAS88QAAAZAAAADwAAAAAAAAAAACOHAmQBAAAA/gBTQU1TVU5HCiAgICAgAAAA/gBMVE4xNTRYMy1MMDEKAGg=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x768 1280x1024 1024x768 1024x768 800x600 800x600 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wBCkwkD3QcBABgNAQMIIBjG6lwRnllHmycQSE+hSgAxWQEBRVlFaGFZgYABAQEB6iQAYEEAKDAwYBMAQPAQAAAeMCoAmFEALEAwcBMAQPAQAAAeAAAA/QAyoB5GCwAKICAgICAgAAAA/wBGQlVMMzYwNjc1NDlVAJ0=
DistUpgraded: Fresh install
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
GdmLog: Not present
GdmLog1: Not present
GdmLog2: Not present
GraphicsCard: Subsystem: Hewlett-Packard Company Device [103c:30cf]
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 13fe:3423 Kingston Technology Company Inc.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Hewlett-Packard HP Pavilion dv6500 Notebook PC
Package: xorg-server (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine:
 noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash --
 maybe-ubiquity
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Renderer: Software
Tags: natty natty ubuntu
Uname: Linux 2.6.38-1-generic i686
UserGroups:

dmi.bios.date: 03/03/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.32
dmi.board.name: 30CF
dmi.board.vendor: Quanta
dmi.board.version: 85.26
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.32:bd03/03/2009:svnHewlett-Packard:pnHPPaviliondv6500NotebookPC:pvrRev1:rvnQuanta:rn30CF:rvr85.26:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6500 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu5
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

zeruke (oninekoze) wrote :
zeruke (oninekoze) wrote :

i did some checking by doing all of the resolutions i could by adding vga=(whatever resolution) which makes it seem to be more of a driver problem which by what i know the default for the daily live build is nouveau...

bugbot (bugbot) on 2011-02-02
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
zeruke (oninekoze) on 2011-02-02
description: updated
zeruke (oninekoze) on 2011-02-02
description: updated
Chris Halse Rogers (raof) wrote :

Hm. That looks pretty bad. Would it be possible for you to collect logs from a livecd which displays that problem? Running “apport-collect 711591” should collect all the relevant logs and attach them to this bug.

Changed in xorg-server (Ubuntu):
status: New → Incomplete
importance: Undecided → High
zeruke (oninekoze) wrote :

@Chris

ok i'll do that sometime today....and yea it used to not be as bad were a simple resolution change fixed it and now it just doesnt get fixed up that way

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

zeruke (oninekoze) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

both using laptop screen and a screen connected to the VGA port gets the same problems on the graphics but the console is able to be seen in an ok state on the screen connected to the VGA port

zeruke (oninekoze) wrote :

well i decided to try something which proves that its xserver-xorg-video-nouveau thats causing the problem because if i add to the other options line area for booting into the live cd with "nouveau.modeset=0" the graphics show correctly

zeruke (oninekoze) on 2011-02-04
affects: xorg-server (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
summary: - does not detect resolution corectly
+ does not detect resolution correctly(xserver-xorg-video-nouveau causes
+ graphic corruption were you cant do anything)
Changed in nouveau:
importance: Unknown → Critical
status: Unknown → Confirmed
edmon (bozhan-abv) wrote :

I have the same problem with my video card:

00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 6100 nForce 405] (rev a2)

edmon (bozhan-abv) wrote :

 Option "NoAccel" "True"

helps

zeruke (oninekoze) wrote :

@edmon

that helps for some people and iv tried that and shadowFB and a combination of them and both gave the same results of an unusable GUI....and by the looks of it its started doing this stuff sence a few patches by whats came up on the upstream bug report, so you might want to keep checking on that end too https://bugs.freedesktop.org//show_bug.cgi?id=33887

Bryce Harrington (bryce) wrote :

[ 5.368826] [drm] nouveau 0000:00:12.0: 5: 0x00000340: type 0x40 idx 5 tag 0xff
[ 5.368833] [drm] nouveau 0000:00:12.0: Parsing VBIOS init table 0 at offset 0xE333
[ 5.368855] [drm] nouveau 0000:00:12.0: ======= misaligned reg 0x001020FB =======
[ 5.368861] [drm] nouveau 0000:00:12.0: ======= misaligned reg 0x001020FB =======
[ 5.368891] [drm] nouveau 0000:00:12.0: Parsing VBIOS init table 1 at offset 0xE484

misaligned reg sounds weird. Other than that (and a lot of other nouveau verbosity) there doesn't seem to be an obvious error message in dmesg, nor anything in /var/log/Xorg.0.log to indicate that the system was in a broken state.

Are you certain you did apport-collect while the system was exhibiting the issue?

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Given that they're looking at kernel patches in the upstream bug report, that suggests this is a linux kernel drm bug. Which makes sense since -nouveau relies on kernel modesetting. Refiling to linux. Nevermind my last comment.

affects: xserver-xorg-video-nouveau (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New
Andy Whitcroft (apw) on 2011-02-11
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

On the upstream bug a preliminary patch is suggested. I have pulled this patch into the Natty kernel for testing. Could those of you affected by this bug give the kernels with this fix a test and report back here. The kernels are at the URL below:

    http://people.canonical.com/~apw/lp711591-natty/

Thanks.

zeruke (oninekoze) wrote :

the patch fixes it were now i can see for the most part but it doesnt fix what was going on befor the compleate blocking of the screen

still has a small tiling of about 3 or so when resolution is at 1280x800(16:10) which i believe is my screens native resolution....that tiling is fixed by lowering the resolution which i now have at 1024x768(4:3)

it seems to have the small tiling when the aspect ratio is at (16:10) and (9:5), all resolutions using the aspect ratio (4:3) shows things perfectly when using the patch

edmon (bozhan-abv) wrote :

The kernels are at the URL below:

    http://people.canonical.com/~apw/lp711591-natty/

works for me! :)

Changed in linux:
status: Unknown → Confirmed
Changed in linux (Ubuntu):
status: New → Incomplete
status: Incomplete → Invalid
Changed in linux:
status: Confirmed → Fix Released
Andy Whitcroft (apw) wrote :

This was reported as tested fixed in v2.6.38-rc6 based kernels. As these are now in the Archive I am closing this out Fix Released.

Changed in linux (Ubuntu):
status: Invalid → Fix Released
Changed in nouveau:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.