[STAGING] Broadcom 4313 firmware fails to load because it is not present

Bug #707353 reported by Pete Goodall on 2011-01-25
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Canonical Kernel Team
Natty
High
Canonical Kernel Team

Bug Description

I'm using a Dell Inspiron m101z which was certified for use with both Ubuntu 10.04 and 10.10. Previously the Broadcom chipset for wireless used the proprietary drivers, but this card is now apparently blacklisted and presumably covered by the new mac80211 drivers. The card does not show up as available, but is idenfied by lspci.

$ lspci | grep Broadcom
03:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

Checking dmesg I can see that the firmware fails to load because the specific filename is not present:

$ dmesg | grep brcm
[ 11.184346] brcm80211: module is from the staging directory, the quality is unknown, you have been warned.
[ 11.192457] brcm80211 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 11.192468] brcm80211 0000:03:00.0: setting latency timer to 64
[ 11.884891] brcm80211: fail to load firmware brcm/bcm43xx-0.fw
[ 11.884897] brcm80211: Failed to find firmware usually in /lib/firmware/brcm
[ 11.884942] brcm80211 0000:03:00.0: PCI INT A disabled
[ 11.884962] brcm80211: wl_pci_probe: wl_attach failed!

I have tried installing the proprietary driver, but receive a message that my card is blacklisted:

$ jockey-text --list
kmod:wl - Broadcom STA wireless driver (Proprietary, Disabled, Not in use) [auto-install]
xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Disabled, Not in use)

$ jockey-text --enable=kmod:wl
Additional Drivers
Searching for available drivers...

Sorry, the installation of this driver failed.

Please have a look at the log file for details.: /var/log/jockey.log

I installed both b43-fwcutter and b43-fwcutter and firmware-b43-installer:

$ dpkg -l b43-fwcutter firmware-b43-installer
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii b43-fwcutter 1:013-3 Utility for extracting Broadcom 43xx firmwar
ii firmware-b43-i 4.150.10.5-5 Installer package for firmware for the b43 d

The firmware-b43-installer package does install firmware, but none of the .fw files has the filename the system is looking for:

$ ls -l /lib/firmware/brcm/
total 368
-rw-r--r-- 1 root root 269595 2010-11-18 21:20 bcm4329-fullmac-4-218-248-5.bin
-rw-r--r-- 1 root root 1604 2010-11-18 21:20 bcm4329-fullmac-4-218-248-5.txt
-rw-r--r-- 1 root root 97376 2010-11-18 21:20 bcm43xx-0-610-809-0.fw
-rw-r--r-- 1 root root 180 2010-11-18 21:20 bcm43xx_hdr-0-610-809-0.fw

I tried making a symlink from bcm43xx-0-610-809-0.fw and bcm43xx_hdr-0-610-809-0.fw (separately) to bcm43xx-0.fw, but that just makes the system hang on boot.

Anyway, I'm out of ideas... This may just be a point-in-time bug, but I figured it should be reported as this is a common chipset and a previously certified device.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-generic (not installed)
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic-pae 2.6.37
Uname: Linux 2.6.37-12-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC259 Analog [ALC259 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: pgoodall 1386 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd0400000 irq 16'
   Mixer name : 'Realtek ALC259'
   Components : 'HDA:10ec0269,10280470,00100100'
   Controls : 13
   Simple ctrls : 8
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xd0110000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Jan 25 10:56:53 2011
HibernationDevice: RESUME=UUID=ba30a010-5c2a-48b9-a4f8-119ec71d3e8e
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110120)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Dell Inc. Inspiron 1120
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic-pae root=UUID=d550288a-2fd0-48d7-9506-55b5736b8223 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.37-12-generic-pae N/A
 linux-backports-modules-2.6.37-12-generic-pae N/A
 linux-firmware 1.46
SourcePackage: linux
StagingDrivers: brcm80211
Title: [STAGING]
dmi.bios.date: 07/23/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X24
dmi.board.asset.tag: 1234567890
dmi.board.name: 0102BK
dmi.board.vendor: Dell Inc.
dmi.board.version: X24
dmi.chassis.asset.tag: 1234567890
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: X24
dmi.modalias: dmi:bvnDellInc.:bvrX24:bd07/23/2010:svnDellInc.:pnInspiron1120:pvrX24:rvnDellInc.:rn0102BK:rvrX24:cvnDellInc.:ct8:cvrX24:
dmi.product.name: Inspiron 1120
dmi.product.version: X24
dmi.sys.vendor: Dell Inc.

Pete Goodall (pgoodall) wrote :

same for me. running natty on a dell Inspiron N5010

Jeff Fortin Tam (kiddo) wrote :

Same here, I am unable to get wifi working on clean installs of ubuntu 10.10 with a Dell Mini 9 and a Dell Vostro 3500 (both Ubuntu-certified machines). I used to be able to make it work simply by activating the proprietary driver offered in ubuntu's restricted driver manager (jockey), but this doesn't work anymore nowadays.

Is there any known workaround or a set of packages to install or a way to manually install drivers so that it just works? I've tried various combinations with drivers available in synaptic, to no avail.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Natty):
importance: Undecided → High
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
milestone: none → ubuntu-11.04-beta-1
tags: added: kernel-key
Florian Stoll (flostoll) wrote :

I have also a BCM4313 wireless card in my asus eeepc 1015pem and it works fine in maverick and natty with brcm80211,mac80211... open source modules.

In Maverick I installed linux-backports-modules-compat-wireless and downloaded firmware files to /lib/firmware/brcm/* with symlinks.
In Natty modules and firmware files are included but symlinks are missing, see following bug:
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/728746

Wireless card has to be enabled in bios or wlan will not work, even if you push keyboard shortcuts... (led off)!
I guess state of wireless card and bluetooth in bios can be influenced by state in operating system.

Hi All,

I'm marking this as a duplicate of bug 728746. Please continue to track the status of this issue using bug 728746. As a side note, I've sent a pull request to the kernel team mailing list with a patch to resolve the missing symlink issue. Thanks.

Oytun (oytunnew18) wrote :

I'm fixed this poblem a forum post.

Link: http://forums.debian.net/viewtopic.php?f=30&t=78407

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers