High CPU load when machine is idle kernel 2.6.35

Bug #706592 reported by Dennis Kruyt
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Lucid
Low
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: linux-image-2.6.35-24-generic

My Dell 1750 server has jumping loads from 0 to 3.0 while the machine is idle.

There is no CPU usage, no zombie procs running and no IO waits.

The issue ls the same to me as reported here:

https://patchwork.kernel.org/patch/367101/
https://bbs.archlinux.org/viewtopic.php?id=103346&p=1

Revision history for this message
Dennis Kruyt (dennis-kruyt) wrote :
Revision history for this message
Dennis Kruyt (dennis-kruyt) wrote :
Revision history for this message
Stefan Bader (smb) wrote :

For current development release, this patch is included and should be released now. For Maverick, the mentioned patch which is commit 0f004f5a696a9434b7214d0d3cbd0525ee77d428 upstream is needed. For Lucid there is potentially the same issue. Though we currently carry some other patch which would need to get replaced by both upstream parts.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
Changed in linux (Ubuntu Maverick):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Stefan Bader (smb) wrote :

Likely will need to revert

commit 0d843425672f4d2dc99b9004409aae503ef4d39f
Author: Chase Douglas <email address hidden>
Date: Thu Apr 8 12:02:11 2010 -0400

    sched: update load count only once per cpu in 10 tick update window

and apply this one instead:

commit 74f5187ac873042f502227701ed1727e7c5fbfa9
Author: Peter Zijlstra <email address hidden>
Date: Thu Apr 22 21:50:19 2010 +0200

    sched: Cure load average vs NO_HZ woes

Though it would be better to have some confirmation on the miscalculation for Lucid in order to get a sensible validation if we make these changes.

Revision history for this message
Dennis Kruyt (dennis-kruyt) wrote :

note: When I boot with nohz=off the jumpy loads are gone.

Stefan Bader (smb)
Changed in linux (Ubuntu Maverick):
status: Triaged → Won't Fix
assignee: Stefan Bader (stefan-bader-canonical) → nobody
Changed in linux (Ubuntu Lucid):
importance: Undecided → Low
Revision history for this message
Stefan Bader (smb) wrote :

I am unaware of any confirmation for this in Lucid and without some way to confirm any change does work or not there is no justification to make any modifications.

Changed in linux (Ubuntu Lucid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Bug attachments