[HDA-Intel] No digital audio output with latest kernel patch (2.6.35-25-generic-pae)

Bug #705313 reported by Roberto Leinardi on 2011-01-20
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

After the upgrade to the latest kernel patch (2.6.35-25-generic-pae) no sound is played by the Digital Audio Output.

The sound works well with the kernel patch 2.6.35-24-generic-pae.

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-25.43-generic-pae 2.6.35.10
Uname: Linux 2.6.35-25-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: jd 5211 F.... pulseaudio
 /dev/snd/controlC0: jd 5211 F.... pulseaudio
 /dev/snd/pcmC0D1p: jd 5211 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfbff8000 irq 51'
   Mixer name : 'Realtek ALC889'
   Components : 'HDA:10ec0889,1458a022,00100004'
   Controls : 38
   Simple ctrls : 21
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xf9ffc000 irq 17'
   Mixer name : 'Nvidia GPU 11 HDMI/DP'
   Components : 'HDA:10de0011,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Card2.Amixer.info:
 Card hw:2 'SAA7134'/'saa7133[0] at 0xfb8ff000 irq 16'
   Mixer name : 'SAA7134 Mixer'
   Components : ''
   Controls : 6
   Simple ctrls : 3
Date: Thu Jan 20 09:35:19 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.utf8
 SHELL=/bin/bash
SelectedCard: 0 Intel HDA-Intel - HDA Intel
SourcePackage: alsa-driver
Symptom: audio
Title: [HDA-Intel - HDA Intel] ALSA test tone not correctly played back
dmi.bios.date: 11/26/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: Fc7
dmi.board.name: X58A-UD7
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFc7:bd11/26/2010:svnGigabyteTechnologyCo.,Ltd.:pnX58A-UD7:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnX58A-UD7:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: X58A-UD7
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Roberto Leinardi (leinardi) wrote :
summary: - [HDA-Intel] No digital audio output with latest kernel pach (2.6.35-25
+ [HDA-Intel] No digital audio output with latest kernel patch (2.6.35-25
-generic-pae)
Robert Hrovat (robi-hipnos) wrote :

Confirming. Audio worked properly with 2.6.35-24 but stopped working after upgrade to 2.6.35-25. The only output that worked with latest kernel was HDMI audio. All other outputs did not produce any sound.

Jeremy Foshee (jeremyfoshee) wrote :

Hi JD,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-sound
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Griotte (waste52) wrote :

Hi there,

I have got the same problem,

I am not a Linux expert but I have noticed that the package called "upstart" is refusing to update, due to an error with libc6:
upstart:
  Breaks: libc6 (<2.12.1-0ubuntu10.2) but 2.12.1-0ubuntu10.1 is to be installed

I am wondering if this has to do something with it, but knowing how many package depend on libc6 I wouldn't be surprised

Thanks

G

squarooticus (krose) wrote :

I believe my bug (705405) is a duplicate of this one. I have the same audio device (ICH10, 8086:3a3e) and lost audio somewhere between 2.6.35-24 and 2.6.35-25. I am about to test mainline 2.6.35.10 and will check back in in a few minutes.

squarooticus (krose) wrote :

Upstream kernel 2.6.35.10 has the same problem, so this is not Ubuntu-specific. This is critical enough that I suspect it has been fixed in a more recent upstream kernel version, so I am going to try some variant of 2.6.38.

Sparafucile (derrick-everett) wrote :

I lost digital sound output on my 64-bit computer a few days back, apparently with the upgrade to kernel 2.6.35-25. I have tried various things in the hope of getting sound back, including upgrading to the next kernel 2.6.35-26 and updating the alsa drivers, uninstalling and reinstalling pulseaudio, etc., but so far nothing helps. My audio card is described by lspci as follows:

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

squarooticus (krose) wrote :

Sparafucile: sounds like the same bug. FWIW, this problem still exists with mainline kernel 2.6.38, so the problem is neither Ubuntu specific nor, as yet, solved.

Roberto Leinardi (leinardi) wrote :

Does anyone have news?

tags: removed: needs-upstream-testing
enb (elitenoobboy) wrote :

This happens with upstream kernels as well, including 2.6.38. Trying kernel specific alsa driver dev releases from the audio dev ppa does not fix the problem for me either.

Changed in linux (Ubuntu):
status: Incomplete → New
enb (elitenoobboy) wrote :

This bug might be related to this:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/704401

From that page, it looks like adding
options snd-hda-intel model=6stack-dig
to /etc/modprobe.d/alsa-base.conf might fix it.

squarooticus (krose) wrote :

Indeed, that solves it for me. Thanks, enb.

Lee Burch (ltburch2000) wrote :

Yes, worked for me too.

confrimed that #11 works for me as well

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers