Ubuntu

After upgrade to linux-image-2.6.35-25 Radeon graphics are broken

Reported by Thomas Basset on 2011-01-16
150
This bug affects 26 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Maverick
High
Canonical Kernel Team

Bug Description

I've upgraded yesterday to linux-image-2.6.35-25. As I boot today my computer, graphics are all broken: only white and black dots but nothing is readable. The few texts (BIOS, GRUB) before the login are finely displayed, though. But GDM is unusable as the whole graphic environment.

If I boot with the previous kernel, everything just works fine.

My graphic card is a AMD/ATI Radeon 4670. I do not use the fglrx module.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-25-generic 2.6.35-25.43
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Uname: Linux 2.6.35-24-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: goon 2277 F.... pulseaudio
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfddf8000 irq 22'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,18491e01,00100001'
   Controls : 33
   Simple ctrls : 18
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfeafc000 irq 47'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sun Jan 16 14:28:34 2011
HibernationDevice: RESUME=UUID=5fd17ba9-2f87-4e59-9fcc-74e384142f88
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-24-generic root=UUID=5110df5b-63de-44e2-af28-7c925dd21dab ro quiet splash
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.38.3
SourcePackage: linux
dmi.bios.date: 03/06/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.30
dmi.board.name: 4Core1600Twins-P35
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.30:bd03/06/2008:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvn:rn4Core1600Twins-P35:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Thomas Basset (thomasbasset) wrote :

Hi,
exactly the same with Ubuntu 10.10 X64 and Radeon HD 4890. Tried fglrx but the problem remains.

Reverting to kernel 2.6.35-2x with x<5 resolve.

Roby

Montblanc (montblanc) on 2011-01-17
Changed in linux (Ubuntu):
status: New → Confirmed
Montblanc (montblanc) wrote :

Confirming.
I have an nVidia 9500 GT and using gfx payload to have a bootscreen with higher resolution.

2.6.35-25 with default parameters: it stucks at the boot logo.
2.6.35-25 recovery mode: it stucks at few lines of kernel starting up.

If I knew a way to install nVidia proprietary drivers on this kernel it would be great...

2.6.35-24 is no problem.

Max Bowsher (maxb) wrote :

Confirming also on an "ATI Technologies Inc Device 9488" (apparently I have an unrecognized pci id, even after running update-pciids).

Possibly relevant datum - lots of the following logging from the kernel:

[drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

tags: added: regression-proposed
removed: regression-release
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu Maverick):
importance: Undecided → High
status: New → Confirmed
Andy Whitcroft (apw) wrote :

This new maverick kernel incorporates the mainline update 2.6.35.10, could those affected please test the v2.6.35.10 mainline build and confirm whether the problem is also there. That can be found in the mainline kernel archive:

    https://wiki.ubuntu.com/Kernel/MainlineBuilds

tags: added: kernel-key
Thomas Basset (thomasbasset) wrote :

I can't find any 2.6.35.10 kernel at http://kernel.ubuntu.com/~kernel-ppa/mainline Could you give us the correct URL?

Changed in linux (Ubuntu Maverick):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Tom Nicholls (pmyteh) wrote :

I've also been unable to find the 2.6.35.10 kernel in the place specified, but I did install 2.6.35.9 and it works flawlessly for me - don't know if this is helpful or not.

tom@maturin:~$ uname -r
2.6.35-02063509-generic

Steve Conklin (sconklin) wrote :

Tom, that is helpful.

I've created the first in a series of kernels to bisect the changes. Could you please test the kernel here and tell me whether it works? Thanks!

http://people.canonical.com/~sconklin/maverick-bisect/

The Platform Services team has also found a machine which exhibits this problem, so we'll be able to test on multiple machines.

Tom Nicholls (pmyteh) wrote :

With the new 2.6.35-25.44~SPC01LP703553 package installed, I can confirm that the graphics failed as they did with the original 2.6.35-25.

I'm assuming that this package replaces the stock 2.6.35-25 in the grub menu with the new version - it didn't show up separately as the mainline kernel image did. Sorry if this is obvious - I don't normally change the stock kernel!

Tom Nicholls (pmyteh) wrote :

I should also add that the mainline 2.6.36 kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline also works fine for me.

Steve Conklin (sconklin) wrote :

Tom, all valuable information, and the behavior you saw in grub was normal.

Thanks for testing, The next test kernel is in the same place:

http://people.canonical.com/~sconklin/maverick-bisect/

Steve Conklin (sconklin) wrote :

And while I'm thinking about it, a big thank you to all the people who take -proposed kernels! I wonder how many there are, as I have no way of knowing.

Max Bowsher (maxb) wrote :

On my Dell Radeon hardware:
bisection spc01 => BAD
bisection spc02 => GOOD

Otus (jan-varho) wrote :

I can confirm that 2.6.35-25-generic #44~spc02LP703553 does not show the corruption. I have a Radeon 4850 and everything except the background image was corrupted with the original proposed kernel. I'm subscribing and can test any further kernel in the next few hours.

Tom Nicholls (pmyteh) wrote :

Confirmed: spc02 is good. I am now also available to test new kernels for the next few hours.

Steve Conklin (sconklin) wrote :

building kernels now, expect them in about 20-30 minutes

Steve Conklin (sconklin) wrote :

new test kernels are up

Tom Nicholls (pmyteh) wrote :

spc03 is working fine too.

Steve Conklin (sconklin) wrote :

thanks, building next test now

Tom Nicholls (pmyteh) wrote :

spc04 is also good.

Steve Conklin (sconklin) wrote :

04 is up.

Tom, are you using amd64 or i386? If i386 I'll not bother building amd64

Thanks,

Steve

Tom Nicholls (pmyteh) wrote :

amd64, as it happens.

Steve Conklin (sconklin) wrote :

got a report from another tester that 04 works, so I just prepped 05. Unless 04 fails for you, go ahead and test 05 if you can.

Thanks

Tom Nicholls (pmyteh) wrote :

Both 04 and 05 are good. (I did confirm 04 in message #20, but because it slightly preceded your announcement it's easy to miss!)

Steve Conklin (sconklin) wrote :

ok 06 is up.

Steve Conklin (sconklin) wrote :

Incidentally, the other tester reported 05 as bad.

Tom Nicholls (pmyteh) wrote :

06 is bad. I will try to downgrade and re-check 05, to see if I made a mistake, or if it's a genuine difference.

Otus (jan-varho) wrote :

For me 04 is good, 05 bad. Checking 06 next.

Otus (jan-varho) wrote :

And 06 is bad here too.

Tom Nicholls (pmyteh) wrote :

On downgrade, 05 is also bad. I think we can assume the first result was my error - sorry.

Steve Conklin (sconklin) wrote :

no problem, thanks for rechecking. 07 is ready.

Tom Nicholls (pmyteh) wrote :

07 is good.

Steve Conklin (sconklin) wrote :

08 is ready, thanks!

Tom Nicholls (pmyteh) wrote :

08 is bad.

Steve Conklin (sconklin) wrote :

very good. We're close.

Steve Conklin (sconklin) wrote :

09 is up

Tom Nicholls (pmyteh) wrote :

09 is good.

Steve Conklin (sconklin) wrote :

same as the other tester. That identifies the bad commit. I'll do a sanity build with only that patch reverted, and then I'll go off and ponder what to do next

Steve, just for our information, can you tell us which change you did
to the kernel that broke graphics?

Within the next couple of hours, the v2.6.35.10 kernel should be available here:

http://kernel.ubuntu.com/~kernel-ppa/mainline

We'll also need to get that tested so we can determine whether this is an Ubuntu-only problem, or whether it exists in the upstream longterm kernel.

Steve Conklin (sconklin) wrote :

Test kernel version linux-image-2.6.35-25-generic_2.6.35-25.44~spcrevert01
is up for testing. That should not exhibit the problem

Thanks for all the help!

Steve Conklin (sconklin) wrote :

If I'm correct, this is the patch that broke it:

commit 6f15f605120331a44aeacb4fca5550e2dfb92204
Author: Alex Deucher <email address hidden>
Date: Mon Oct 25 19:44:00 2010 -0400

    drm/radeon/kms: MC vram map needs to be >= pci aperture size

    BugLink: http://bugs.launchpad.net/bugs/690730

    commit b7d8cce5b558e0c0aa6898c9865356481598b46d upstream.

    The vram map in the radeon memory controller needs to be
    >= the pci aperture size. Fixes:
    https://bugs.freedesktop.org/show_bug.cgi?id=28402

    The problematic cards in the above bug have 64 MB of vram,
    but the pci aperture is 128 MB and the MC vram map was only
    64 MB. This can lead to hangs.

    Signed-off-by: Alex Deucher <email address hidden>
    Signed-off-by: Dave Airlie <email address hidden>
    Signed-off-by: Greg Kroah-Hartman <email address hidden>
    Signed-off-by: Andi Kleen <email address hidden>
    Signed-off-by: Brad Figg <email address hidden>

diff --git a/drivers/gpu/drm/radeon/r100.c b/drivers/gpu/drm/radeon/r100.c
index a89a15a..5c37c48 100644
--- a/drivers/gpu/drm/radeon/r100.c
+++ b/drivers/gpu/drm/radeon/r100.c
@@ -2321,6 +2321,9 @@ void r100_vram_init_sizes(struct radeon_device *rdev)
                /* Fix for RN50, M6, M7 with 8/16/32(??) MBs of VRAM -
                 * Novell bug 204882 + along with lots of ubuntu ones
                 */
+ if (rdev->mc.aper_size > config_aper_size)
+ config_aper_size = rdev->mc.aper_size;
+
                if (config_aper_size > rdev->mc.real_vram_size)
                        rdev->mc.mc_vram_size = config_aper_size;
                else

Steve Conklin (sconklin) wrote :

One tester reports that the kernel with the revert fails, so this may not be the right patch, or there may be interactions between patches. Investigating.

Tom Nicholls (pmyteh) wrote :

The test kernel fails for me, too.

Steve Conklin (sconklin) wrote :

consistency is good, even if I don't understand it. I'm investigating now

Steve Conklin (sconklin) wrote :

I found my mistake, I dumb-thumbed the last bisection.

The patch that's implicated now makes much more sense, and it;s even specific to the model listed in the bug.

I'll build again with that reverted and have it for testing

Here's the offending patch:

From fa7e0b5ba8551654a6887c5b1678c713c0e9c973 Mon Sep 17 00:00:00 2001
From: Alex Deucher <email address hidden>
Date: Mon, 18 Oct 2010 23:54:56 -0400
Subject: [PATCH] drm/radeon/kms: properly compute group_size on 6xx/7xx

BugLink: http://bugs.launchpad.net/bugs/690730

commit 881fe6c1d06bf49f4ab7aef212cdaf66bd059614 upstream.

Needed for tiled surfaces.

Signed-off-by: Alex Deucher <email address hidden>
Signed-off-by: Dave Airlie <email address hidden>
Signed-off-by: Greg Kroah-Hartman <email address hidden>
Signed-off-by: Andi Kleen <email address hidden>
Signed-off-by: Brad Figg <email address hidden>
---
 drivers/gpu/drm/radeon/r600.c | 7 +++++--
 drivers/gpu/drm/radeon/rv770.c | 9 +++++----
 2 files changed, 10 insertions(+), 6 deletions(-)

diff --git a/drivers/gpu/drm/radeon/r600.c b/drivers/gpu/drm/radeon/r600.c
index eddeff3..a40be95 100644
--- a/drivers/gpu/drm/radeon/r600.c
+++ b/drivers/gpu/drm/radeon/r600.c
@@ -1592,8 +1592,11 @@ void r600_gpu_init(struct radeon_device *rdev)
        rdev->config.r600.tiling_npipes = rdev->config.r600.max_tile_pipes;
        rdev->config.r600.tiling_nbanks = 4 << ((ramcfg & NOOFBANK_MASK) >> NOOFBANK_SHIFT);
        tiling_config |= BANK_TILING((ramcfg & NOOFBANK_MASK) >> NOOFBANK_SHIFT);
- tiling_config |= GROUP_SIZE(0);
- rdev->config.r600.tiling_group_size = 256;
+ tiling_config |= GROUP_SIZE((ramcfg & BURSTLENGTH_MASK) >> BURSTLENGTH_SHIFT);
+ if ((ramcfg & BURSTLENGTH_MASK) >> BURSTLENGTH_SHIFT)
+ rdev->config.r600.tiling_group_size = 512;
+ else
+ rdev->config.r600.tiling_group_size = 256;
        tmp = (ramcfg & NOOFROWS_MASK) >> NOOFROWS_SHIFT;
        if (tmp > 3) {
                tiling_config |= ROW_TILING(3);

diff --git a/drivers/gpu/drm/radeon/rv770.c b/drivers/gpu/drm/radeon/rv770.c
index 67e8073..082c380 100644
--- a/drivers/gpu/drm/radeon/rv770.c
+++ b/drivers/gpu/drm/radeon/rv770.c
@@ -627,10 +627,11 @@ static void rv770_gpu_init(struct radeon_device *rdev)
        else
                gb_tiling_config |= BANK_TILING((mc_arb_ramcfg & NOOFBANK_MASK) >> NOOFBANK_SHIFT);
        rdev->config.rv770.tiling_nbanks = 4 << ((gb_tiling_config >> 4) & 0x3);
-
- gb_tiling_config |= GROUP_SIZE(0);
- rdev->config.rv770.tiling_group_size = 256;
-
+ gb_tiling_config |= GROUP_SIZE((mc_arb_ramcfg & BURSTLENGTH_MASK) >> BURSTLENGTH_SHIFT);
+ if ((mc_arb_ramcfg & BURSTLENGTH_MASK) >> BURSTLENGTH_SHIFT)
+ rdev->config.rv770.tiling_group_size = 512;
+ else
+ rdev->config.rv770.tiling_group_size = 256;
        if (((mc_arb_ramcfg & NOOFROWS_MASK) >> NOOFROWS_SHIFT) > 3) {
                gb_tiling_config |= ROW_TILING(3);
                gb_tiling_config |= SAMPLE_SPLIT(3);
--
1.7.0.4

Daniel Manrique (roadmr) wrote :

Here's lspci -vv output for a test system that exhibits this problem (a Dell Inspiron 1545 with Radeon 4300 graphics).

Thanks for your efforts, Steve.
Although I haven't tried your test kernels yet, I can see from the
patches that the changes only reflect radeon modules (am I wrong?),
while graphics is broken for me with an nVidia card (proprietary
drivers).

I'll test 2.6.35-10 when it's out and will let you know.

a new test is up here:
http://people.canonical.com/~sconklin/maverick-bisect/

linux-image-2.6.35-25-generic_2.6.35-25.44~spcrevert02

Steve Conklin (sconklin) wrote :

Montblanc,

If the proprietary driver is broken, there's nothing I can do. If the problem persists without the proprietary drivers, please open a new bug for your hardware, as this bug is only addressing the radeon problem.

You can open a bug against the kernel from the command line like this:

ubuntu-bug kernel

Tom Nicholls (pmyteh) wrote :

spcrevert02 is GOOD.

Thanks for all you work on this, Steve - it's much appreciated. I'm logging off now, but will check back tomorrow to have a look at 2.6.35.10 mainline when it's released.

Daniel Manrique (roadmr) wrote :

I checked the upstream / mainline kernel as suggested by Steve. The kernel I installed on Maverick was this one:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35.10-maverick/linux-image-2.6.35-02063510-generic_2.6.35-02063510.201101192005_i386.deb

On my test system (Dell Inspiron 1545 with Radeon 4300) this kernel is BAD, and also exhibits breakage, as in a garbled and unusable display, just like we observed during the tests.

Just to be 120% sure, my running kernel is:

Linux dell-test 2.6.35-02063510-generic #201101192005 SMP Wed Jan 19 21:21:19 UTC 2011 i686 GNU/Linux

Steve,
Thanks for your reply.
nVidia proprietary drivers must be installed against ANY new kernel,
there's no dkms or any automatic module building. So what I do after
installing a new kernel is getting to the tty shell and install nVidia
drivers against the running kernel. But on 2.6.35-25 I can't even get
to the tty shell.
So, as you can see, there are no nvidia modules on 2.6.35-25. The
title says "broken graphics", not "broken ati graphics", should I
really file a NEW bug report?

I'm not affected by this bug because I don't have proposed enabled. But since this will be the next one on Maverick I tested the one from #49 which is ok here.
2.6.35-25-generic #44~spcrevert02 SMP Wed Jan 19 22:10:37 UTC 2011 x86_64 GNU/Linux

$ sudo lshw -C video
*-display
       description: VGA compatible controller
       product: RV710 [Radeon HD 4350]
       vendor: ATI Technologies Inc
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:45 memory:d0000000-dfffffff memory:fe9e0000-fe9effff ioport:c000(size=256) memory:fe9c0000-fe9dffff

Daniel Manrique (roadmr) wrote :

Montblanc,

Pending a more authoritative answer, for the ATI bug it *is* possible to go to the console (ctrl-alt-f1) and do stuff from there. If you're unable to do so and you're on an NVidia GPU, that would suggest a different issue.

Thanks Daniel,
I'll try the fixed kernel once it's out (just in case...) then I'll
file a new bug if it's still present. What I was saying is just that
2.6.35-25 has broken graphics for ati and nvidia too, and even if it
comes from different issues, it broke graphics in a way for ati and in
another for nvidia.

Regards,
~montblanc

Steve Conklin (sconklin) wrote :

Montblanc,

Yes, open a new bug. Kernel bug policy is that we have a different bug for each set of hardware affected, especially graphics, audio, and other subsystems with specific drivers.

summary: - After upgrade to linux-image-2.6.35-25 graphics are broken
+ After upgrade to linux-image-2.6.35-25 Radeon graphics are broken
Robert Hooker (sarvatt) wrote :

It looks like userspace was broken by that kernel commit, and fixing up userspace (mesa) will break things for people without that kernel update so it is a tricky situation..

https://bugzilla.kernel.org/show_bug.cgi?id=24802

It should be noted that it can be worked around temporarily also by disabling desktop effects.

Montblanc (montblanc) wrote :

Hey guys,
I filed bug #705596 which is related to nVidia users. Pretty please, would you kindly have a look to it?

Thank you very much,
~montblanc

Thomas Basset (thomasbasset) wrote :

Hello there. Thanks for the amazing work you did this week I was not able to help but I read all the comments with great interest.

I've tested http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35.10-maverick/linux-image-2.6.35-02063510-generic_2.6.35-02063510.201101192005_amd64.deb which is still broken (in a different manner though: I've got some colors :D ).

Should I test another kernel?

Martin Pitt (pitti) wrote :

linux (2.6.35-25.44) maverick-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon/kms: properly compute group_size on 6xx/7xx"
    - LP: #703553

Changed in linux (Ubuntu Maverick):
status: Confirmed → Fix Released
Steve Conklin (sconklin) wrote :

There is a new kernel in -proposed with this patch reverted. Please test the new kernel (2.6.35-25.44) and report on whether it resolves the issue.

Thanks for all the help.

Steve Conklin (sconklin) on 2011-01-24
tags: added: verification-needed
jnq35 (quero-jeannoel) wrote :

Ok bug fix for me with the last update of the kernel.

Download full text (3.3 KiB)

Fixed for me as well

On 24 January 2011 10:28, jnq35 <email address hidden> wrote:
> Ok bug fix for me with the last update of the kernel.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (703352).
> https://bugs.launchpad.net/bugs/703553
>
> Title:
>  After upgrade to linux-image-2.6.35-25 Radeon graphics are broken
>
> Status in “linux” package in Ubuntu:
>  Invalid
> Status in “linux” source package in Maverick:
>  Fix Released
>
> Bug description:
>  I've upgraded yesterday to linux-image-2.6.35-25. As I boot today my
>  computer, graphics are all broken: only white and black dots but
>  nothing is readable. The few texts (BIOS, GRUB) before the login are
>  finely displayed, though. But GDM is unusable as the whole graphic
>  environment.
>
>  If I boot with the previous kernel, everything just works fine.
>
>  My graphic card is a AMD/ATI Radeon 4670. I do not use the fglrx
>  module.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 10.10
>  Package: linux-image-2.6.35-25-generic 2.6.35-25.43
>  Regression: Yes
>  Reproducible: Yes
>  ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
>  Uname: Linux 2.6.35-24-generic x86_64
>  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
>  Architecture: amd64
>  AudioDevicesInUse:
>   USER        PID ACCESS COMMAND
>   /dev/snd/controlC0:  goon       2277 F.... pulseaudio
>  CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
>  Card0.Amixer.info:
>   Card hw:0 'Intel'/'HDA Intel at 0xfddf8000 irq 22'
>     Mixer name : 'Realtek ALC888'
>     Components : 'HDA:10ec0888,18491e01,00100001'
>     Controls      : 33
>     Simple ctrls  : 18
>  Card1.Amixer.info:
>   Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfeafc000 irq 47'
>     Mixer name : 'ATI R6xx HDMI'
>     Components : 'HDA:1002aa01,00aa0100,00100100'
>     Controls      : 4
>     Simple ctrls  : 1
>  Card1.Amixer.values:
>   Simple mixer control 'IEC958',0
>     Capabilities: pswitch pswitch-joined penum
>     Playback channels: Mono
>     Mono: Playback [on]
>  Date: Sun Jan 16 14:28:34 2011
>  HibernationDevice: RESUME=UUID=5fd17ba9-2f87-4e59-9fcc-74e384142f88
>  InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
>  MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
>  ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-24-generic root=UUID=5110df5b-63de-44e2-af28-7c925dd21dab ro quiet splash
>  ProcEnviron:
>   LANG=fr_FR.utf8
>   SHELL=/bin/bash
>  RelatedPackageVersions: linux-firmware 1.38.3
>  SourcePackage: linux
>  dmi.bios.date: 03/06/2008
>  dmi.bios.vendor: American Megatrends Inc.
>  dmi.bios.version: P1.30
>  dmi.board.name: 4Core1600Twins-P35
>  dmi.chassis.asset.tag: To Be Filled By O.E.M.
>  dmi.chassis.type: 3
>  dmi.chassis.vendor: To Be Filled By O.E.M.
>  dmi.chassis.version: To Be Filled By O.E.M.
>  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.30:bd03/06/2008:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvn:rn4Core1600Twins-P35:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
>  dmi.product.name: To Be Filled By O.E.M.
>  dmi.product.version: To Be Filled By O.E.M.
>  dmi.sys.vendor...

Read more...

Steve Conklin (sconklin) on 2011-01-24
tags: added: verification-done
removed: verification-needed
Thomas Basset (thomasbasset) wrote :

Fixed as well. Thanks ;-)

Daniel Manrique (roadmr) wrote :

Apologies for taking this long to help validate.

I just reinstalled Maverick on our test system, and updated, I'm now running this kernel:

Linux 200910-4252 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:48 UTC 2011 i686 GNU/Linux

Everything seems fine display-wise, no garbling or corruption.

Montblanc (montblanc) wrote :

The changes that were reverted in 2.6.35-25.44 solved graphics issues for nVidia cards too, as I suspected. I was able to telinit 3 and install the drivers against this kernel and everything is working fine now. It was useless to open bug #705596 since it was really related to this one (probably it was the same issue), but thanks to Steve for (unknowingly) fixing it! :)

Andy Whitcroft (apw) wrote :

@Montblac -- it is not clear how the patch that was reverted could help an Nvidia system as the code path is only exercised on a couple of very specific pieces of radeon hardware. The module containing that code would not even be loaded if you do not have Radeon hardware nor even if it was would the code in question run as the cards in questions would not be present. Whatever has fixed your issue is really very unlikely to be the revert on this bug.

Montblanc (montblanc) wrote :

I understand it too, but fact is that after the fix was released,
graphics did not hang as before for me. An arcane to be solved...

I experienced the same as Montblanc, i have an nvidia gtx 260m with propietary drivers.

Montblanc (montblanc) wrote :

Oh, i was not alone, at least! Since graphics hung for nVidia users at
the same time Ati users got it screwed up, and it started working
again after a Radeon fix was released, it seems that the buggy changes
made to the kernel affected overall graphics. Also, my mainboard has
an Ati chipset, don't know if it helps.

Hi everyone,

I have Nvidia drivers and after updating to 2.6.35-25 nvidia drivers seem to be broken and only work if I start in 2.6.35-24 kerner version. I kinda get lost reading all the comments....is there a quick fix for this?

Thanks and best regards,
Alex

Montblanc (montblanc) wrote :

alejandrovk,
The problem with nvidia *proprietary* drivers was fixed for me as you
can see in bug #705596 , if you're still having problems then please
refer to that bug or open a new one.

axeoth (axeoth) wrote :

I still receive the same message on Xubuntu 12.04 3.2.0-25-generic #40-Ubuntu SMP Wed May 23 20:30:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux, while trying to launch a demo combining Qt and Irrlicht.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.