Ubuntu

[Conexant CX20585] Recording problem with internal mic

Reported by Schmidt on 2011-01-10
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
David Henningsson

Bug Description

I'm using Ubuntu Maverick and the latest Alsa modules from the Ubuntu Audio Dev PPA.

First Headphone jack hasn't worked. Got it working with latest driver and
options snd_hda_intel model=hp-laptop (ideapad and thinkpad are working too)

Mic-Jack is also working just the internal mic doesn't want to record a sound. I tried http://ubuntuforums.org/showthread.php?p=9162799 , but doesn't help.
Maybe the linuxant driver helps, but they won't compile for lates kernel (maybe to get an idea whats wrong...)

Regards Jan

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Uname: Linux 2.6.35-24-generic x86_64
AlsaVersion:
 Advanced Linux Sound Architecture Driver Version 1.0.23.
 Compiled on Jan 10 2011 for kernel 2.6.35-24-generic (SMP).
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jan 1694 F.... pulseaudio
                      jan 1965 F.... alsamixer
 /dev/snd/pcmC0D0c: jan 1694 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd5200000 irq 47'
   Mixer name : 'Conexant CX20585'
   Components : 'HDA:14f15069,104313f3,00100302'
   Controls : 8
   Simple ctrls : 5
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xd0040000 irq 48'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Jan 10 23:38:43 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SelectedCard: 0 Intel HDA-Intel - HDA Intel
SourcePackage: alsa-driver
Symptom: audio
Title: [Conexant CX20585] Recording problem
dmi.bios.date: 10/28/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K52JU.203
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K52JU
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK52JU.203:bd10/28/2010:svnASUSTeKComputerInc.:pnK52JU:pvr1.0:rvnASUSTeKComputerInc.:rnK52JU:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: K52JU
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Schmidt (h3ll) wrote :
David Henningsson (diwic) wrote :

Hi Schmidt, could you please try the following:

1) https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules
2) add this line to /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=hp-laptop
3) reboot and test. Is everything working now? If so, I'll put a quirk in the driver so that the next version of Ubuntu will have this working by default.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Schmidt (h3ll) wrote :

Hi, thanks for replying.

Have tested that before and tested it again.

The the internal speakers are working with that solution and also the speaker-jack works fine.
An external microphon is working to, just the internal one isn't. I got no signal when the external microphon is not plugged in even with 40db amplification.

Regards Jan

P.S.: The output of the internal speakers are also not that loud even with PCM and Master set to 100 at the alsamixer and rythmbox.

Schmidt (h3ll) on 2011-01-12
Changed in alsa-driver (Ubuntu):
status: Incomplete → Confirmed
David Henningsson (diwic) wrote :

Ok, sorry if I didn't read your initial report well enough. Actually it seems like there is no current model supporting 0x1a as internal mic and that a new model (or better, some autodetection!) should be written.

Thanks for your bug report, marking as triaged for now.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Triaged
Flyboy (lukas-loser) wrote :

Same problem here on Lenovo G560, with stock kernel 2.6.36 on archlinux, speakers are not loud at 100% and internal mic is not working. Tried hda analyzer , maxed up Node 0x14 as suggested for workaround at https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.32/+bug/590756. Didnt work for me. Happy to post any outputs, just let me know.

David Henningsson (diwic) wrote :

@Flyboy, since you have different hardware, please file a separate bug, e g using the "ubuntu-bug audio" command. Thanks!

Flyboy (lukas-loser) wrote :

Yep, i'll finish flying on Friday so i can install ubuntu ( currently on archlinux ) and will post the outputs or fire a new bug report. Thought its the same problem since its conexant 20585.

Flyboy (lukas-loser) wrote :
David Henningsson (diwic) wrote :

@Flyboy, ok, given your alsa-info, it seems like your issue is the same as Schmidt's: you both have internal mics at 0x1a and external ones at 0x1b.

Flyboy (lukas-loser) wrote :

@David. Thanks, I'd like to point out the bug discussed in https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.32/+bug/590756 . Its the same problem, internal mic on 0x1a on conexant 20585. According to kayno, he got it working using either hda-analyzer or compiling the latest alsa driver from source. It didnt work for me , still might be worth you checking that out.

Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Triaged → In Progress
David Henningsson (diwic) wrote :

Ok, I have now made a dkms package to test, I want both Schmidt and kanyo to test it. Please do the following:
1) Make sure you have no alsa driver overrides installed (no linux-alsa-driver-modules, no home-compiled alsa upgrade etc)
2) Download and install http://people.canonical.com/~diwic/temp/alsa-hda-diwic-conexant-asus-dkms_1.0.23.diwic_all.deb
3) Reboot, test and report back.
Thanks!

Changed in alsa-driver (Ubuntu):
status: In Progress → Incomplete
David Henningsson (diwic) wrote :

Sorry, I meant Flyboy, not kanyo.

Schmidt (h3ll) wrote :

Hi,

the patch seems to work fine. The internal mic is working. It also switches to the jack when i plug in an external mic. Some with the speakers.

It just have another idea. Could the driver store the mic gain of internal and external mic seperatly and automatically change it when i plug in/unplug the external one?

Thank u very much!
Regards Jan

Flyboy (lukas-loser) wrote :

Hello, I have installed the patch on ubuntu 10.10 installed from scratch , and proud to say it works just fine thought the gain of the internal mic could be a bit better..
@David are you going to provide some patch for alsa-driver 1.0.23 to be compiled from source or are you going to incluede this patch into some daily snapshot so i could use it on archlinux as well ? Many thanks and great work

David Henningsson (diwic) wrote :

Thanks for testing, both of you!

@Schmidt, yes, that would probably be a good idea but is a little more complicated and more than I can currently spend time on unfortunately.

@FlyBoy, I have now sent the patch upstream, see
http://mailman.alsa-project.org/pipermail/alsa-devel/2011-January/035954.html
My hope is that it will be accepted as part of the 2.6.38 kernel.

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → In Progress
Flyboy (lukas-loser) wrote :

@David: once again and many thanks for a great work. Would be great if they incluede it in a new kernel, meantime, would you mind providing a diff to standart alsa-driver-1.0.23 or some git so i could use it as a patch ?

David Henningsson (diwic) wrote :

@Flyboy, these two patches:
http://mailman.alsa-project.org/pipermail/alsa-devel/2011-January/035952.html
http://mailman.alsa-project.org/pipermail/alsa-devel/2011-January/035954.html
should apply (and hopefully, will soon be applied) to this git tree:
http://git.kernel.org/?p=linux/kernel/git/tiwai/sound-2.6.git;a=summary

I don't think they are easily backported to anything else.

Nitisara (nitisara) wrote :

David Henningsson, thank you very much for your solution!
It helped me on Lenovo G560 with Ubuntu 10.10 with the same probles as discussed.

David Henningsson (diwic) wrote :

Released in Natty.

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Andy Whitcroft (apw) wrote :

This bug was fixed in the package linux - 2.6.38-3.30

---------------
linux (2.6.38-3.30) natty; urgency=low

  [ Andy Whitcroft ]

  * rebase to v2.6.38-rc4
  * ppc64 -- add basic architecture
  * ubuntu: AUFS -- update to 65835da20b77c98fb538c9114fc31f5de1328230

  [ Colin Ian King ]

  * SAUCE: Add WMI hotkeys support for Dell All-In-One series
    - LP: #676997
  * SAUCE: Add WMI hotkeys support for another Dell All-In-One series
    - LP: #701530
  * SAUCE: Dell WMI: Use sparse keymaps and tidy up code.
    - LP: #701530

  [ Dan Rosenberg ]

  * SAUCE: (drop after 2.6.38) Convert net %p usage %pK

  [ Kees Cook ]

  * Revert "SAUCE: kernel: make /proc/kallsyms mode 400 to reduce ease of
    attacking"
  * SAUCE: (drop after 2.6.38) use %pK for /proc/kallsyms and /proc/modules

  [ Tim Gardner ]

  * [Config] CONFIG_BLK_CGROUP=y
    - LP: #706394
  * [Config] CONFIG_DELL_WMI_AIO=m

  [ Upstream Kernel Changes ]

  * drm/i915/lvds: Restore dithering on native modes for gen2/3
    - LP: #711568

  [ Upstream Kernel Changes ]

  * rebase from v2.6.38-rc3 to v2.6.38-rc4.
 -- Andy Whitcroft <email address hidden> Tue, 08 Feb 2011 02:07:18 +0000

Alex Howarth (alex-howarth) wrote :

This patch fixes the problem switching between built in and jack speaker/mic on my Lenovo G560.

What it doesn't solve is the internal microphone's inability to pick anything up.

I have the 'crack of the day' alsa installed by following this:

https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules

alex@foo:~$ uname -a
Linux foo 2.6.35-28-generic #49-Ubuntu SMP Tue Mar 1 14:39:03 UTC 2011 x86_64 GNU/Linux

alex@foo:~$ grep asus /var/log/messages
Apr 5 21:06:15 foo kernel: [ 16.867976] ALSA hda_codec.c:3727: hda_codec: model 'asus' is selected for config 17aa:38af (Lenovo G560)

In order for the internal microphone to be *any* use at all I need to run hda analyzer and bump up the gain?.

The diff from hda analyzer is:

Diff for codec 0/1 (0x14f15069):
---
+++
@@ -87,17 +87,17 @@
     rates [0x160]: 44100 48000 96000
     bits [0xe]: 16 20 24
     formats [0x1]: PCM
   Power: setting=D0, actual=D0
   Connection: 4
      0x17* 0x18 0x23 0x24
 Node 0x17 [Audio Selector] wcaps 0x30050d: Stereo Amp-Out
   Amp-Out caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
- Amp-Out vals: [0x00 0x00]
+ Amp-Out vals: [0x04 0x04]
   Power: setting=D0, actual=D0
   Connection: 4
      0x1a* 0x1b 0x1d 0x1e
 Node 0x18 [Audio Selector] wcaps 0x30050d: Stereo Amp-Out
   Amp-Out caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
   Amp-Out vals: [0x00 0x00]
   Power: setting=D0, actual=D0
   Connection:

Without this the internal microphone is completely useless - it looks from this thread like I'm not alone with this problem either. Any chance it could be patched?

David Henningsson (diwic) wrote :

@Alex, the alsamixer control "Analog Mic Boost" should change the value of node 0x17 - is that not working properly?

Alex Howarth (alex-howarth) wrote :

Thanks. I didn't realise alsamixer gave me more control than the Gnome 'Sound Preferences' over this.

Adjusting 'Analog Mic Boost' to +40db fixes this and the setting is saved.

Every user of the Lenovo G560 will need to do this (by googling and eventually finding this page) if they want to use the internal microphone (it picks up nothing without a boost) - does this not warrant a patch?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers