Ubuntu

Request to enable vmwgfx driver in kernel config

Reported by Ajeet Singh Raina on 2011-01-06
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Do
Undecided
Unassigned
linux (Ubuntu)
Wishlist
Andy Whitcroft

Bug Description

Hello,

VMware would like to have own "vmwgfx" DRM kernel driver enabled by default in distribution kernels to improve customer experience.

In Ubuntu 11.04 Alpha 1, we noticed that the Ubuntu kernel disables the vmwgfx driver.Currently, the vmwgfx driver is stable and is shipped since kernel 2.6.37-rc4.Please change the kernel configuration from Ubuntu 11.04 Alpha 2 onwards so that "vmwgfx DRM kernel driver is compiled as a module (CONFIG_DRM_VMWGFX=m). The driver has to be compiled as a module to allow our installer detect that the driver is being supplied by the distribution.

Thanks,
VMware QA Team

Chris Halse Rogers (raof) wrote :

This was disabled in Ubuntu 10.10 as per the request in bug 606139.

I've moved this bug to the linux package in Ubuntu where people who can do something about this can see it :).

Given that we're now past feature freeze, I'd be surprised if this were enabled at this point, however.

Changed in do:
status: New → Invalid
Jeremy Foshee (jeremyfoshee) wrote :

Hi Ajeet,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 698009

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Ajeet Singh Raina (ajeetsingh) wrote :

Jeremy,

Few minutes before, I installed the Ubuntu build from http://cdimage.ubuntu.com/daily/current/natty-alternate-i386.iso. I don't see vmwgfx drivers been loaded. so the issue still persists.

I tried running apport-collect command but it threw the following error:

ERROR: connecting to Launchpad failed: "NoneType' object has noa ttribute 'makefile'
you can reset the credentials by removing the file "/root/.cache/apport/launchpad.credentials"

Can you please suggest?

Ajeet Singh Raina (ajeetsingh) wrote :

Regarding the upstream kernel from kernel.org, vmwgfx is present since 2.6.37-rc1.
I tested the latest 2.6.38 Final Release kernel and it does load vmwgfx without any issue.

All we need to enable it in your kernel too.

Michel Dänzer (daenzer-vmware) wrote :

Speaking as a VMware developer who worked on the vmwgfx drivers before, I'm not sure it makes sense to do this while the kernel driver is guarded by CONFIG_STAGING and the userspace drivers aren't enabled by default by VMware Tools.

At the very least, this should probably require a more specific rationale for why the drivers[0] should be enabled, and some feedback from people who actually use Ubuntu in VMs as to whether the new drivers are a net win.

[0] Note that just enabling the kernel vmwgfx driver will at most affect console, the vmwgfx drivers from the Gallium tree are also needed otherwise.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Changed in linux (Ubuntu):
status: Expired → Confirmed

Given ubuntu wants to ship with Unity 3D by default, having a 3D capable driver would be really nice.

Changed in linux (Ubuntu):
importance: Undecided → Wishlist
Andy Whitcroft (apw) wrote :

The X team think that having this built is appropriate. Will enable.

Changed in linux (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andy Whitcroft (apw)
milestone: none → ubuntu-11.10-beta-2
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.0.0-9.13

---------------
linux (3.0.0-9.13) oneiric; urgency=low

  [ Andy Whitcroft ]

  * [Config] enable CONFIG_DRM_VMWGFX=m
    - LP: #698009

  [ Kamal Mostafa ]

  * SAUCE: i915: do not setup intel_backlight twice
    - LP: #831542
 -- Leann Ogasawara <email address hidden> Mon, 22 Aug 2011 06:22:25 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints