Ubuntu

Wireless not recovering after sleep / hibernate: Error in ath9k driver

Reported by Magnus McElroy on 2010-12-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

****Fixed in 2.6.37-rc2****

Wireless networking is not recovering after sleep or hibernate. The system is using U:NR 10.10 although it did exist in 10.04 as well.

The issue seems to be with the ath9k default wireless driver setting random values after sleep / hibernate. When the module is rmmod / modprobe, then wireless can resume. Presumably, this action reseeds the wireless connection with default blanks, allowing for reconnection with the wireless access point.

This will affect all systems where the hardware is not setting the values to zero on a reset.

A patch for this problem may exist:
http://w1.fi/p/ath9k-keycache-reset-on-resume.patch

The log for the problem is here:
http://www.fpaste.org/0cKc/

Thank you; this bug requires CLI or a reboot to correct and is therefore reasonably important for novice users.

Magnus McElroy (magnus-shaw) wrote :

Apologizes; linked log is for wpa_supplicant.

Fabio Marconi (fabiomarconi) wrote :

Hello can you please install the latest mainline kernel:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.37-rc2-maverick/
Thanks
Fabio

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
Magnus McElroy (magnus-shaw) wrote :

Fabio, I don't know how to do that. Is there a guide?

Magnus McElroy (magnus-shaw) wrote :

Ugh, that was easier than I thought. All I had to do was download the linked file and have the package manager install it.

It does work on my machine, and it works instantly. Thank you very much.

description: updated
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers