Ubuntu

microphone not working on installed Ubuntu

Reported by Ralph Wabel on 2010-12-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Sound and webcam works perfectly. I cannot use the microphones of my Laptop, however the line-in is working. This means when I play music on my laptop and use line-in, I can record it. Using the microphone, sound-recorder does even not start recording.

Everything is unmuted. It works fine with the Ubuntu Live CD. As soon as I install Ubuntu I encounter this issue.

In order to fix the issue I had to add the below line into /etc/modprobe.d/alsa-base.conf

options snd-hda-intel position_fix=1

Mic volume works correctly under sound recorder now

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
Uname: Linux 2.6.36-999-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rwabel 1692 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xf2300000 irq 16'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,1025026f,00100004'
   Controls : 17
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xf2210000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sat Dec 4 13:31:38 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100725)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
dmi.bios.date: 10/20/2009
dmi.bios.vendor: Acer
dmi.bios.version: V1.15
dmi.board.name: Aspire 5538
dmi.board.vendor: Acer
dmi.board.version: V1.15
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.15
dmi.modalias: dmi:bvnAcer:bvrV1.15:bd10/20/2009:svnAcer:pnAspire5538:pvrV1.15:rvnAcer:rnAspire5538:rvrV1.15:cvnAcer:ct10:cvrV1.15:
dmi.product.name: Aspire 5538
dmi.product.version: V1.15
dmi.sys.vendor: Acer

Ralph Wabel (rwabel) wrote :
Daniel T Chen (crimsun) wrote :

Do you still need this quirk (position_fix) if you use the latest daily build of the sound drivers? https://wiki.ubuntu.com/Audio

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Ralph Wabel (rwabel) wrote :

Installed the latest daily build and get still the same issue when not adding the above hack

Daniel T Chen (crimsun) wrote :

Enable internal mic capture on Acer Aspire 5538

Changed in alsa-driver (Ubuntu):
status: Incomplete → In Progress
importance: Undecided → Low
tags: added: patch-forwarded-upstream
Daniel T Chen (crimsun) on 2010-12-06
Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
tags: added: patch-accepted-upstream
removed: patch-forwarded-upstream
Ralph Wabel (rwabel) wrote :

@Daniel I've upgraded to latest alsa drivers and it's now workiing. Thanks a lot!

Andy Whitcroft (apw) on 2011-02-10
Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu Maverick):
status: New → Fix Committed
Brad Figg (brad-figg) on 2011-02-15
tags: added: verification-needed-maverick
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Brad Figg (brad-figg) wrote :

This patch was applied from a stable, upstream release. Therefor it does not require verification.

tags: added: verification-done-maverick
removed: verification-needed-maverick
Launchpad Janitor (janitor) wrote :
Download full text (12.1 KiB)

This bug was fixed in the package linux - 2.6.35-27.48

---------------
linux (2.6.35-27.48) maverick-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #723335

  [ Upstream Kernel Changes ]

  * thinkpad-acpi: avoid keymap pitfall
    - LP: #722747

linux (2.6.35-27.47) maverick-proposed; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #716532

  [ Upstream Kernel Changes ]

  * Revert "USB: gadget: Allow function access to device ID data during
    bind()"
    - LP: #714732
  * net: fix rds_iovec page count overflow, CVE-2010-3865
    - LP: #709153
    - CVE-2010-3865
  * Input: fix typo in keycode validation supporting large scancodes
    - LP: #658198
  * net: ax25: fix information leak to userland, CVE-2010-3875
    - LP: #710714
    - CVE-2010-3875
  * net: ax25: fix information leak to userland harder, CVE-2010-3875
    - LP: #710714
    - CVE-2010-3875
  * net: packet: fix information leak to userland, CVE-2010-3876
    - LP: #710714
    - CVE-2010-3876
  * net: tipc: fix information leak to userland, CVE-2010-3877
    - LP: #711291
    - CVE-2010-3877
  * posix-cpu-timers: workaround to suppress the problems with mt exec,
    CVE-2010-4248
    - LP: #712609
    - CVE-2010-4248
  * sys_semctl: fix kernel stack leakage, CVE-2010-4083
    - LP: #712749
    - CVE-2010-4083
  * thinkpad-acpi: lock down size of hotkey keymap
    - LP: #712174
  * thinkpad-acpi: add support for model-specific keymaps
    - LP: #712174
  * thinkpad-acpi: Add KEY_CAMERA (Fn-F6) for Lenovo keyboards
    - LP: #712174
  * x86, hotplug: Use mwait to offline a processor, fix the legacy case
    - LP: #714732
  * fuse: verify ioctl retries
    - LP: #714732
  * fuse: fix ioctl when server is 32bit
    - LP: #714732
  * ALSA: hda: Use position_fix=1 for Acer Aspire 5538 to enable capture on
    internal mic
    - LP: #685161, #714732
  * ALSA: hda: Use model=lg quirk for LG P1 Express to enable playback and
    capture
    - LP: #595482, #714732
  * drm/radeon/kms: don't apply 7xx HDP flush workaround on AGP
    - LP: #714732
  * drm/kms: remove spaces from connector names (v2)
    - LP: #714732
  * drm/radeon/kms: fix vram base calculation on rs780/rs880
    - LP: #714732
  * nohz: Fix printk_needs_cpu() return value on offline cpus
    - LP: #714732
  * nohz: Fix get_next_timer_interrupt() vs cpu hotplug
    - LP: #714732
  * nfsd: Fix possible BUG_ON firing in set_change_info
    - LP: #714732
  * NFS: Fix fcntl F_GETLK not reporting some conflicts
    - LP: #714732
  * sunrpc: prevent use-after-free on clearing XPT_BUSY
    - LP: #714732
  * hwmon: (adm1026) Allow 1 as a valid divider value
    - LP: #714732
  * hwmon: (adm1026) Fix setting fan_div
    - LP: #714732
  * EDAC: Fix workqueue-related crashes
    - LP: #714732
  * amd64_edac: Fix interleaving check
    - LP: #714732
  * ASoC: Fix swap of left and right channels for WM8993/4 speaker boost
    gain
    - LP: #714732
  * ASoC: Fix off by one error in WM8994 EQ register bank size
    - LP: #714732
  * ASoC: WM8580: Fix R8 initial value
    - LP: #714732
  * ASoC: fix deemphasis control in wm8904/55/60 codecs
    - LP: #714732
  * bootmem: Add alloc_bootmem_...

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Ralph Wabel (rwabel) wrote :

The bug appears again. I cannot tell since which version. I now need again to add that line above to fix it

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers