X does not work in Xen, causes crash

Bug #68440 reported by Ian Jackson on 2006-10-26
50
This bug affects 1 person
Affects Status Importance Assigned to Milestone
X.Org X server
Incomplete
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

I'm running edgy:
 xen-hypervisor-3.0-i386 3.0.3-0ubuntu1
 xen-image-xen0-2.6.17-6-generic-xen0 2.6.17-6
 xserver-xorg 1:7.1.1ubuntu6
If I boot the native kernel everything works fine.

If I boot xen, the X server thinks it has started up but in fact my screen (an lcd) is black. If I log in over the network chvt 2 sort of works but takes a very long time and leaves the display in a strange state: the letters are twice as high as they should be, so I can see only the top half of the text on the screen.

dpkg-reconfigure xserver-xorg appears to work fine, but if I haven't done chvt 2 first then it crashes the whole machine hard when I say yes to monitor autodetection. Likewise, most attempts to shut X down, and many other things one might do, crash the machine hard.

There is nothing in the kernel log about these crashes. I have tried using the vesa driver instead, and telling X to use the kernel framebuffer driver, and using an older kernel (xen-image-xen0-2.6.16-11.1-generic 2.6.16-11.1) and those didn't help; the behaviour was identical.

The Xorg.0.log show significant differences between the xen and not-xen cases. I will attach both. I will also subscribe Chuck Short, the Xen maintainer, to this bug.

Tags: xen Edit Tag help
Ian Jackson (ijackson) wrote :
Ian Jackson (ijackson) wrote :

I still have this problem with feisty's X server packages.
(I'm still using edgy's hypervisor and dom0 kernel because feisty doesn't have these yet).

Timo Aaltonen (tjaalton) wrote :

the only difference I could tell from the logs was that Mode 15c was "blank" running natively.

Bryce Harrington (bryce) wrote :

Can you please report if this still occurs with Gutsy?

Bryce Harrington writes ("[Bug 68440] Re: X does not work in Xen, causes crash"):
> Can you please report if this still occurs with Gutsy?

Is there a 2.6.19+ Xen kernel for gutsy yet ? Since I filed that
report I had to repurpose the motherboard I was using for my Xen setup
and the new one has a Marvell IDE controller. I was able to get it
working with etch a few weeks ago.

Ian.

Hello :-),

unfortunately I can confirm this problem on Gusty. Without starting the xserver everything is working fine. If i start X the system 'crashes'. I get a black screen, i can not change to console and even Numlock or Caps isn't working.

If you need more inforation feel free to ask. I will answer as soon as possible.

Bye

Timo Aaltonen (tjaalton) on 2008-01-12
Changed in xorg:
importance: Undecided → Medium
status: New → Confirmed
Aaron B. Russell (aaronr) wrote :

I can also confirm this problem on Gutsy, running linux-image-2.6.22-14-xen. If you need me to get any information from my system, reply here and I'll get it for you.

Wilco Baan Hofman (wilco) wrote :

Confirming problem with Intel driver on X.org running on linux-image-2.6.24-12-xen on Hardy.

Wilco Baan Hofman (wilco) wrote :

Works for me if I explicitly tell Xorg to use the vesa driver.

I'm on an HP Business notebook NC6400, with intel 945 + ICH7 integrated chipset and a Core 2 Duo T5600 CPU.

Using the vesa driver is of course not a real option, but I imagine there's some incompatibility between the intel Xorg driver and the Xen kernels.

Julio M. Merino Vidal (jmmv) wrote :

Same problem here using the Intel driver (default Xorg settings) with Hardy Heron beta on a Dell OptiPlex 745 machine. I am attaching a copy of the dmesg for the working machine (i.e. booting without Xen) and the Xorg log.

Please note that I was able to get Xen to work with Fedora 8 on this same machine also using the intel driver. But probably its intel driver was older than the one shipped in Hardy.

Julio M. Merino Vidal (jmmv) wrote :

And now the Xorg log... what a pity one cannot attach multiple files on the same comment.

STaRMaN (jarizaro) wrote :

Some here... with intel GMA X3100 (chipset GM965 in board)
All system start ok, until kdm start, if this moment the screen go black, and the system stop responding.

Jisakiel (jisakiel) wrote :

Same problem as the former comment (GMA X3100 on an XPS-m1330 on Hardy), although using GDM.

I'd suggest it's quite important, as Xen is effectively unusable for a normal user.

Bryce Harrington (bryce) wrote :

I notice that everyone confirming this bug has Intel hardware, so I'm re-filing to xserver-xorg-video-intel, although it should be noted that Ian was seeing the issue with the -vesa driver, so this *might* be more than a driver bug. However, I think giving visibility of this to the Intel folks may help in investigating it.

Bryce Harrington (bryce) wrote :

Can someone confirm this as still happening with latest Hardy?

Also, for reproducing this issue is it sufficient to simply install and start up Xen, or are there any additional steps required to trigger it?

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Aaron B. Russell (aaronr) wrote :

For reference, this happened to me on two different machines with nVidia GeForce 4 MXs too.

Julio M. Merino Vidal (jmmv) wrote :

Yes, this still happens with today's Hardy.

I'd like to remind you once again that Xen worked fine on this same hardware with Fedora 8 (with X.org too, of course). Maybe comparing the drivers in them can shed some light.

Cezar (emperorcezar) wrote :

I can confirm this behavior in Hardy. I'm not sure if the machine crashes hard after the lcd goes blank because I can't get any response at all.

gribiii (ubuntu-gribii) wrote :

I've got the same problem in Hardy ... If i use the vesa-driver, all things works fine but I can't work with a resolution of 800x600

CjNr11 (cjnr11) wrote :

Same problem here using xen 3.2 and linux-image-xen (I've tested 2.6.24-16 to 2.6.24-18). I've tried to build a more recent version of xserver-xorg-video-intel (the 2.3.1) and now I'm able to get a working Xserver. But the problem is still there because as soon as I start X, the kernel becomes unstable (random oops related to udev, syslog, X, ....). And there is always an oops (not always related to the same process) when I try to kill X.

CjNr11 (cjnr11) wrote :
CjNr11 (cjnr11) wrote :
Antonio Batovanja (toni-toni) wrote :

Same thing here with xen 3.2 and 2.6.24-18-xen on x86_64 with Intel driver.
The screen goes blank, but I can connect via ssh.
The ps command shows kdm as the last process and hangs.
strace shows:
open("/proc/5478/status", O_RDONLY) = 6
read(6, "Name:\tXorg\nState:\tD (disk sleep)"..., 1023) = 601
close(6) = 0
open("/proc/5478/cmdline", O_RDONLY) = 6
read(6,

The REALLY interesting line from syslog is:
Jun 6 12:04:24 (none) kernel: [ 19.652184] kernel BUG at include2/asm/mach-xen/asm/maddr_64.h:28!
(see attachment)

With vesa-driver everything works fine.

Antonio Batovanja (toni-toni) wrote :

Xorg.0.log attached

Pieter (diepes) wrote :

Also seeing the problem.
Intel Graphics.

My Caps and Num lock still working.
Can reboot with Ctrl + PrintScreen S -> U -> B

Standard install, just installed xen and rebooted again to trigger.

sds (svetlin-objectist) wrote :

All of the above is true, many times observed and confirmed for a long, long, long time.
What more is needed?

Why is the status of this bug still "Incomplete"?
When will be there an ETA of assigning it and starting work on it?

I am surprised to see relatively minor annoyances filed with "High" importance whereas this show-stopper does not get any attention.
Makes me wonder whether Ubuntu considers Xen a priority at all.

Aaron B. Russell (aaronr) wrote :

Agreed. This bug is 18 months old. It's probably still marked incomplete because it's been filed under the xserver-xorg-video-intel package, despite not an Intel specific issue -- it happens on old nVidia cards too, as I've previously commented.

TTL (supernova-2149) wrote :

Same Problem here. Everything works until kdm tries to start. My graphic hardware is an intel GMA 945 (Mobile 945GM/GMS, 943/940GML) too. I tried the linux-image-2.6.24-19-xen. The screen goes blank. And nothing happened until I press Strg+Alt+Entf, then two of the keyboard leds starts blinking periodically.

unggnu (unggnu) on 2008-06-22
Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
Andre Blum (andre-blum-home) wrote :

Seeing the same on an intel D945GCLF motherboard (atom CPU) with 945 chipset.

The issue looks very similar to the issues that I've had with nvidia graphics adapters when using xen over the last year or more. The problem there, as is clearly communicated by nvidia, is that Xen has no support for AGP / GART. Nvidia has patched drivers that work.

Comparing Xorg log files between xen (not-working) and non-xen (working) boots, I can see that the last line in the non-functional scenario is indeed:

(II) intel(0): xf86BindGARTMemory: bind key 0 at 0x01000000 (pgoffset 4096)

in the working scenario (non-xen), this line is followed by many more lines.

El Diablo (el-diablo) wrote :

Ok, I'm no Xen guy... however after experiencing a load of lock up's when booting the 8.04 Xen kernel (64bit) , destroying my fs by powering down by holding the button... I found this lame fix:

Now I can't speculate as to what is wrong, and I'm not going to... however try this (It also worked for ilowe in #ubuntu):

edit your /etc/X11/xorg.conf and force xorg to use Vesa driver.... reboot, at grub select your xen kernel... all being well, GDM should start

Section "Device"
        Identifier "Configured Video Device"
        Driver "vesa"
EndSection

Hope it helps (until somebody fixes the damn linux-xen kernels)...

FYI: If you have an nvidia card, change the line to

Driver "nv"

;-) nuff said

Iain Lowe (ilowe) wrote :

As El Diablo mentions, the hack above works to get X up and running. Unfortunately, you remain stuck in a 800x600 resolution. I found that using the intel driver works just as well (or just as badly) as the vesa driver. I'm running latest versions of everything:

libc6-xen-2.7-10ubuntu3
libxen3-3.2.0-0ubuntu10
linux-image-2.6.24-18-xen-2.6.24-18.32
linux-image-2.6.24-19-xen-2.6.24-19.34
linux-image-xen-2.6.24.19.21
linux-restricted-modules-xen-2.6.24.19.21
linux-ubuntu-modules-2.6.24-18-xen-2.6.24-18.26
linux-ubuntu-modules-2.6.24-19-xen-2.6.24-19.28
linux-xen-2.6.24.19.21
python-xen-3.2.0-0ubuntu10
ubuntu-xen-desktop-0.0.1-2ubuntu8
xen-docs-3.2.0-0ubuntu10
xen-hypervisor-3.2.0-0ubuntu10
xen-tools-3.8-4ubuntu4
xen-utils-3.2.0-0ubuntu10
xenman-0.6-5ubuntu1

As above, I'm using a GM965/GL960 integrated Intel card in a Vaio CR420D

Iain Lowe (ilowe) wrote :

Actually, I made a mistake: if I reboot using drivers other than vesa my machine hangs quietly when gdm starts up. With the vesa driver, everything but the resolution works.

Bryce Harrington (bryce) wrote :

Ah, since we're seeing kernel oopses, it must be a kernel bug. Refiling.

Changed in xorg:
status: Confirmed → New
Changed in xorg-server:
status: New → Incomplete
Antonio Batovanja (toni-toni) wrote :

Looks like no-one is interested in fixing this bug (reported on 2006-10-26!!!).
I'm getting additional servers soon, the only serious choice I can make is to install another distribution.

Dyno (dyno-fu) wrote :

just to confirm El Diablo's solution workaround the problem -- and without the resolution wart.

my laptop is Thinkpad X61s with intel GM965 video card.
#uname -a
Linux koala 2.6.24-19-xen #1 SMP Sat Jul 12 03:55:08 UTC 2008 i686 GNU/Linux

same here...
x3100+xen+X->hang
the interesting thing is that the vba16fb driver seems to crash the maschine, too, if enabled.
Isn't the xen-kernel pae-enabled? Perhaps there is a bug in the ram-allocation code for the gpu in the kernel and/or in the x-driver?

btw, same in intrepid

km (km-mathcs) wrote :

I'm running with an Intel 915GM on a Pentium M 2ghz laptop, running Ubuntu 8.04 2.6.24-21-xen .
The workaround of using Vesa works. I get a 1600x1200 display on my vga monitor.

If I use the Intel driver I get a black screen as other do. What is strange is that I can't get in with ssh. ssh from another machine connects, but hangs after that. This doesn't happend with Vesa.

Although Vesa seems to work ok, I make use of the XVIDEO extension which doesn't work with Vesa.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

the problem is that there is noo 2.6.27-xen kernel (which can work as a dom0).

I think I'm seeing this issue too on a fairly default hardy system. Thinkpad X60s laptop, intel video.

AJ Lewis (vortechs2000) wrote :

I'm seeing the blank screen on an freshly upgraded 8.10 64-bit AMD system with a Intel 82Q35 Express Integrated Graphics Controller. My xorg.conf is setup to use the vesa controller: I can ssh in, but the keyboard and mouse don't do anything and the screen stays blank, even if I chvt. In summary:

Ubuntu 8.10
64-bit AMD system
Linux 2.6.24-21-xen kernel (both Xen 3.2 and 3.3)
vesa Xorg driver
Intel 82Q35 Express Integrated Graphics Controller

Daniel T Chen (crimsun) on 2008-12-20
Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: New → Confirmed

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

tags: added: xen
removed: cft-2.6.27
Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers