0x1028043a needs "alienware" model quirk

Bug #683695 reported by Cody Thierauf on 2010-12-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Daniel T Chen

Bug Description

(copied from my forum post)
i'm using an alienware m17x and cannot for the life of me get the headphone jacks to work, although i get sound through my laptop speakers.
also, i'm running ubuntu 10.10

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic x86_64
NonfreeKernelModules: fglrx wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: cody 1863 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0e20000 irq 52'
   Mixer name : 'IDT 92HD73C1X5'
   Components : 'HDA:111d7675,1028043a,00100103'
   Controls : 18
   Simple ctrls : 12
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xbfeec000 irq 53'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed Dec 1 10:19:16 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SelectedCard: 0 Intel HDA-Intel - HDA Intel
SourcePackage: alsa-driver
Symptom: audio
Title: [IDT 92HD73C1X5] ALSA test tone not correctly played back
dmi.bios.date: 09/17/2010
dmi.bios.vendor: Alienware
dmi.bios.version: A09
dmi.board.vendor: Alienware
dmi.board.version: A09
dmi.chassis.type: 8
dmi.chassis.vendor: Alienware
dmi.chassis.version: A09
dmi.modalias: dmi:bvnAlienware:bvrA09:bd09/17/2010:svnAlienware:pnM17x:pvrA09:rvnAlienware:rn:rvrA09:cvnAlienware:ct8:cvrA09:
dmi.product.name: M17x
dmi.product.version: A09
dmi.sys.vendor: Alienware

Cody Thierauf (sk8rjess) wrote :
Daniel T Chen (crimsun) wrote :
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Cody Thierauf (sk8rjess) wrote :

i just updated everything and rebooted, still not working

Cody Thierauf (sk8rjess) wrote :

Thanks, Daniel. here's the file
http://ubuntuone.com/p/RgQ/

Daniel T Chen (crimsun) wrote :

Please append the following line to /etc/modprobe.d/alsa-base.conf and reboot:

options snd-hda-intel model=alienware

Daniel T Chen (crimsun) on 2010-12-01
summary: - No sound coming from sound jack, but laptop speakers work fine
+ 0x1028043a needs "alienware" model quirk
Changed in alsa-driver (Ubuntu):
status: Incomplete → Triaged
Cody Thierauf (sk8rjess) wrote :

That fixed it, thanks Daniel! I'll post this solution in the forum as well.

Daniel T Chen (crimsun) on 2010-12-01
Changed in alsa-driver (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Low
status: Triaged → In Progress
Daniel T Chen (crimsun) wrote :

Add SSID to quirk table to support another Alienware M17x

tags: added: patch-forwarded-upstream
Daniel T Chen (crimsun) on 2010-12-02
Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
tags: added: patch-accepted-upstream
removed: patch-forwarded-upstream

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Brad Figg (brad-figg) wrote :

This patch was applied to Maverick as part of an upstream stable update, therefore it doesn't require individual verification.

tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) on 2011-02-04
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Andy Whitcroft (apw) on 2011-02-10
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers