Blank screen after resuming from hibernation on a Dell Latitude E6410

Bug #681877 reported by Ara Pulido on 2010-11-26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Andy Whitcroft
Andy Whitcroft

Bug Description

In a Dell Latitude E6410, with nVidia Corporation GT218 [NVS 3100M].

After suspend, the system resumes correctly. After hibernation, though, it only shows a blank screen. Although quite similar to bug 578673, I have opened a new one, as it is not the same video HW.

Using the kernel

 * Someone with access to the hardware to test hibernate/resume on Natty.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-22-generic 2.6.35-22.33
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic
Uname: Linux 2.6.35-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 /dev/snd/controlC0: ubuntu 1635 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
 Card hw:0 'Intel'/'HDA Intel at 0xd9660000 irq 48'
   Mixer name : 'IDT 92HD81B1C5'
   Components : 'HDA:111d76d5,1028040a,00100104 HDA:14f12c06,14f1000f,00100000'
   Controls : 14
   Simple ctrls : 9
 Card hw:1 'NVidia'/'HDA NVidia at 0xd3080000 irq 16'
   Mixer name : 'Nvidia GT21x HDMI'
   Components : 'HDA:10de000b,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Fri Nov 26 12:43:46 2010
HibernationDevice: RESUME=UUID=f3d1b3d5-6d36-41c3-a59a-0ee4c13bbc6a
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Dell Inc. Latitude E6410
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=b5103ded-6f60-498a-b676-1b3baf89b8b1 ro quiet splash initcall_debug
RelatedPackageVersions: linux-firmware 1.38
SourcePackage: linux 01/30/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X51 RAMDEL
dmi.board.vendor: Dell Inc.
dmi.board.version: 0001
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX51:bd01/30/2010:svnDellInc.:pnLatitudeE6410:pvr0001:rvnDellInc.:rnRAMDEL:rvr0001:cvnDellInc.:ct9:cvr: Latitude E6410
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.

Ara Pulido (ara) wrote :
tags: added: blocks-hwcert pcert
Marc Tardif (cr3) wrote :

Hibernating and resuming seems to work fine on a Latitude E6410 running Natty, tested with image 20101130. However, after resuming, the swap partition changed and the UUID no longer matches the one in /etc/fstab. So, the hibernate option is no longer available in the panel drop down menu. After recovering the swap partition, hibernation seems to work fine again but the same happens to the swap partition.

On a side note, suspend doesn't resume with the swap partition. However, after hibernation and the swap gets removed, then suspend resumes just fine. I tried this a couple times and the behavior is consistent: suspend with swap doesn't resume.

Ameet Paranjape (ameetp) on 2010-12-06
Changed in linux (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Changed in linux (Ubuntu Maverick):
status: New → Triaged
Ameet Paranjape (ameetp) on 2010-12-06
Changed in linux (Ubuntu Maverick):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
status: Triaged → Invalid
status: Invalid → Triaged
importance: Undecided → Critical
Changed in linux (Ubuntu Natty):
status: Triaged → Incomplete
importance: Critical → Undecided
Ameet Paranjape (ameetp) on 2010-12-06
Changed in linux (Ubuntu Natty):
status: Incomplete → Triaged
importance: Undecided → Critical
tags: added: kernel-series-unknown
Andy Whitcroft (apw) wrote :

@Marc -- the hibernate issue is known and fixes are in the works for that. Hibernate is not working at all in fact, we cannot resume it at all currently. This is likely a boot issue as a result. Could you try booting with set gfxpayload=text in the grub part of the grub command line for the booted kernel. Thanks!

shan (khoorasan) wrote :

Same problem on Dell Inspiron 9200, running on 1.8 ghz, 2 gb ram, 100 GB HDD. I wanted to open a new topic but this is very similar problem. I attached my acpi-support configuration (sudo gedit /etc/default/acpi-support).

Rick B. (rbeltz48) wrote :

Same problem on IBM Thinkpad R51 with 1.5 GHz 512 MB RAM running 10.04. Worked OK in 9.10.

MrTuTu (tutu-tutu) wrote :

Same problem in Dell Latitude E6510. Everything was ok with 10.04

MrTuTu (tutu-tutu) wrote :

Oups, not true. Sorry. I have a black screen after suspend, not hibernate.

I have the same issue in a Vostro 3500 Laptop with a nVidia Geforce 310M in Maverik.
And also the power management still triggers an hibernate message (and i think also a system hibernate routine) when it has the battery in critical state BUT it has the AC plugged in.

Andy Whitcroft (apw) wrote :

So we now have an official v2.6.38-rc2 kernel in the archive for Natty (2.6.38-1.28), if those of you affected by this could confirm whether the issue is resolved by that kernel that would be very helpful. Please report back here. Thanks!

Changed in linux (Ubuntu Natty):
status: Triaged → Incomplete
Andy Whitcroft (apw) wrote :

There is now a v2.6.34-rc4 kernel in the archive for Natty, please test.

Dave Neary (dneary) wrote :

Same issue on Natty on a Dell Latitude E6500. Blank post-resume after suspend. Affects both classic desktop & Unity. Tested with a kernel updated yesterday, version 2.6.38-3-generic-pae.

Daniel Manrique (roadmr) wrote :

Installed Natty using the 20110214 image, results are as follows:

kernel 2.6.38-3.30 - kernel doesn't even boot, right after grub loads kernel and initrd I get a blank screen, if I push the power button the system turns off instantly.

kernel 2.6.38-2.29 - Boots fine, suspends and hibernates without problems and resumes from both also without problems. Only issue I could find is that hibernate doesn't appear in the Ubuntu panel, I had to use the pm-hibernate command for that, but this appears to be OK for Natty.

kernel 2.6.38-rc4-natty[1] - boots fine, suspends and recovers fine, hibernates and restores fine.


Our E6410 is used primarily for Ubuntu testing so I'm available to test and report on any fixes or new code.

Ara Pulido (ara) on 2011-02-17
Changed in linux (Ubuntu Natty):
status: Incomplete → Triaged
Andy Whitcroft (apw) wrote :

We have had good reports with some patches from upstream, could you test the kernels prepared for that bug please. To repeat what I wrote on that bug:

In the upstream bug Jesse provides a 2.6.38 based backport of an upstream fix. I have pulled this into a Natty kernel. Could those of you affected by the black screen on boot try the kernels below and report back here. The kernels are at the URL below:

Please report back here. Thanks.

Changed in linux (Ubuntu Natty):
status: Triaged → Incomplete
Daniel Manrique (roadmr) wrote :


Tested the 2.6.38-4 kernel from here in our E6410:

This kernel seems to work mostly:

After grub loads kernel and initrd, I see a black screen, no ubuntu logo. Hard drive light shows activity. After about 30 seconds some garbling appears on screen. After that the system comes up to the Ubuntu desktop normally. Boot time from kernel selection in grub to a usable desktop is about 45 seconds (autologin enabled).

I tested suspend behavior, which seems OK, it goes into and comes out of suspension just fine.

Hibernation works fine as well, though it has to be invoked manually with the pm-hibernate command. The system still recovers successfully from hibernation.

Let me know if any more tests are needed.

Ara Pulido (ara) on 2011-02-18
Changed in linux (Ubuntu Natty):
status: Incomplete → Triaged
Andy Whitcroft (apw) wrote :

I am going to take that as positive testing of Hibernate/Resume, that the black screen on resume there is no longer present. I would like to see additional bugs for the boot symptoms please. If someone could take a video or something that might be instructive.

Thank you for testing.

Andy Whitcroft (apw) wrote :

Ok the commit tested here is now scheduled for application to 2.6.38, in the meantime I am pulling it into the Natty kerenel and it should be in the next upload. Fix Committed. Thanks all for your testing.

Changed in linux (Ubuntu Natty):
status: Triaged → Fix Committed
assignee: Canonical Kernel Team (canonical-kernel-team) → Andy Whitcroft (apw)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-5.32

linux (2.6.38-5.32) natty; urgency=low

  [ Andy Whitcroft ]

  * rebase to mainline 6f576d57f1fa0d6026b495d8746d56d949989161
  * [Config] updateconfigs following rebase to v2.6.38-rc6
  * [Config] enable CONFIG_DMAR
    - LP: #552311

  [ Upstream Kernel Changes ]

  * drm/i915: skip FDI & PCH enabling for DP_A
    - LP: #561802, #600453, #681877

  [ Major Kernel Changes ]

  * rebase from v2.6.38-rc5 to v2.6.38-rc6
    - LP: #718402
    - LP: #719524
    - LP: #721126
    - LP: #719691
    - LP: #722689
    - LP: #722310
 -- Andy Whitcroft <email address hidden> Tue, 22 Feb 2011 13:28:39 +0000

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released
Seth Forshee (sforshee) wrote :

I took a stab at backporting the fix to maverick. Unfortunately the changes required were pretty substantial, requiring backports of several other patches that added functionality needed by the final patch, and that makes me a little nervous about the possibility of introducing regressions. Debs are available at:

@Andy, if you get a few minutes to review the patches for regression potential it would be much appreciated. They're available alongside the debs or at

git:// lp681877

Changed in linux (Ubuntu Maverick):
assignee: Canonical Kernel Team (canonical-kernel-team) → Seth Forshee (sforshee)
status: Triaged → In Progress
Seth Forshee (sforshee) on 2011-04-14
Changed in linux (Ubuntu Maverick):
status: In Progress → Incomplete
Seth Forshee (sforshee) on 2011-09-16
Changed in linux (Ubuntu Maverick):
assignee: Seth Forshee (sforshee) → nobody
Ara Pulido (ara) wrote :

Don't think it is worth backporting this to Maverick, as it is reaching EOL

Changed in linux (Ubuntu Maverick):
status: Incomplete → Invalid
To post a comment you must log in.