page flipping causes lock ups with full screen apps (usually compositors, ie. compiz), fix in 2.6.36

Bug #680204 reported by steubens on 2010-11-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Maverick
Medium
Tim Gardner

Bug Description

commit responsible for fix in newer version:

commit 4e5359cd053bfb7d8dabe4a63624a5726848ffbc
Author: Simon Farnsworth <email address hidden>
Date: Wed Sep 1 17:47:52 2010 +0100

    drm/i915: Avoid pageflipping freeze when we miss the flip prepare interrupt

    When we miss the flip prepare interrupt, we never get into the
    software state needed to restart userspace, resulting in a freeze of a
    full-screen OpenGL application (such as a compositor).

    Work around this by checking DSPxSURF/DSPxBASE to see if the page flip
    has actually happened. If it has, do the work we would have done when
    the flip prepare interrupt comes in.

    Also, add debugfs information to tell us what's going on (based on the
    patch from Chris Wilson attached to bugs.fdo bug #29798).

    Signed-off-by: Simon Farnsworth <email address hidden>
    Signed-off-by: Chris Wilson <email address hidden>

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-23-generic 2.6.35-23.40
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ohsix 1939 F.... pulseaudio
 /dev/snd/pcmC0D0p: ohsix 1939 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd4700000 irq 45'
   Mixer name : 'Intel Cantiga HDMI'
   Components : 'HDA:14f15051,103c360b,00100000 HDA:80862802,80860101,00100000'
   Controls : 16
   Simple ctrls : 7
Date: Mon Nov 22 12:29:47 2010
HibernationDevice: RESUME=UUID=b361beaf-a63a-4b3f-a711-781118e35d62
MachineType: Hewlett-Packard Compaq Presario CQ60 Notebook PC
ProcCmdLine: root=UUID=457249de-6049-42fd-a0c6-9d5019baf7bd ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.38
SourcePackage: linux
WpaSupplicantLog:

dmi.bios.date: 03/08/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.63
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3612
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 09.67
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.63:bd03/08/2010:svnHewlett-Packard:pnCompaqPresarioCQ60NotebookPC:pvrPCID:rvnHewlett-Packard:rn3612:rvr09.67:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: Compaq Presario CQ60 Notebook PC
dmi.product.version: PCID
dmi.sys.vendor: Hewlett-Packard

steubens (steubens) wrote :
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Maverick):
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → Medium
milestone: none → maverick-updates
status: New → In Progress
Tim Gardner (timg-tpi) wrote :

SRU Justification

impact: See bug description

Patch: Upstream cherry-pick 4e5359cd053bfb7d8dabe4a63624a5726848ffbc

Patch Description: See bug description

steubens (steubens) wrote :

thanks a bunch!

Tim Gardner (timg-tpi) on 2010-11-30
Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Committed
Jeremy Foshee (jeremyfoshee) wrote :

Hi steubens,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
steubens (steubens) wrote :

i started with a mainline/upstream kernel first, then worked backwards

tags: removed: needs-upstream-testing

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

steubens (steubens) on 2010-12-08
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (9.0 KiB)

This bug was fixed in the package linux - 2.6.35-24.42

---------------
linux (2.6.35-24.42) maverick-proposed; urgency=low

  [ Brad Figg ]

  - LP: #683422

  [ Colin Ian King ]

  * SAUCE: Allow registration of handler to multiple WMI events with same
    GUID
    - LP: #676997
  * SAUCE: Add WMI hotkeys support for Dell All-In-One series
    - LP: #676997
  * [Config] Enable Dell All-In-One WMI Hotkeys driver
    - LP: #676997

  [ David Woodhouse ]

  * [Upstream] Call acpi_video_register() in intel_opregion_init() failure
    path
    - LP: #615947

  [ Manoj Iyer ]

  * SAUCE: enable rfkill for rtl8192se driver
    - LP: #640992
  * SAUCE: Enable jack sense for Thinkpad Edge 11
    - LP: #677210

  [ Tim Gardner ]

  * [Config] Use correct be2iscsi module name in d-i/modules/scsi-modules
    - LP: #628776
  * [Config] Added NFS and related modules to virtual flavour
    - LP: #659084
  * [Config] Add support for cross compiling armel
  * Simplify the use of CROSS_COMPILER

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) ACPI: enable repeated PCIEXP wakeup by clearing
    PCIEXP_WAKE_STS on resume"
  * Revert "(pre-stable) mm: Move vma_stack_continue into mm.h"
  * x86, cpu: After uncapping CPUID, re-run CPU feature detection
    - LP: #672664
  * ALSA: sound/pci/rme9652: prevent reading uninitialized stack memory
    - LP: #672664
  * ALSA: oxygen: fix analog capture on Claro halo cards
    - LP: #672664
  * ALSA: hda - Add Dell Latitude E6400 model quirk
    - LP: #643891, #672664
  * ALSA: prevent heap corruption in snd_ctl_new()
    - LP: #672664
  * ALSA: rawmidi: fix oops (use after free) when unloading a driver module
    - LP: #672664
  * hwmon: (lis3) Fix Oops with NULL platform data
    - LP: #672664
  * USB: fix bug in initialization of interface minor numbers
    - LP: #672664
  * usb: musb: gadget: fix kernel panic if using out ep with FIFO_TXRX
    style
    - LP: #672664
  * usb: musb: gadget: restart request on clearing endpoint halt
    - LP: #672664
  * HID: hidraw, fix a NULL pointer dereference in hidraw_ioctl
    - LP: #672664
  * HID: hidraw, fix a NULL pointer dereference in hidraw_write
    - LP: #672664
  * ahci: fix module refcount breakage introduced by libahci split
    - LP: #672664
  * lib/list_sort: do not pass bad pointers to cmp callback
    - LP: #672664
  * ACPI: invoke DSDT corruption workaround on all Toshiba Satellite
    - LP: #672664
  * oprofile: Add Support for Intel CPU Family 6 / Model 29
    - LP: #672664
  * oprofile, ARM: Release resources on failure
    - LP: #672664
  * RDMA/cxgb3: Turn off RX coalescing for iWARP connections
    - LP: #672664
  * drm/radeon/kms: fix bad cast/shift in evergreen.c
    - LP: #672664
  * drm/radeon/kms: avivo cursor workaround applies to evergreen as well
    - LP: #672664
  * ARM: 6400/1: at91: fix arch_gettimeoffset fallout
    - LP: #672664
  * ARM: 6395/1: VExpress: Set bit 22 in the PL310 (cache controller)
    AuxCtlr register
    - LP: #672664
  * V4L/DVB: gspca - main: Fix a crash of some webcams on ARM arch
    - LP: #672664
  * V4L/DVB: gspca - sn9c20x: Bad transfer size of Bayer images
    - LP: #672664
  * mmc: sdhci-s3c: fix NULL ptr acc...

Read more...

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers