Ubuntu

Touchpad recognised as generic PS/2 mouse

Reported by Jonathan Lumb on 2010-11-21
110
This bug affects 21 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xserver-xorg-input-synaptics

It would seem that this bug is similar to the following although on different hardware:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/650529

Dell Inspiron N5030 running Ubuntu Maverick 10.10, kernel 2.6.37-020637rc2-generic.

The touchpad is failing to be recognised as a touchpad and being configured instead as a PS/2 generic mouse. As a consequence, settings such as touchpad sensitivity, scrolling, tapping, multi-touch etc. cannot be altered in the slightest making the touchpad very unresponsive and pretty much useless.

Here are the outputs to a couple of commands that may be useful:

~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Generic Mouse id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Video Bus id=6 [slave keyboard (3)]
    ↳ Power Button id=7 [slave keyboard (3)]
    ↳ Sleep Button id=8 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_0.3M id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=12 [slave keyboard (3)]

lumbfamily@lumb:~$ cat /proc/bus/input/devices

###
#OTHER DEVICES HERE
###

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse0 event6
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

It appears, although not mentioned above, that this Dell model uses an Alps touchpad.

Please can something be done about this bug so that a laptop that offers otherwise full support on Ubuntu can be made even better - this issue seriously affects the usability of this computer under Ubuntu and I suspect it will affect many users as this is a popular model!

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-input-synaptics 1.2.2-2ubuntu5
Uname: Linux 2.6.37-020637rc2-generic i686
NonfreeKernelModules: btrfs zlib_deflate crc32c libcrc32c ufs qnx4 hfsplus hfs minix ntfs vfat msdos fat jfs xfs exportfs reiserfs binfmt_misc parport_pc ppdev snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_seq_midi snd_rawmidi i915 snd_seq_midi_event arc4 drm_kms_helper ath9k snd_seq drm i2c_algo_bit video mac80211 snd_timer snd_seq_device intel_agp intel_gtt snd dell_wmi ath9k_common output ath9k_hw dell_laptop psmouse agpgart ath uvcvideo serio_raw sparse_keymap videodev v4l1_compat cfg80211 soundcore snd_page_alloc lp shpchp parport dcdbas usb_storage ahci libahci atl1c
Architecture: i386
Date: Sun Nov 21 11:47:41 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-input-synaptics
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.37-020637rc2-generic

Jonathan Lumb (jonolumb) wrote :
Gursimran singh (simar) wrote :

As seen in the devices file in the bug description

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
affects: xserver-xorg-input-synaptics (Ubuntu) → linux (Ubuntu)
Gursimran singh (simar) wrote :

Hi Jonathan,

Thanks for reporting the bug and making ubuntu better. The main cause of the bug is already clear in the description, still it would be good if you could upload the main log files especially devices in separate comments as files.

Changed in linux:
status: New → Invalid
Jonathan Lumb (jonolumb) wrote :

Any particular reason why this has been invalid? It seems valid enough to me as I can't change any of the touchpad settings...

Jonathan Lumb (jonolumb) wrote :

Sorry - I wasn't looking closely, still valid for Ubuntu :-)

I will try and get additional log files uploaded soon - this is my parents' new laptop.

Thanks

Gursimran singh (simar) on 2010-11-24
Changed in linux (Ubuntu):
importance: Undecided → Low
Kukman (sergey-kukunin) wrote :

I have same problem in my Acer Aspire 1551. My touchpad recognize as PS/2 Generic Mouse. This is part from /proc/bus/input/devices:

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input8
U: Uniq=
H: Handlers=mouse0 event8
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

Solutions "i8042.nomux" and "modprobe psmouse proto=imps" doesn't works.

uname -r : 2.6.35

Jonathan Lumb (jonolumb) wrote :
Jonathan Lumb (jonolumb) wrote :
John (venoom27) wrote :
Chris Brunner (chris-brunner) wrote :

Is it possible to pay someone to have a bug like this addressed?

MaverickJesterX (markshanley) wrote :

I noticed this is posted as a low priority. Some people depend on this feature. It has become so common place to be able to scroll in this manner now. You can work much more effectively (arguably and depending on your field of course). I have spent a lot of time working on this bug myself on both Ubuntu and Linux Mint 10. I have been unsuccessful and it seems to me it revolves around a proprietary system the way the PS2 mouse and the trackpad interact. The Ubuntu (or Linux Mint) installs are correct in calling the trackpad a PS2 mouse because that is the first mouse seen by the system as there is a PS2 mouse in these sytems (that little nub between G, H and B keys). The problem is once this mouse is seen that is the end. This I believe is because the PS2 is integrated with the trackpad in some way. So until these drivers get open sourced or someone reverse engineers this hardware then I am afraid it will not be fixed. I am especially sad because I have an awesome machine.

Dell E6510
Quad Core
8GB RAM
500 GB Hard drive
"HD Monitor"1920x1080

Not bad for a laptop.

bolee (voriain) wrote :

I have a Dell Precision M4500 64-bit laptop with 16G RAM.
This issue is driving me mad.
Fix please.

Anybody got a workaround?
Even if I could disable the touchpad completely, I'd settle for that.

I am running Linux Mint 10 (Julia) on it

blm14 (blm14) wrote :

I can confirm that this bug persists in Natty A3

[code]
ben@maybeinnovations:~$ uname -a
Linux maybeinnovations 2.6.38-7-generic #39-Ubuntu SMP Fri Mar 25 21:24:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
ben@maybeinnovations:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ImPS/2 ALPS GlidePoint id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Video Bus id=6 [slave keyboard (3)]
    ↳ Power Button id=7 [slave keyboard (3)]
    ↳ Sleep Button id=8 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_0.3M id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=12 [slave keyboard (3)]
ben@maybeinnovations:~$
[/code]

output of dmesg:
http://pastebin.com/zz9YR8wx

Same bug here, I have a Dell Inspiron N4030.
Is anyone trying to solve this?

Atanas Stoyanov (amorphis) wrote :

I have kind of a solution, at least for disabling the touchpad with the button on the keyboard.
I have posted it here: http://ubuntuforums.org/showpost.php?p=10651082&postcount=13
Hope it works for you until a better/permanent solution has been added.

The bug is the touchpad being recognized as PS/2 Mouse, so no, this is not a solution, not even partial, it's a workaround for one of the many many things this bug reflects.
This problem is the only thing that makes Linux a little annoying for me and I hope it will soon be solved.

summary: - Dell Inspiron N5030, Touchpad recognised as generic PS/2 mouse
+ Dell Inspiron N Series, Touchpad recognised as generic PS/2 mouse

This is still present in Ubuntu Natty 11.04.

Whilst the touchpad does now allow vertical scrolling using the right edge of the pad, it's sensitivity still cannot be modified in the Mouse Settings dialogue box and it is listed as ImPS/2 ALPS GlidePoint.

This will be a huge disappointment to people who have recently bought a Dell machine and wish to use Ubuntu.

Jonathan Lumb (jonolumb) wrote :

Correction: the Mouse Settings does in fact now allow the sensitivity and speed to be changed.

So scrolling and speed/sensitivity problems have now been fixed - but the device is still recognised by Ubuntu as a PS/2 mouse which means that there is still no access to certain touchpad-specific settings.

At least the device is usable now!

Geobert Quach (geobert) wrote :

same thing with Acer 1830T

I can tap to click and move cursor but no scrolling (neither vertical or horizontal) and it is detected as PS/2 mouse
Ive posted https://bugzilla.kernel.org/show_bug.cgi?id=35462

Jonathan Lumb (jonolumb) wrote :

@Geobert

Vertical scroll and tap to click are now working in Ubuntu Natty 11.04. Your problem is specific to Archlinux.

Marja Erwin (marja-e) wrote :

Same problem on Sony Vaio E-series in 10.10 and 11.04. Tap-to-click causes the cursor to move erratically while typing.

Fixed on Ubuntu Natty and Mint Katya

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Marja Erwin (marja-e) wrote :

I'm running an up-to-date version of Natty. I'm still having this problem, albeit on a Vaio.

pauljohn32 (pauljohn32) wrote :

I'm running Debian now, but I think this may address your problem (although it may be the "fix" mentioned above is the application of the same patch, I can't tell).

http://pj.freefaculty.org/blog/alps-touchpad-linux-final-statement-now

Brief summary. Install the "psmouse" patch https://patchwork.kernel.org/patch/350841/ following instructions you find here: http://budts.be/weblog/2010/12/dell-latitude-e6510-screen-and-touchpad.

After that, 1) no more random cursor movements while typing 2) tap to click, right side scroll, and doubleclick to grab will work.

Why was it marked as "fix released"? I still can't see the touchpad panel in oneiric, so I can't disable tapping to click.

Miklós György (gymi) wrote :

The "Fix released" status is not correct: I can confirm that the bug still exists in ubuntu 11.10 on a Dell N5040 laptop.

quarara (classic-art-showcase) wrote :

Same here on Dell Inspiron n5110 15R.

Bence Lukács (lukacs-bence1) wrote :

This bug is still present on Precise.
The psmouse-alps-0.10.deb doesn't work for me, I think becasue Precise has a new kernel.
Any idea how can I use this touchpad properly?

Finally working on Precise. The patch in psmouse-alps-0.10.deb should be already in the kernel.

For Alessandro and others who have this working in Precise on an updated kernel: is there something other than installing the kernel upgrade that is necessary to make this work? Is there a config file that must be changed or some other action to take?

Dave Turvene (dturvene) wrote :

I just got a Dell Inspiron 15R, installed precise and updated. The current kernel is 3.2.0-24-generic-pae. The problem still exists, and was frustrating me. I fixed it (hopefully) by following the instructions on this thread to add the ALPS awareness in the psmouse driver:

http://askubuntu.com/questions/104431/how-do-i-enable-multi-touch-on-a-dell-inspiron-n5110-with-an-alps-touchpad

and then tuning the delay using sudo syndaemon -i 2 -k -t -R

It appears to be working much cleaner. It's a tricky problem, and one that many people will like different solutions.

Dave Turvene (dturvene) wrote :

Oh, one thing I should add is that the module_param definition in alps.c:135 gives a compile error. I set alps_dump_packet=1 and commented out #135. I'm not familiar with linux 3 driver frameworks.

quarara (classic-art-showcase) wrote :

Hi, Dave.
I'm glad you've finally sorted out how to make your touchpad work. Unfortunately I don't have enough knowledge to apply the process you're describing in your very latest post. Could you explain it to a digitally illiterate as I am?

Thanks for your support! :)

Dave Turvene (dturvene) wrote :

Well, after a day of testing I think something is still wrong, only less so. I still get occasional spurious focus changes. It only happens when I'm typing really fast. And then the focus changes to where I rested the cursor. Still, it happens a lot less frequently.

@quarara: Yeah, it's a little detailed. Basically, I built a Dynamic Kernel Module for the psmouse driver, taking the source from http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.10/psmouse-alps-dkms_0.10_all.deb
It's the same patch sergiomb discusses. The step-by-step instructions are (taken from an askubuntu post),
MUST USE sudo:

* dpkg -i psmouse-alps-dkms_0.10_all.deb
* cd /usr/src/psmouse-alps-0.10/src
* edit alps.c, copy the line with the Vostros 1400 comment to the end of the array and change 0x73, 0x02 to 0x73, 0x03. This creates a new description for the I15R. BTW, DEBUG is defined so the driver will log to dmesg (/var/log/kern.log on my system)
* dkms add -m psmouse -v alps-0.10, which builds the module. This is where I got the compile error and removed alps.c#136.
* dkms install -m psmouse -v alps-0.10, which installs the new driver
* rmmod psmouse && modprobe psmouse, which removes the old driver and loads the new one
* dmesg for lines beginning with alps.c
* xinput --list to see "PS/2 ALPS GlidePoint"
* syndaemon -i 2.0 -K -R -t to change keystroke to touchpad delay. ALternatively use can use the Settings->Mouse and Touchpad->Touchpad screen, enabled by the ALPS driver, to mess around with this.
* xev to test touchpad and buttons

Complicated, and you need to be somewhat familiar with kernel drivers, but HTH.

Dave

Dave Turvene (dturvene) wrote :

Uggh. In my instructions "dkms add" should be changed to "dkms build".

Also, to rebuild (e.g. add dbg statements), the simplest way is

sudo dkms remove psmouse/alps-0.10 --all

to remove package. "psmouse/alps-0.10" is an alternative to "-m psmouse -v alps-0.10"

Dave

quarara (classic-art-showcase) wrote :

Thank you, Dave. I will try this ASAP. Even thogh I'm not very familiar with the terminal your instructions are very detailed.

Thanks!
Luigi

quarara (classic-art-showcase) wrote :

Hi!
I've tried this and now my system recognizes the touchpad, but, even though there is a new tab to set touchpad parameters, side scroll doesn't work.

My xinput list is as follows:

luigi@luigi-Inspiron-N5110:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Mouse id=12 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS GlidePoint id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=14 [slave keyboard (3)]

I have modified the two lines Dave said as follows:
static int alps_dump_packets = 1;
/* module_param(alps_dump_packets, int, 0644); */

How can I select the Alps GlidePoint as main touchpad?
Thanks in advance!

Luigi

no longer affects: linux (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed

Jonathan Lumb, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

affects: linux (Arch Linux) → linux (Ubuntu)
no longer affects: linux (Ubuntu)
affects: linux → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Invalid → Incomplete
importance: Undecided → Low
summary: - Dell Inspiron N Series, Touchpad recognised as generic PS/2 mouse
+ Touchpad recognised as generic PS/2 mouse
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.