Ubuntu

keyboard doesn't work with acpi on lenovo s10-3c

Reported by Boris Savelev on 2010-11-19
272
This bug affects 49 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
Debian
New
Undecided
Unassigned
Gentoo Linux
Invalid
Medium
linux (Fedora)
New
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
linux (openSUSE)
New
Undecided
Unassigned

Bug Description

When I run linux on my netbook lenovo s10-3c all keys are disabled, numlock, capslock... It's seems like keyboard haven't power.

keyboard works perfectly in bios, in grub (or lilo), in windows, but not in linux.

I try linux kernel 2.6.35, 2.6.36, 2.6.37-rc2 (from Natty) and upgrade BIOS up to 3CCN13WW keyboard doesn't work.

Also I try all variants for kernel opts from https://wiki.ubuntu.com/DebuggingACPI -- keyboard works only with 'noapic acpi=off'

WORKAROUND:
http://s10lenovo.com/viewtopic.php?f=47&t=4482 :
add to kernel opts 'noapic acpi=off'

But battery state, powersaving, powerbutton and other useful things doesn't work.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-22-generic 2.6.35-22.35
Regression: No
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Fri Nov 19 23:09:43 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: linux

Boris Savelev (boris-savelev) wrote :
Boris Savelev (boris-savelev) wrote :
Boris Savelev (boris-savelev) wrote :
tags: added: kernel-input
tags: added: kernel-acpi
Boris Savelev (boris-savelev) wrote :
summary: - keyboard doesn't work with acpi
+ keyboard doesn't work with acpi on lenovo s10-3c
Boris Savelev (boris-savelev) wrote :

hello?

Boris Savelev (boris-savelev) wrote :

/proc/interrupts when kbd doesn't work

Boris Savelev (boris-savelev) wrote :

/proc/interrupts when kbd works

Boris Savelev (boris-savelev) wrote :

screen of kernel panic with acpi=noirq (same with pci=noacpi)

Evgeniy Kulikov (owner-madfox) wrote :

I'm join to Boris. I have the same prb on Lenovo S10-3C.

BTW: If you will turn off wifi in "noapic acpi=off" mode, then touchpad turn off also and it doesn't work any more (the same as wi-fi) until rebot. I think that keyboard also turn off. Some later i will check it too.

Regards, e.

Evgeniy Kulikov (owner-madfox) wrote :

BTW2: in "noapic acpi=off" keyboard is "/dev/input/event0", otherwise it is "/dev/input/event4"

Boris Savelev (boris-savelev) wrote :

I wrote to the linux-acpi and linux-input maillist:
http://www.spinics.net/lists/linux-acpi/msg31008.html

Evgeniy, can you connect to discussion?

Jeremy Foshee (jeremyfoshee) wrote :

Hi Boris,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Evgeniy Kulikov (owner-madfox) wrote :

I tested last kenel that i can to install. It is (v2.6.37-rc3-natty). After it i have to say few points:
1 and GENERAL: keyboard still don't work
2: after disabling bluetooth and wi-fi by hard button on notebook, touchpad still work (it also disabled before this kernel install)
3: after turn off wifi by this button, wifi didn't turn on again by this button (the same as before)

I still must to work in "noapic acpi=off" mode

Boris, i will join discussion asap.

Regards, Evgeniy

Evgeniy Kulikov (owner-madfox) wrote :

BTW: Boris, I will ask you to be a general in this discussion because you started this topic and i haven't so much knowlege about *nix systems. I just will post comments from my side.

Regards, e.

Boris Savelev (boris-savelev) wrote :

thx Evgeniy!

2all:
I also tested last kernel (v2.6.37-rc3-natty and v2.6.37-rc2-maverick)
keyboard still don't work

tags: removed: needs-upstream-testing
Evgeniy Kulikov (owner-madfox) wrote :

I finded on one of the formum this way to make work i8042 kbd on acer aspire. It didn't helps me.

Boris, maybe you will have some results after check it?

Add in xorg.conf:

Section "ServerFlags"
        Option "AllowMouseOpenFail" "true"
        Option "AllowEmptyInput" "False"
        Option "AutoAddDevices" "False"
EndSection

Section "InputDevice"
        Identifier "Keyboard0"
        Driver "evdev"
        Option "Device" "/dev/input/event4" # in my case and i think your too
        Option "CoreKeyboard"
        Option "XkbRules" "xorg"
        Option "XkbModel" "evdev"
        Option "XkbLayout" "us,ru"
        Option "XkbVariant" ",winkeys"
        Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:rwin,grp:switch"
EndSection

Regard, e.

Boris Savelev (boris-savelev) wrote :

Problem not in Xorg.
Problem in kernel.
I test keyboard without Xorg -- in pure test console

Boris Savelev (boris-savelev) wrote :

*text console

Chetan Chauhan (chetan) wrote :

I can confirm the same bug on my Lenovo S10-3C.

The consensus on google is ACPI DSDT problems on this laptop. I tried all kernels upto 2.6.36.1 and still same result no keyboard.

I have attached dmesg ACPI related error log in the hope someone is able to upload a custom dsdt which works for this laptop.

Jay (jskcomputerrepair) wrote :

I can confirm that the following bug is now affecting the lenovo s10-3c

The latest maverick kernel update causes major problems including the following.
System Hanging on shutdown.
Wifi Card issues with the Realtek wifi card.
System stuck forever rebooting.
Also in my case It managed to cause complete system falure due to hard disk corruption.

Here is the bug report for a fyi. Since it also relates to this bug since it is cause by acpi/apic problems. Except on the S10-3t model

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/634702

Jay (jskcomputerrepair) wrote :

Update #1. I have a nasty hack in place that allows you to fix this problem. In other words the keyboard is working with the acpi.

At least I have the keyboard and acpi working at the same time now.

I agree the best way to solve this is a custom DSDT.
That will take a bit of time.
Even better news Its appears from the bios dumps 3g hardware and wifi adapters are hardcoded on which ones will and will not work in the bios.

Quote of the day from Bill Gates.

Bill gates "Heres some money now fix it"
Programmer "Its going to break everyone elses stuff"
Bill gates "Here is some more money now fix it"
Programmer "Its fixed"

Boris Savelev (boris-savelev) wrote :

output of dmidecode

Dmirty Davidenko (dave-28) wrote :

I have same problem

Dmirty Davidenko (dave-28) wrote :

BTW: bluetooth doesn't work too

Eleanor Chen (chenyueg) wrote :

And if ACPI is off, the computer can not be shut down.

Jay (jskcomputerrepair) wrote :

Update #2

Happy holidays to everyone. The problem is located in atkbd.c . It was fixed a long time ago. I will get with them after the new year and see if they will patch it since it affects a project they are working on. If you would like to see both the acpi and the keyboard workiing. The new unbuntu kernel update has issues with these laptops. Use the stock kernel 2.6.35-22-generic add the following to the grub boot line. You need to attach a external keyboard.

apm=power-off nomce vga=771 intel_idle.max_cstate=0

Now once you boot with a external keyboard attached keep tapping the enterkey <This is very important it creates a response from the atkdb which initializes the internal and external keyboard.

It may be a little bit flaky with the unbuntu kernel. Your system may reboot a couple of times. This has been fixed in the test kernel. It works just fine with the stock knoppix 6.2.1 kernel. If you would like to test it out without reinstalling anything.

Regards and happy holidays
Jay

Artem Anischenko (art-xakep) wrote :

I'am confirm bug on Lenovo S10-3C. Problem in kernel. What do it???

The same problem with my S10-3C! The keyboard doesn't work in linux! (with ACPI support)
The kernel was updated. Are there any decisions to fix it?

Dmitry Alexandrov (dimzon541) wrote :

The same problem with my S10-3C! The keyboard doesn't work in linux! (with ACPI support)
Checked both lubuntu 10.10 and CrunchBang 10 “Statler” r20110105

Vladislav Alekseev (vldrus) wrote :

Seems like trouble is specific to 2.6 kernel. I tried kernels 2.4.21 (CentOS 3.9), 2.6.9 (CentOS 4.8), 2.6.18 (CentOS 5.5) - keyboard works only in kernel 2.4 on my S10-3C.

Dmitry Torokhov (dtor) wrote :

Just out of curiosity, does booting with atkbd.reset on the kernel command line gets the keyboard going? (I assume Ubuntu has atkbd built in).

Nikolay Myasnikov (n740xy) wrote :

#31
>does booting with atkbd.reset on the kernel command line gets the keyboard going?
I tried to use this parameter when loaded Fedora 14 and Ubuntu Netbook Remix 10.10, but keyboard was not worked (BIOS version 1.10.)

Vladislav Alekseev (vldrus) wrote :

A little offtopic: freebsd 8.1 have the same trouble :(

Boris Savelev (boris-savelev) wrote :

BTW, I think that our problem is in bad-bad-bad BIOS from lenovo. If interested peoples want to solve this problem they can try to get support directly from lenovo. May be they publish new bios with fixes.

That is just to confirm S10-3C is affected by this issue, with the HW configuration distributed all over the world (no HW/SW parts specifics to Russia). Hope to see the bug fix sooner, rather then latter.

UPD, JFYI: FreeBSD 8.1 doesn't handle the problem well - booting with ACPI leave keyboard inactive, but without ACPI keyboard works like a charm.

Vladislav Alekseev (vldrus) wrote :

Alexander, did you try to install and use FreeBSD without ACPI? I think, if install FreeBSD without ACPI, we will have troubles with battery state and other, like on Linux.

UPD2, JFYI:
- FreeBSD 8.2 RC3 doesn't work with Lenovo S10-3 ACPI;
- latest Knoppix (released Feb 2011) doesn't boot at all;
- Mint Debian (201101) same thing as with Ubuntu / others.

Hi Vlad,

no I don't. As mentioned, ACPI is the key of the issue (with no ACPI OSes are capable to boot and install), but what the heck do I need a notebook without ACPI?! :)

Satana (i-tezi-yandex) wrote :

I'am confirm this bug on my Lenovo s10-3c. Waiting for solution...

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Changed in gentoo:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux (Ubuntu):
assignee: nobody → Serdar (serdar73)
Changed in gentoo:
status: Confirmed → Invalid
Pavel (pavel-ka) on 2011-03-25
Changed in linux:
assignee: nobody → Pavel (pavel-ka)
assignee: Pavel (pavel-ka) → nobody
affects: niceeepc → ubuntu-tn-drafting
grampe (igrampe) on 2011-04-29
Changed in linux (Ubuntu):
assignee: nobody → grampe (igrampe)
status: Confirmed → Incomplete
grampe (igrampe) on 2011-05-14
Changed in linux (Ubuntu):
assignee: grampe (igrampe) → nobody
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
57 comments hidden view all 137 comments
Dmitry Ogorodnikov (dmitrybo) wrote :

Mainly debugged DSDT (0 Errors, 4 Warnings) doesn't improve situation.

Is there any progress in bug fixing? Meego kernel mentioned above doesn't work for me. But I haven't yet tried to build custom kernel with Meego's config.

Also any other free OS I've tried (NetBSD/OpenBSD/FreeBSD/Plan9) is affected by this bug. Windows XP Professional falls in blue screen during setup.

gaf (gaf) wrote :

Hello. I've found a workaround to this bug. If you compile and run as root programm that mentioned here (http://blog.yjl.im/2010/08/disable-laptop-ps2-at-keyboard-i8042.html) - your keyboard will work.

I wish this will help to fix bug in the kernel or through /sys

gaf (gaf) wrote :

And to Russians users: с вас пивас =)

Pavel (pavel-ka) wrote :

It works! Thank you. Just added stuff to my rc.local on ubuntu 10.4. But I have no idea how to send you beer from east siberia :(

Hallelujah, that little program worked! No more lugging around an external keyboard just in case I have to reboot my machine :D

redline (redline-moscow) wrote :

Can anybody write "how to" for ubuntu?

Dmitry Ogorodnikov (dmitrybo) wrote :

How-To is extremely simple and is the same for all distros.
Here it is in ruska: http://help.ubuntu.ru/совместимость/s10-3c#клавиатура

And what about poweroff, is anyone have problems with it or I am doing something wrong?

Sergey Maksimov (e2fsckj) wrote :

Thanks, Dmitry. In Ubuntu 11.04 all work OK, except webcam.
And no problems with poweroff.

Куда пиво завезти?;-)

Kaushik Ghosh (kaushikghosh) wrote :

Can anyone please write a how-to in English for a newbie? Thanks

Yabbarov R.R. (ram-7) wrote :

poweroff dont work with wifi((( may be smbdy know what problem can be with it?

partyzan543 (partyzan543) wrote :

The camera works? On my device with ubuntu 10.04 not working. Solution?

Hi! gaf mentioned above that the work around for keyboard issue was to compile and run as root program that was mentioned in (http://blog.yjl.im/2010/08/disable-laptop-ps2-at-keyboard-i8042.html) and this was the script below;

#include <unistd.h>
#include <sys/io.h>

#define I8042_COMMAND_REG 0x64

int main(int argc, char *argv[]) {
  char data = 0xae; // enable keyboard

  ioperm(I8042_COMMAND_REG, 1, 1);

  if (argc == 2 && argv[1][0] == '0')
    data = 0xad; // disable keyboard
  outb(data, I8042_COMMAND_REG);
  return 0;
  }

I'm a novice and know nothing about script, please help me, can somebody provide a step by step how this program(script)

What the proper step to make so that this program will work? Please help.

Maximino

Save the code as a mmm, "activate_keyboard.c", next do
   gcc activate_keyboard.c -o activate_keyboard
give the binary permissions of execution with
   chmod +x activate_keyboard
and copy activate keyboard to a location, where only root can see it, like /sbin
   sudo cp activate_keyboard /sbin/
Finally, make or edit a boot script to run this program at startup.

Fedor (fgh151) wrote :

https://sourceforge.net/projects/s10-3c-keybdrv/files/ this is link for binary file (pre compiled) an readme

Dmitry Ogorodnikov (dmitrybo) wrote :

> https://sourceforge.net/projects/s10-3c-keybdrv/files/

This says place driver to rc.local.
However, comrades report that driver should be placed to /etc/pm/power.d/ to make keyboard work after sleeping. Isn't it?

The patch works.... at least the keyboard works. Thanks everybody

Kaushik Ghosh (kaushikghosh) wrote :

The webcam works in Linux Mint 11 Katya. The Wi-fi works properly and does not disrupt poweroff in Linux Mint Debian 201101. The webcam too works in Linux Mint Debian 201101.
But even after applying the patch, the keyboard does not work after suspend/hibernate. Anyone has a solution for a newbie? Thanks

partyzan543 (partyzan543) wrote :

Kaushik Ghosh,
Read this post. Do you understand russian language?

http://syslinux.ru/node/1290

SATANA) (i-tezi) wrote :

partyzan543
This is a detailed instruction to WiFi, the keyboard and out of sleep mode to work on the netbook.
Sorry for bad English, wrote a translator.

Pavel (pavel-ka) wrote :

http://syslinux.ru/node/1290 the trick wich acpi/event didn't work properly for me. I added file for example named as 99sleep-keys in /etc/pm/sleep.d/

#!/bin/bash

case "$1" in
 suspend|freeze)
  echo "Sleeping..."
 ;;

 resume|thaw)
 /bin/keys_on #it's a compiled program
 ;;

 *)
 ;;
esac

work's fine for me.

Pavel (pavel-ka) wrote :

Don't forget to make

sudo chmod a+x /etc/pm/sleep.d/99sleep-keys

And about wifi out of the box on ubuntu 10.4 do:

sudo mkdir -p /etc/Wireless/RT2860STA/
sudo touch /etc/Wireless/RT2860STA/RT2860STA.dat
sudo service network-manager restart

the last problem for me with a netbook is a webcam.

Pavel (pavel-ka) wrote :

Not urgent for me, ill just wait till 12.04

Kaushik Ghosh (kaushikghosh) wrote :

Sorry for the delay. Don't know Russian, so I used Google Translate and managed to solve the keyboard problem. Pavel's method did not work for me so I followed the instructions at http://syslinux.ru/node/1290.
Pavel's Wi-fi activation fix did not work either (maybe because my Wi-fi hardware is RT3090). I followed the instructions at http://www.techytalk.info/ralink-rt3090-ubuntu-driver-ppa/ to activate Wi-fi.
But the Bluetooth still isn't working. If anyone knows how to activate it in Ubuntu 10.04/Linux Mint 9 please post.
However, my webcam has worked with every OS so far.
Thanks a lot partyzan543, Pavel, SATANA) and everyone else for all the help.

partyzan543 (partyzan543) wrote :

I'am don't understandr how you used webcamera on this device with Linux Mint 11 Katya? Camera also not working. Cheese and skype says "unable to find device"
Success history anybody?

Sorry for my bad english

Can anybody translate it in spanish? I'm so newbie and I don't understand anything!!!!

diman-k (diman-kv) wrote :

ВСЕМ ПРИВЕТ!!! Я смог решить проблему клавиатуры только после ОБНОВЛЕНИЯ БИОСА!!! МНЕ РЕАЛЬНО ПОМОГЛО!!!!!!!
УДАЧИ ВСЕМ!!!!!

Hello! I was able to solve the problem of the keyboard only after BIOS UPDATE!!!!! ME really helped!!!!!!!
GOOD LUCK!!!!!

http://s-lenovo.ru/forum/viewtopic.php?f=12&t=1514
http://ifolder.ru/25910748

Diman-kv, thank you for your information!
But a one question - how to update my BIOS with linux OS ?
All drivers from lenovo came only in windows binaries (((

Pavel (pavel-ka) wrote :

Stanislav I think you have to load windows somehow. In my case, I have no possibility to do it. Please notify if there any success.

yipidee (aconnolly08) wrote :

For those facing a similar problem under FreeBSD, I compiled a version of the above code and tested it on 9.0-RC3. With ACPI disabled, it functioned like described, but it has no effect when acpi is enabled. I don't know enough about the workings of OSs to hazard a guess as to why it works under Linux but not BSD, but I'd welcome any suggestions for further research.

Dmitry Ogorodnikov (dmitrybo) wrote :

Stanislav, you can use FreeDOS.

Archive with BIOS contains $BIOSVERSION_ReleseNote.doc with corresponding instruction.

You should call Lenovo support and request new BIOS, dont't download it elsewhere, even on Lenovo site, it's not the same.

This may be useful:
http://www.fedora.md/wiki/FreeDOS_%D0%BD%D0%B0_USB_Flash

And yeah, new BIOS works.

description: updated
tags: added: natty needs-upstream-testing
Dmitry Ogorodnikov (dmitrybo) wrote :

What a nasty workaround. Who need a notebook without acpi.
There is a better workaround given by gaf.

But there is no need in workaround, just update your BIOS to version 16 or later.

Let's provide Lenovo's phone in description and close this ticket as invalid.

Boris Savelev, thank you for reporting this and helping make Ubuntu better. Maverick reached EOL on April 10, 2012.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in a supported release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

affects: ubuntu-tn-drafting → null
Changed in null:
status: New → Invalid
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
NIKITA (m-a-nikitooz) on 2012-05-14
Changed in linux (Ubuntu):
status: Incomplete → In Progress

NIKITA, if you are having a problem in Ubuntu, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Changed in linux (Ubuntu):
status: In Progress → Incomplete
Pavel (pavel-ka) wrote :

With vmware client made install of rescue disc from cd, then usb image, booted from usb image with new bios directory, updated bios, keyboard works. Damn you lenovo!

Pavel (pavel-ka) wrote :

Install of rescue disc was made on standalone ubuntu workstation, netbook has no cd drive.

Caza (mihijoeldoctor) wrote :

well, the solution given in #114 it's not working for me.
I think i'm doing every thing, but i still can't use my keyboard.
Maybe there is something i'm missing beacause my poor English, i don't now.

I'll describe step by step what i've done, so please, tell what i'm not doing (or doing wrong).

1.- copy driver file s10-3c-keybdrv-x86-64 to /bin directory

2.- execute on the terminal "chmod +x /bin/s10-3c-keybdrv-x86-64"

3.- add to /etc/rc.local string before exit 0 "/bin/s10-3c-keybdrv-x86-64"

4.- copy "s10-3c-keybdrv.c" to /sbin

5.- reboot

But nothing happen.

Please, i need your feedbak. Thanks.

ps. sorry for my English.

Pavel / Caza, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

Displaying first 40 and last 40 comments. View all 137 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.