Nvidia Accelerated Graphics Driver does not work in Asus N61J laptop with Hybrid Graphics Drivers

Bug #671659 reported by Havard Bjastad on 2010-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

There seems to be a problem getting Ubuntu to use the nvidia card of laptops with hybrid graphics drivers. My Asus N61J has an Intel card and an Nvidia card. For some other Asus models, there is a workaround (which includes changing a hard drive parameter in the BIOS): http://wiki.daviddarts.com/Ubuntu_Maverick_on_the_Asus_UL30VT

This workaround does not work for me. The BIOS option is similar, but not the same, and I tried changing to IDE (which was the only alternative to the default), but no change.

I bought this laptop because I thought nvidia cards were supposed to be a safe choice, if you want to run Linux. But no :(

There is a discussion about the problem here: http://ubuntuforums.org/showthread.php?p=9429844
It indicates that the Intel card can use GLX, but it doesn't work for me. My lspci output is similar to that in the first posting in the thread, with 2 lines of output.

Havard Bjastad (havard-bjastad) wrote :

I forgot to mention, I'm running Ubuntu 10.10 with all packages updated. And the nvidia proprietary driver (as suggested by Ubuntu).

Havard Bjastad (havard-bjastad) wrote :

I have also tried to blacklist i915, as suggested here: http://art.ubuntuforums.org/showthread.php?t=1420377&page=3

Yet another link I came across: http://linux-hybrid-graphics.blogspot.com/

Jeremy Foshee (jeremyfoshee) wrote :

Hi Havard,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 671659

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Havard Bjastad (havard-bjastad) wrote :

Hehe, it's true that there's been no activity, so no surprise the problem is still there!
Was hoping someone would tell me what more information could be provided, or maybe suggest a solution.
I'd love to try out the latest development release of Ubuntu, so I downloaded the live CD for Natty alpha 1. But when I boot from it, it shows the initial boot screen briefly, then the screen goes completely black, and the boot process seems to stop. So, if anything, the situation seems much worse than with Ubuntu 10.10 :(

I don't mind testing an upstream kernel, but I need more specific instructions than what is given at https://wiki.ubuntu.com/Kernel/MainlineBuilds?action=show&redirect=KernelMainlineBuilds
This is new ground to me, so I need to be told specifically which debs to download and install.

Can anybody comment about whether this is SUPPOSED to work? E.g. see the nvidia link i provided. If it's not supposed to work, it's a waste of time testing out different kernels.

Should i run the apport-collect command on my current system? Or is it only valuable after I get a working natty version?

Havard Bjastad (havard-bjastad) wrote :

Is there anybody looking at this issue? Getting Ubuntu to work with recent laptops should be a priority...if we want people to use Ubuntu... :)

See also https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/740397

I've reported my case with similar hardware than you. This is a major issue since Optimus technology is still not supported and almost every new laptop with nVidia graphic cards have this tech with no means of bypassing them.

My report:
Bug #738789

I don't see this fised in the near future, but my findings are that nouveau experimental driver has some gained ground on 3d.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Havard Bjastad (havard-bjastad) wrote :

How very convenient...you avoid processing the bug for 60 days, then you close it as expired :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers