Ubuntu

acpi-cpufreq doesn't set the cpu frequencies right on macbook 2,5

Reported by dentament on 2010-11-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

No matter which governor and/or frequency I set via cpufreq-set, the 2 cores on my macbook 2,5 are always running at the slowest frequency, ie 1.60 ghz, according to cpufreq-info readings *from hardware*.
According to cpufreq-info readings from cpufreq-core, the frequency varies, but it doesn't.
In other terms, "/sys/devices/system/cpu/cpu*/cpufreq/cpuinfo_cur_freq" always reports "1596000" (1.60 Ghz), no matter what "/sys/devices/system/cpu/cpu*/cpufreq/scaling_cur_freq" is reporting.
According to "Documentation/cpu-freq/user-guide.txt":

cpuinfo_cur_freq : Current frequency of the CPU as obtained from
                                the hardware, in KHz. This is the frequency
                                the CPU actually runs at.

scaling_cur_freq : Current frequency of the CPU as determined by
                                the governor and cpufreq core, in KHz. This is
                                the frequency the kernel thinks the CPU runs
                                at.
---
AlsaVersion:
 Advanced Linux Sound Architecture Driver Version 1.0.23.
 Compiled on Sep 27 2010 for kernel 2.6.32-25-generic (SMP).
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gnucco 2620 F.... pulseaudio
CRDA: Error: [Errno 2] Nessun file o directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0x93480000 irq 20'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,106b4a00,00100103'
   Controls : 32
   Simple ctrls : 20
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=5fa322db-6dac-46de-aba5-f367831157d2
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Apple Inc. MacBook5,2
NonfreeKernelModules: wl nvidia
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-25-generic root=/dev/sda3 video=efifb acpi=force ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-25.45-generic 2.6.32.21+drm33.7
Regression: No
RelatedPackageVersions: linux-firmware 1.34.1
Reproducible: Yes
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: lucid needs-upstream-testing
Uname: Linux 2.6.32-25-generic x86_64
UserGroups: adm admin audio cdrom dialout games lpadmin plugdev sambashare vboxusers
dmi.bios.date: 04/16/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB52.88Z.0088.B05.0904162222
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F22788AA
dmi.board.vendor: Apple Inc.
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22788AA
dmi.modalias: dmi:bvnAppleInc.:bvrMB52.88Z.0088.B05.0904162222:bd04/16/09:svnAppleInc.:pnMacBook5,2:pvr1.0:rvnAppleInc.:rnMac-F22788AA:rvr:cvnAppleInc.:ct10:cvrMac-F22788AA:
dmi.product.name: MacBook5,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gnucco 2265 F.... pulseaudio
CRDA: Error: [Errno 2] Nessun file o directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0x93480000 irq 20'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,106b4a00,00100103'
   Controls : 34
   Simple ctrls : 21
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=5fa322db-6dac-46de-aba5-f367831157d2
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Apple Inc. MacBook5,2
NonfreeKernelModules: wl nvidia
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-33-generic root=/dev/sda3 video=efifb ro splash
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-33.72-generic 2.6.32.41+drm33.18
Regression: No
RelatedPackageVersions: linux-firmware 1.34.7
Reproducible: Yes
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: lucid needs-upstream-testing
Uname: Linux 2.6.32-33-generic x86_64
UserGroups: adm admin audio cdrom dialout games lpadmin plugdev sambashare vboxusers
dmi.bios.date: 04/16/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB52.88Z.0088.B05.0904162222
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F22788AA
dmi.board.vendor: Apple Inc.
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22788AA
dmi.modalias: dmi:bvnAppleInc.:bvrMB52.88Z.0088.B05.0904162222:bd04/16/09:svnAppleInc.:pnMacBook5,2:pvr1.0:rvnAppleInc.:rnMac-F22788AA:rvr:cvnAppleInc.:ct10:cvrMac-F22788AA:
dmi.product.name: MacBook5,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

dentament (elledone) wrote :

Is there a kernel parameter to disable acpi-cpufreq module, which is builtin, from loading at boot?
This way I could try and see wether p4-clockmod works instead.

Fabio Marconi (fabiomarconi) wrote :

Hello
can you please run in a terminal
apport-collect -p linux 669865
Thanks
Fabio

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → New
dentament (elledone) wrote :

Note that in order to make linux work with smp and acpi on my Macbook 5,2 I have to boot using grub-efi as a workaround to this other acpi-related bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/341230
https://bugzilla.kernel.org/show_bug.cgi?id=13170
Maybe it's related somehow.

Jeremy Foshee (jeremyfoshee) wrote :

Hi dentament,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 669865

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

dentament (elledone) wrote :

I tried with ubuntu 11.04 and 11.10, same problem.

dentament (elledone) wrote :

I've found out this is not a bug (well, not a linux bug): it's a macbook "hardware feature" (or flaw?: I can't understand why it's set up this way) to lock the 2 cpu cores to minimum speed (1.60ghz) if the battery is not present, as in my case (I removed it since I mostly use the laptop as a desktop and wanted to preserve it).
With the battery mounted, the frequency scaling behaves normally.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.