[ICH4 - Intel ICH6] Dell Latitude D610 - Master mixer doesn't affect headphone output

Bug #669279 reported by Ben Gamari on 2010-11-01
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

The Master mixer does not change the volume from the headphone output (which is affected by the headphone mixer). Instead it only seems to control the on-board speaker volume. This confuses PulseAudio greatly as the Master channel is merged into the volume mix.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-23.36-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ben 14085 F.... alsamixer
                      ben 14546 F.... pulseaudio
 /dev/snd/pcmC0D0p: ben 14546 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'ICH6'/'Intel ICH6 with STAC9750,51 at irq 16'
   Mixer name : 'SigmaTel STAC9750,51'
   Components : 'AC97a:83847650'
   Controls : 38
   Simple ctrls : 24
Date: Sun Oct 31 20:58:40 2010
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SelectedCard: 0 ICH6 ICH4 - Intel ICH6
SourcePackage: alsa-driver
Symptom: audio
Title: [ICH4 - Intel ICH6] Playback problem
dmi.bios.date: 03/02/2005
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0U8082
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd03/02/2005:svnDellInc.:pnLatitudeD610:pvr:rvnDellInc.:rn0U8082:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D610
dmi.sys.vendor: Dell Inc.

Ben Gamari (bgamari) wrote :
Ben Gamari (bgamari) wrote :

On Mon, 01 Nov 2010 01:19:21 -0000, Daniel T Chen <email address hidden> wrote:
> Is there also a LED on this machine that indicates mute status?
>
No.

Can you append the following line to /etc/modprobe.d/alsa-base.conf and reboot?

options snd-intel8x0 ac97_quirk=hp_only

Changed in alsa-driver (Ubuntu):
status: New → In Progress
importance: Undecided → Low
tags: added: patch
Ben Gamari (bgamari) on 2010-11-03
summary: - [ICH4 - Intel ICH6] Dell Latitude D610 - Master mixer doesn't effect
+ [ICH4 - Intel ICH6] Dell Latitude D610 - Master mixer doesn't affect
headphone output
Daniel T Chen (crimsun) wrote :

@Ben Can you try the workaround that I posted in comment 4, please? I attached also a patch that fixes the symptom.

On Wed, 03 Nov 2010 15:09:08 -0000, Daniel T Chen <email address hidden> wrote:
> @Ben Can you try the workaround that I posted in comment 4, please? I
> attached also a patch that fixes the symptom.
>
Sorry about the latency; I haven't had consistent access to the machine
over the last few days. I'll try it when I get back home tonight. Thanks!

- Ben

Ben Gamari (bgamari) wrote :

Finally tested. Volume scales as expected with that quirk. Thanks!

- Ben

David Henningsson (diwic) wrote :

Thanks for reporting back - the patch has now been sent to stable and upstream: http://mailman.alsa-project.org/pipermail/alsa-devel/2010-November/033554.html

Daniel T Chen (crimsun) wrote :
tags: added: patch-accepted-upstream
removed: patch
Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
Ben Gamari (bgamari) wrote :

Thanks!

- Ben

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Brad Figg (brad-figg) wrote :

This patch was applied to Maverick as part of an upstream stable update, therefore it doesn't require individual verification.

tags: added: verification-done
removed: verification-needed

I just reinstalled Maverick and applied all updates. Problem was only corrected when I performed comment #4.

David Henningsson (diwic) wrote :

@Ninjix, this is because this bug isn't released into maverick-updates yet, it's only present in maverick-proposed.

Martin Pitt (pitti) on 2011-02-04
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Andy Whitcroft (apw) on 2011-02-10
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers