Media keys not working in Toshiba Satellite U500

Bug #665918 reported by Schiphol on 2010-10-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: udev

The special media keys in the Toshiba Satellite U500 do not work. Following the instructions in /usr/share/doc/udev/README.keymap.txt.gz I've tried to create a keymap to sort this out (attached), with not very good results:

*The mute key was originally mapped to 'd'. Apparently it is linked to the 'd' key itself, because changing the mapping of this key also changes the mapping of the 'd' key to mute! This makes the keyboard unusable, of course.

* Next/previous track do not work, even with the mapping attached.

* There is a key -supposed to launch the media player- that does not do anything even under sudo /lib/udev/keymap -i input/event3. This key works in Windows.

I'm using Ubuntu 10.10, and udev version 162-2.1

The output of cat /sys/class/dmi/id/sys_vendor is TOSHIBA
The output of cat /sys/class/dmi/id/product_name is SATELLITE U500

Thanks for your help. Cheers,
Manolo

Schiphol (manolo-austrohungaro) wrote :
Martin Pitt (pitti) wrote :

Do you get any different scan code in keymap -i for the 'd' and the 'mute' keys? Which scan code/key code did you get for the media key?

For the next/previous track keys, which key code did you see in keymap -i? With which program did you try it? Rhythmbox handles those well.

Changed in udev (Ubuntu):
status: New → Incomplete
Schiphol (manolo-austrohungaro) wrote :

Martin, thanks for your reply:

> Do you get any different scan code in keymap -i for the 'd' and the 'mute' keys?

I do now... Stupidly, I didn't try when preparing the bug report:

scan code: 0x20 key code: d
scan code: 0xA0 key code: mute

> Which scan code/key code did you get for the media key?

None whatsoever! I find this puzzling, it's as if the key was not connected with anything. As I say, a physical problem is out of the question, because the key launches the WMP in Windows.

> For the next/previous track keys, which key code did you see in keymap -i? With which program did you try it? Rhythmbox handles those well.

scan code: 0x99 key code: nextsong
scan code: 0x90 key code: previoussong

Btw, I've just noticed these codes only appear the second time I press the keys (?). I'm using Rhythmbox, yes; these keys simply block the keyboard and most everything else too.

Thanks again.
Manolo

Martin Pitt (pitti) wrote :

Thanks. I reassign to the kernel, as the keys that do produce a scan code already produce the correct keycode, so from the udev keymaps perspective this is working. The kernel bug is that the "media" key does not produce a scancode.

affects: udev (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New
Schiphol (manolo-austrohungaro) wrote :

Thanks, Martin.

As for the rest of keys (previous/next track, etc.), shouldn't they be tackled to?

Manolo

Schiphol (manolo-austrohungaro) wrote :

"too", I meant :)

Martin Pitt (pitti) wrote :

For previous/next song, you can try putting attached file to /lib/udev/rules.d/95-keyboard-force-release.rules, then do

  echo -e '0x90\n0x99' | sudo tee /lib/udev/keymaps/force-release/local

and then rebooting your machine. Do they work better now?

Jeremy Foshee (jeremyfoshee) wrote :

Hi Schiphol,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 665918

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
amak79 (amak79) wrote :

I know this bug has expired but I would like to provide updated information for anyone still using the Toshiba Satellite U500.

With Ubuntu 13.10 the product name is reported as "Satellite U500" instead of "SATELLITE U500". This breaks the previous fix for the volume keys in Ubuntu bug #271706.

To fix this issue add the following to /etc/udev/hwdb.d/61-satellite-u500.hwdb

# Satellite U500
keyboard:dmi:bvn*:bvr*:bd*:svnTOSHIBA:pn[sS][aA][tT][eE][lL][lL][iI][tT][eE]*[uU]500*:pvr*
 KEYBOARD_KEY_a0=!mute
 KEYBOARD_KEY_ae=!volumedown
 KEYBOARD_KEY_b0=!volumeup

The above hwdb rule should match both "Satellite U500" and "SATELLITE U500".

Now update the hardware database information.

sudo udevadm hwdb --update

The other media keys are still not working as reported in this bug.

amak79 (amak79) wrote :

I erroneously left a line for the mute button in the original 61-satellite-u500.hwdb file and should be removed.

The following is the correct 61-satellite-u500.hwdb file:

# Satellite U500
keyboard:dmi:bvn*:bvr*:bd*:svnTOSHIBA:pn[sS][aA][tT][eE][lL][lL][iI][tT][eE]*[uU]500*:pvr*
 KEYBOARD_KEY_ae=!volumedown
 KEYBOARD_KEY_b0=!volumeup

Furthermore the previous and next media buttons are mapped to hex 0x10 (165) and 0x19 (163). These are the same codes that are used for Q and P respectively so I'm unable to remap them without disabling those keys.

Martin Pitt (pitti) wrote :

amak79, thanks for pointing out! I fixed that upstream in http://cgit.freedesktop.org/systemd/systemd/commit/?id=c79af123de

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers