Comment 16 for bug 665796

I think i have found a fix for my interrupt timer freeze, but need more testing to be sure.

After having tried several kernel boot options without succes (irqfixup, irqpoll, noapic) i ran into this 2 year old thread: https://bugzilla.kernel.org/show_bug.cgi?id=8300 which suggests clocksource=acpi_pm in the last post.

After booting with this option dmesg noted: Override clocksource acpi_pm is not HRT compatible. Cannot switch while in HRT/NOHZ mode, and cat /sys/devices/system/clocksource/clocksource0/current_clocksource still returned: tsc

But strangly enough it did seem te fix the problem. I ran the system for 2x1.5 hours without problems with heavy io and audio/video, which would normally trigger the problem within 15 minutes.
I compared dmesg's and 2 mem ranges seem to be slightly different.

After digging up some more information about clocksource i changed it to hpet, since my bios supports 64bit hpet. And this also seems to work. Running for 3+ hours atm. Seems to be the best option anyway since my bios supports it.

I also tried to disabled hpet in the bios and boot without clocksource, but the problem was still there, but i guess without the option it is not using it as timer as default (yet?).