thinkpad w510 fails to suspend

Bug #664398 reported by Jerome Lacoste on 2010-10-21
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have a new thinkpad w510 and it doesn't suspend at all on ubuntu 10.10 (based off kernel 2.6.35).

When suspending I get to a state where the console is cleared, a cursor blinks on the top left, no more disk activity, wifi light is still on and keyboard is unresponsive.

I am running with nvidia drivers, but even with non proprietary module (nouveau?), I have the same behavior.
I tried suspending from the command line (https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume#Suspending from text mode): same behavior and nothing gets printed on the screen. I removed quiet and slash boot options to see if the pm-suspend in from CLI would display more. Nothing.
I tried without X running, pm-suspend with power-trace to 1, same thing. If I hard reboot and store the dmesg contents I see this:

[ 1.327028] PM: Resume from disk failed.
[ 1.327043] registered taskstats version 1
[ 1.327566] Magic number: 0:990:668
[ 1.327568] hash matches /build/buildd/linux-2.6.35/drivers/base/power/main.c:544
[ 1.327678] rtc_cmos 00:08: setting system clock to 1976-02-18 05:39:35 UTC (193469975)

I also sometimes get
dmesg3.txt:[ 1.321892] Magic number: 0:990:107

Not sure what to do with that.

I tried removing many kernel modules before using pm-suspend, same thing.

I tried acpi_sleep=sci_force_enable, because of: https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/532374/comments/125. No help.

I am going to try the stock kernel now.

More notes:

* thinkwiki page is from 2007 and nothing on w510 or T510
http://www.thinkwiki.org/wiki/How_to_make_use_of_Power_Management_features

* I am aware of: https://bugzilla.kernel.org/show_bug.cgi?id=15407 but this seems different

* I have bios 1.31 (almost latest, latest has according to README only support for newer CPUs).
http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-74858#version

* I haven't found any quirks to play with in hal (such as in https://bugzilla.redhat.com/show_bug.cgi?id=230675 )

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-22-generic 2.6.35-22.34
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jerome 1840 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf2620000 irq 50'
   Mixer name : 'Conexant CX20585'
   Components : 'HDA:14f15069,17aa218b,00100302'
   Controls : 6
   Simple ctrls : 4
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xcdefc000 irq 16'
   Mixer name : 'Nvidia GT220 HDMI'
   Components : 'HDA:10de000a,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6MHT38WW-1.13'
   Mixer name : 'ThinkPad EC 6MHT38WW-1.13'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Thu Oct 21 11:17:26 2010
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=23556b8c-edc7-45b9-a46b-5092d3c49d94
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: LENOVO 431962G
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=6cfff386-814d-4ff9-8634-b82236f89058 ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.38
SourcePackage: linux
dmi.bios.date: 07/27/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6LET66WW (1.31 )
dmi.board.name: 431962G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6LET66WW(1.31):bd07/27/2010:svnLENOVO:pn431962G:pvrThinkPadW510:rvnLENOVO:rn431962G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 431962G
dmi.product.version: ThinkPad W510
dmi.sys.vendor: LENOVO

Jerome Lacoste (jerome-lacoste) wrote :

I've had the same Problem with my Lenovo W510 on Ubuntu 10.10. I think this Bug is not only a duplication of https://bugs.launchpad.net/bugs/522998 . Here are two reasons for my opinion (by the way, I've found a workaround):

1. The USB3.0 module "xhci" mentioned in the bug #522998 was not loaded on my W510 with Ubuntu 10.10 but the module "xhci_hcd" was and has to be unloaded.
2. Unloading "xhci_hcd" was needed, but could not solve the problem at all. Additionaly the module "iwlagn" has to been unloaded. So both modules prevent correct suspending.

The workaround I mentioned above was adding the line 'SUSPEND_MODULES="xhci_hcd iwlagn"' to '/etc/pm/config.d/unload_module'. After this suspending to ram and suspending to disk works fine for me.
Please contact me, if there is a need for additional information about my system and/or configuration.

With kind regards,
Michael Vetter

Edwin Grubbs (edwin-grubbs) wrote :

The fix that Michael Vetter described works for me, namely SUSPEND_MODULES="xhci_hcd iwlagn".

Jerome Lacoste (jerome-lacoste) wrote :

Michael, Edwin:
1. the module has been renamed. So it's normal that the command wasn't sufficient. Check the maverick release notes.
2. my personnal bug report has nothing to do with iwlagn, so it's clearly a duplication of #522998. So please open a particular issue (or find the proper duplicate?) regarding your issue with iwlagn. Maybe here ? https://bugs.launchpad.net/ubuntu/+source/linux?field.searchtext=iwlagn+suspend&orderby=-importance&search=Search&field.status:list=NEW&field.status:list=INCOMPLETE_WITH_RESPONSE&field.status:list=INCOMPLETE_WITHOUT_RESPONSE&field.status:list=CONFIRMED&field.status:list=TRIAGED&field.status:list=INPROGRESS&field.status:list=FIXCOMMITTED&field.assignee=&field.bug_reporter=&field.omit_dupes=on&field.has_patch=&field.has_no_package=

Frank Bicknell (fbicknel) wrote :

The SUSPEND_MODULES="xhci_hcd iwlagn" workaround works for me on my 10.10 + W510.

Thanks!

Jessie Morris (jessieamorris) wrote :

By the way, in Natty (11.04), I had to remove the iwlagn part on the SUSPEND_MODULES while running the newest kernel. If I didn't, Network Manager would sit there saying, "Authorizing" forever.

To post a comment you must log in.